LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-22-2002, 04:03 PM   #1
juggler
LQ Newbie
 
Registered: Oct 2002
Posts: 8

Rep: Reputation: 0
Unhappy /etc/fstab problem


Hello,

I've successfully set up a Win32 /Redhat dual boot situation here at the office.

Using the
#mkdir /mnt/data
#mount /dev/sda5 /mnt/data

I am manually able to mount the Fat32 partition.

When I update the /etc/fstab
with an appropriate /dev/sda5 line and
run a manual
#mount /mnt/data
I am successfully able to mount the Fat32 partition.

However, when I reboot, the reboot
somehow blows away the line I just appended in /etc/fstab
and the /mnt/data directory disappears.

What's going on? How can I remedy this problem?

Thanks.
--juggler
 
Old 10-22-2002, 04:04 PM   #2
juggler
LQ Newbie
 
Registered: Oct 2002
Posts: 8

Original Poster
Rep: Reputation: 0
P.S.

The version of Redhat is 7.3
 
Old 10-22-2002, 05:09 PM   #3
adam_boz
Member
 
Registered: Jul 2002
Location: Santa Cruz, CA
Distribution: lfs
Posts: 538

Rep: Reputation: 30
that sounds really wierd. Are you sure that you saved your /etc/fstab? do:

cat /etc/fstab

and post that here.

the /mnt/data directory DISAPPEARS? that shouldn't happen do

ls /mnt

and see if it's there. You also might need to be doing this:

mount -t vfat /dev/scda5 /mnt/data

and a line like this in /etc/fstab :

/dev/scda5 /mnt/data vfat defaults 0 0

I don't know... that's all I can think of.

good luck

-Adam

Last edited by adam_boz; 10-22-2002 at 05:10 PM.
 
Old 10-22-2002, 08:08 PM   #4
juggler
LQ Newbie
 
Registered: Oct 2002
Posts: 8

Original Poster
Rep: Reputation: 0
New fstab problem

I figured out that if "kudzu" is included anywhere on the /dev/sda5 options, kudzu for whatever reason wipes out
/mnt/data and erases the /dev/sda5 line in our /etc/fstab.

Our /etc/fstab line now
reads:
/dev/sda5 /mnt/data vfat defaults,uid=500,gid=100 0 0

Is there any way we can do a
uid=*,gid=*

or open up the /mnt/data to a multitude of uids (e.g. uid=500-700)? It's kind of a pain to manually enter all UIDs in. I tried simply setting
gid=100

but then the user with uid=500 no longer had access.

Thanks.
 
Old 10-22-2002, 08:30 PM   #5
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Do you want everyone on earth (or at least with an account with access to that computer) to have access to that directory? IF so, remove uid and gid and place:
umask=000

Instead.

Cool
 
Old 10-23-2002, 12:22 PM   #6
juggler
LQ Newbie
 
Registered: Oct 2002
Posts: 8

Original Poster
Rep: Reputation: 0
How about...

That sounds like a nice workaround.

How about allowing just a single group, say the users
group (GID=500) to be able to access /mnt/data? How would I go about doing that?
 
Old 10-23-2002, 01:28 PM   #7
adam_boz
Member
 
Registered: Jul 2002
Location: Santa Cruz, CA
Distribution: lfs
Posts: 538

Rep: Reputation: 30
I don't know how to use fstab for that, but you can do this:

chown -R :500 /mnt/data

and make sure that it has group read/write .... whatever you want


ooh... I forgot it's a vfat partition.... I'm not sure if that'll work, but you can try

good luck

-Adam
 
Old 10-23-2002, 02:56 PM   #8
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Re: How about...

Quote:
Originally posted by juggler
That sounds like a nice workaround.

How about allowing just a single group, say the users
group (GID=500) to be able to access /mnt/data? How would I go about doing that?
What umask does is basically set the chmod. SO a umask of 000 (umask=000) sets a chmod of 777 which means everyone and their dog has all permissions.

So a better way of putting this (and quoting from Acid):
Quote:
so therefore a umask of 333 equates to a chmod of 444 (777-333) which is r--r--r-- in more conventional terms. umask 022 would be rwxr-xr-x (chmod 755) and so on.
from this thread: http://www.linuxquestions.org/questi...threadid=25234

You want to allow full group access, but no one else :
umask=007

What this will set is:
user full perm
group full perm
world (everyone else) no perm

And chown user:group /path/to/folder

This should, I believe set the correct values and abilities for that.

Cool
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
fstab problem: mount: can't find dvd in /etc/fstab or /etc/mtab Nikon01 Slackware 5 11-17-2006 07:15 AM
Fstab problem JackieBrown Debian 3 11-14-2005 06:20 PM
\etc\fstab problem franklampard Linux - Newbie 5 10-03-2005 05:40 PM
/etc/fstab problem mokojin Slackware 8 08-31-2004 01:34 PM
fstab problem marlor Slackware 4 06-30-2004 08:44 PM


All times are GMT -5. The time now is 06:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration