LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Establishing 3D Acceleration for an Intel 945 graphics card in ubuntu 7.10 Guttsy (http://www.linuxquestions.org/questions/linux-newbie-8/establishing-3d-acceleration-for-an-intel-945-graphics-card-in-ubuntu-7-10-guttsy-595193/)

Jason21 10-28-2007 05:58 AM

Establishing 3D Acceleration for an Intel 945 graphics card in ubuntu 7.10 Guttsy
 
Hello guys. I have an Intel 945 graphics card and I'm having some problems stemming from the fact that I haven't set up its 3D acceleration. I know this because of my meddling with Compiz Fusion... I used to run openSUSE, which allowed me to enable 3d acceleration upon installation and Compiz would run perfectly. Now in UBUNTU 7.10 I log into XGL sessions and the GUI lags. Firefox pages scroll down slowly, windows drag even slower, ew. Just ew.

I read this thread but can't say the responses were quite what i am looking for.

Also, in order to at least disable XGL in order to make my gui run smoother until I solve the problem, I followed this guy's advice but there hasn';t been much improvement. The gui doesn't lag as bad as previously, but it's still there.

I also edited my /etc/X11/ xorg.conf file to use an "i810" driver instead of an "intel" one but the only thing it did was lower my resolution from 1280 to 1024.

Any help? =(

Simon Bridge 10-28-2007 11:38 PM

Quote:

Also, in order to at least disable XGL in order to make my gui run smoother
... use the vesa driver instead for this.

Quote:

Now in UBUNTU 7.10 I log into XGL sessions and the GUI lags.
Why are you using XGL? You should be using AIGLX.

I see you have a thread in ubuntuforums too.

From the look of things there, you have been getting very confused. If you really have XGL installed at all, you need to remove it completely. Then you can

dpkg-reconfigure xserver-xorg

Screen resolution thing suggests you need the 915resolution package.

But... why would you go to the trouble installing XGL in the first place? Could it be that you were following that thread you referenced in your post, where the solution was to install xgl ...

That thread is also confused: ashkev claimed good results by installing glx, but later, sumsar claims that disabling xgl was the way to go. dkarnows asserts that uninstalling glx was the way to go.

markballerman posted his experiences - he had your exact symptoms with glx. His solution was to do a fresh install. Others in the thread report that uninstalling X and then reinstalling also fixes the issue.

So it is back to what I was telling you: completely remove glx. You shouldn't have installed it in the first place. It is possible that there are now too many fiddles in your config to troubleshoot successfully from a distance like this...

Jason21 10-31-2007 08:41 AM

I have no idea how my system got through this mess, but I did a fresh installation, made sure that I login automatically before installing the compiz settings manager and rebooting, and my session was never transformed into an XGL session with compiz running super smooth.

Simon Bridge 11-01-2007 11:43 AM

Well done.


All times are GMT -5. The time now is 07:02 PM.