LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-03-2008, 08:33 AM   #1
b_rahulkumar
LQ Newbie
 
Registered: Aug 2008
Posts: 3

Rep: Reputation: 0
Cool Errors with glibc


Hi,

I am getting the below errors when i try to use php and apache to start. Similar kind of errors i am getting when i try to use up2date and wget also. Please advice to fix.


[root@server1 ~]# php -i
php: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /usr/lib/libcurl.so.3)
php: /usr/lib/libnss3.so: version `NSS_3.12' not found (required by /usr/lib/libcurl.so.3)
php: /usr/lib/libk5crypto.so.3: no version information available (required by /lib/libssl.so.4)
php: /usr/lib/libkrb5.so.3: no version information available (required by /lib/libssl.so.4)
php: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /lib/libssl.so.4)

[root@server1 ~]# service httpd start
Starting httpd: /usr/sbin/httpd: /usr/lib/libk5crypto.so.3: no version information available (required by /lib/libssl.so.4)
/usr/sbin/httpd: /usr/lib/libkrb5.so.3: no version information available (required by /lib/libssl.so.4)
/usr/sbin/httpd: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /lib/libssl.so.4)
[FAILED]

Thanks in advance.

Rahul.
 
Old 08-04-2008, 01:36 AM   #2
Uncle_Theodore
Member
 
Registered: Dec 2007
Location: Charleston WV, USA
Distribution: Slackware 12.2, Arch Linux Amd64
Posts: 896

Rep: Reputation: 60
What distribution are you using? Did you install php and apache from your distro's package manager? Or compiled from source? Have you tried to upgrade your system recently?
It looks very much like a glibc version mismatch.
 
Old 08-04-2008, 05:14 AM   #3
immortaltechnique
Member
 
Registered: Oct 2006
Location: Kenya
Distribution: Ubuntu, RHEL, OpenBSD
Posts: 287

Rep: Reputation: 32
If you posted the distro you are running on we could help you further. However i think your gcc installation is conflicting with whatever version you are installing. Please post your distro and what you have been asked by Uncle_Theodore
 
Old 08-04-2008, 07:14 AM   #4
b_rahulkumar
LQ Newbie
 
Registered: Aug 2008
Posts: 3

Original Poster
Rep: Reputation: 0
Hi,

This server is having redhat EL 4 with SMP kernal.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't build glibc 2.4 or 2.5 w/o errors... accp-james Linux From Scratch 4 05-03-2007 05:58 PM
Errors when installing Glibc darkarcon2015 Linux From Scratch 0 11-25-2005 12:26 AM
glibc errors ncsuapex Linux - Software 0 12-20-2004 11:40 PM
glibc - compile errors serg2004 Linux From Scratch 1 11-18-2004 02:52 AM
glibc config errors kudos Linux - Software 2 10-06-2003 01:13 PM


All times are GMT -5. The time now is 01:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration