LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-25-2008, 12:31 PM   #1
allyanncah
LQ Newbie
 
Registered: Sep 2008
Posts: 13

Rep: Reputation: 0
errors installing cairo


I'm trying to install Cairo, which is needed by Pango, which is needed by GTK+ 2.14.3.

I get this error message:
using CFLAGS:
-I/usr/local/include/libpng12 -I/usr/local/include/pixman-1 -Wall -Wextra -Wsign-compare -Werror-implicit-function-declaration -Wpointer-arith -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Wpacked -Wswitch-enum -Wmissing-format-attribute -Wstrict-aliasing=2 -Winit-self -Wunsafe-loop-optimizations -Wdeclaration-after-statement -Wold-style-definition -Wno-missing-field-initializers -Wno-unused-parameter -Wno-attributes -Wno-long-long -Winline -fno-strict-aliasing

configure: error: Cairo requires at least one font backend.
Please install freetype and fontconfig, then try again:
http://freetype.org/ http://fontconfig.org/

I've already installed freetype and fontconfig - what's going on here? Is there something else I need to do?
 
Old 09-25-2008, 12:33 PM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
Probably not finding it in the path when configuring. Are you installing by source I take it? How did you install freetype and fontconfig? What distribution are you running by chance? And what are you passing for the configure options if any? More details get better replies.
 
Old 09-25-2008, 12:37 PM   #3
allyanncah
LQ Newbie
 
Registered: Sep 2008
Posts: 13

Original Poster
Rep: Reputation: 0
Ah, sorry, just frustrated at the moment...

I'm running Novell SLED 10.
Installing by source, freetype and fontconfig also installed via source literally ten minutes ago. I'm not sure what you mean by passing for configure options (which probably means I'm not passing any). I'm still a little backwards on the terminology for just about anything.
 
Old 09-25-2008, 12:42 PM   #4
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
I would imagine you could save yourself a lot of time by just installing the pre-compiled RPM's that SLED 10 probably already has available for download.

Most applications you compile from source you can pass options during ./configure step.
 
Old 09-25-2008, 01:12 PM   #5
allyanncah
LQ Newbie
 
Registered: Sep 2008
Posts: 13

Original Poster
Rep: Reputation: 0
Still running into difficulties; I have pixman but the rpm is insisting that I don't have libpixman-1.so.0, which I'm pretty sure I do considering I installed pixman from source.

can't find the so.0 file itself, either
 
Old 09-25-2008, 01:23 PM   #6
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
Quote:
Originally Posted by allyanncah View Post
Still running into difficulties; I have pixman but the rpm is insisting that I don't have libpixman-1.so.0, which I'm pretty sure I do considering I installed pixman from source.

can't find the so.0 file itself, either
Where is it installing the .so library files at? I'd imagine if you're installing by source, everything might be going into /usr/local/lib or the like where libraries might not be detected. What does your /etc/ld.so.conf include for the directories be included?
 
Old 09-25-2008, 06:06 PM   #7
allyanncah
LQ Newbie
 
Registered: Sep 2008
Posts: 13

Original Poster
Rep: Reputation: 0
Actually, that is where it's going - I see the file here. How do I go about redirecting the appropriate programs to know where these files are?

I'm sorry, I'm very new at this ...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem Installing Limewire - Received Errors While Installing taurusx5 Linux - Software 2 08-05-2008 03:39 AM
pckage "cairo" required by cairo" not found barunparichha Linux - Software 4 06-25-2008 09:29 AM
Problems installing atk and cairo.....need help!!!! geeksdatabase Mandriva 13 02-20-2007 10:40 AM
installing cairo? lilili Linux - Newbie 9 02-01-2006 01:19 PM
The problem about "cairo" in installing of "GTK" :( zhuqlfeixia Linux - Hardware 1 01-28-2006 04:12 PM


All times are GMT -5. The time now is 01:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration