LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-19-2004, 05:32 PM   #1
zoobie
LQ Newbie
 
Registered: Jan 2004
Posts: 5

Rep: Reputation: 0
Errors in Knoppix


Error: No suitable x-server found for your card

After searching here, I typed in: xserver=xf86_w32
It says it can't find it

Now what?

Thanks

Last edited by zoobie; 01-19-2004 at 06:35 PM.
 
Old 01-19-2004, 06:50 PM   #2
scott_R
Member
 
Registered: Jul 2003
Location: Brighton, Michigan, USA
Distribution: Lots of distros in the past, now Linux Mint
Posts: 746

Rep: Reputation: 31
A little more information might be helpful...Like what video card you're using. One thing you might not be aware of is that when Xfree86 went from version 3 to version 4, they dropped some of the more obsolete cards, so if you're running an old machine with a very old video card (5+ years old may qualify, especially if it was lower end back then), then this might be part of the problem, as Knoppix uses Xfree86 version 4.

However, most card should default to their "best" resolution, even if it's as a generic svga card. In fact, try something similar and see if that works.
 
Old 01-19-2004, 07:21 PM   #3
zoobie
LQ Newbie
 
Registered: Jan 2004
Posts: 5

Original Poster
Rep: Reputation: 0
Yes...it's a new box with an old card...a Matrox MGA Ultima/Impression PCI to be exact...

Now what?

Thanks
 
Old 01-19-2004, 10:07 PM   #4
zoobie
LQ Newbie
 
Registered: Jan 2004
Posts: 5

Original Poster
Rep: Reputation: 0
Anyone?
 
Old 01-20-2004, 12:06 AM   #5
zoobie
LQ Newbie
 
Registered: Jan 2004
Posts: 5

Original Poster
Rep: Reputation: 0
Forget it...I'm going to the experts-exchange
 
Old 01-20-2004, 12:11 AM   #6
scott_R
Member
 
Registered: Jul 2003
Location: Brighton, Michigan, USA
Distribution: Lots of distros in the past, now Linux Mint
Posts: 746

Rep: Reputation: 31
From XFree86.org (Matrox hardware support)
---------------------
3.3.6:

Support (accelerated) for the MGA2064W (Millennium I), MGA1064SG (Mystique), MGA2164W (Millennium II) (PCI and AGP), G100, G200 and G400 is provided by the XF86_SVGA server with the mga driver.
4.3.0:

Support (accelerated) for the MGA2064W (Millennium I), MGA1064SG (Mystique), MGA2164W (Millennium II) (PCI and AGP), G100, G200, G400, G450, and G550 is provided by the "mga" driver.
Summary:

All hardware supported in 3.3.6 is also supported in 4.3.0. The G450 and G550 are supported only in 4.3.0.
-------------------

Other things I looked up (mailing lists and such) seemed to indicate that that card was considered old even in mid-1998, and lacking enough users to bother with (at the time, understandably, they were still working to get the basics down). From how it looks, it's simply bad luck. You can still use Linux from the command line, of course, but that's no fun. Perhaps you have another card laying around you can try?
 
Old 01-20-2004, 12:38 AM   #7
zoobie
LQ Newbie
 
Registered: Jan 2004
Posts: 5

Original Poster
Rep: Reputation: 0
Umm...no. However, there is a big used computer show coming up on the 31st of this month in Denver. I guess I'll have to bone up on video cards and buy one there. Thanks
 
Old 04-06-2004, 10:40 PM   #8
oddiofile
Member
 
Registered: Sep 2003
Location: Victoria, BC
Distribution: debian testing
Posts: 43

Rep: Reputation: 15
G550/Knoppix 3.3

So a driver is not necessary to install udner debian? That's good to hear.
I have a Matrox G550 running a Debian Knoppix distro from last month.

I can see stuff on two screens - the problem is, it's the same stuff.
How do I configure Xfree/KDE to display different things on the two screens?
I tried modifying Xfree86Config-4 and adding a Screen2 and a Monitor2 but it didn't seem to work. Is there a guide to setting this up properly?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Knoppix 4.0.2 - HD install - input/output errors on README files and docs kitcatcher Linux - Distributions 3 11-12-2005 11:40 AM
KNOPPIX 4.02 Input/Output Errors nomind Linux - Newbie 2 11-03-2005 11:17 PM
KNOPPIX boot errors, can only get a shell TheMusicGuy Linux - General 2 10-23-2004 06:26 PM
Locales, errors everywhere on Knoppix 3.3 bureado Linux - Newbie 1 10-31-2003 08:03 AM
Fixing HD errors in Knoppix KungFuHamster Linux - General 7 05-01-2003 06:13 PM


All times are GMT -5. The time now is 12:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration