LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-20-2014, 06:12 AM   #1
cycob
LQ Newbie
 
Registered: Mar 2014
Posts: 2

Rep: Reputation: Disabled
Error while installing package!!


You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
gksu : Depends: libgksu2-0 (>= 2.0.8) but it is not going to be installed
wine1.4 : Depends: wine1.4-amd64 (= 1.4.1-0ubuntu7) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
 
Old 03-20-2014, 06:36 AM   #2
s.verma
Member
 
Registered: Oct 2013
Distribution: Debian Sid, Gentoo, Arch, Debian
Posts: 169
Blog Entries: 4

Rep: Reputation: 24
Have you tried
Code:
apt-get -f install
But before, which commands gives you this error.
What was you trying to install?
 
Old 03-20-2014, 08:06 AM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153
@cycob, the install command will usually be :

$ sudo apt-get update && sudo apt-get install <package>

Problems ? Then do $ sudo apt-get -f install
... to fix the issues.

-
 
Old 03-20-2014, 08:18 AM   #4
jamison20000e
Senior Member
 
Registered: Nov 2005
Location: ...uncanny valley... infinity\1975; (randomly born:) Milwaukee, WI, US, Earth, end border$! ◣◢┌∩┐ Fe26-E,e...
Distribution: any GPL that works well on my cheapest, has been KDE or CLI but open... http://goo.gl/NqgqJx &c ;-)
Posts: 3,093
Blog Entries: 2

Rep: Reputation: 840Reputation: 840Reputation: 840Reputation: 840Reputation: 840Reputation: 840Reputation: 840
Hi. I've also found:
Code:
man apt-get
and:
Code:
apt-get clean
to be useful, oh ya:
Code:
man dpkg
http://askubuntu.com/questions/26160...t-dependencies or GUIs best wishes and have fun.

Edit\add: http://www.linuxquestions.org/questi...9/#post5137993

Last edited by jamison20000e; 03-20-2014 at 09:24 AM. Reason: Edit\add: snowpine's post ⇓ made me realise more info is good and think of the link in the link ;)
 
Old 03-20-2014, 08:44 AM   #5
snowpine
Senior Member
 
Registered: Feb 2009
Posts: 4,037

Rep: Reputation: 1099Reputation: 1099Reputation: 1099Reputation: 1099Reputation: 1099Reputation: 1099Reputation: 1099Reputation: 1099
Welcome to the forums cycob!

I see those kinds of errors in Ubuntu all the time. Usually it is for one of two reasons (but we need more info from you):

1. Using an Ubuntu release that is "end of life" and unsupported. Click here to see whether you are using a supported or unsupported release: https://wiki.ubuntu.com/Releases

2. Adding unsupported third-party "repositories" or software sources that are not compatible with your Ubuntu release.

Here is a Terminal command that will give us useful info about your software sources. If you can copy & paste the output from this command, it will help us help you troubleshoot:

Code:
sudo apt-get update
Also, please answer s.verma's questions!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Error Installing Package Whatif Linux - Newbie 2 12-01-2012 03:01 PM
error while installing RPM package sushil_sk Linux - Newbie 2 02-08-2011 01:20 PM
RHEL WS 3 - Error installing package shaifulsafar Linux - Software 3 10-17-2008 08:52 AM
Getting error while installing rpm package payal_shah Linux - General 1 05-10-2007 08:36 PM
Error installing umod package in RH 9.0 althepcman Linux - Software 1 01-27-2004 10:25 PM


All times are GMT -5. The time now is 10:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration