LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-21-2013, 01:00 AM   #1
linuxuday
Member
 
Registered: Mar 2013
Posts: 31

Rep: Reputation: Disabled
Error while installing NS-2.28 on Fedora-17.


Hello,
I am trying to install NS-2.28 on Fedora17.
I had previously installed NS2.33 and NS-2.3 succesfully. I had encounters some errors but found the fixes, mainly those were because of gcc compile version incompatibility.

Now when I'm truing to install NS-2.28 I'm getting following error.

Code:
============================================================
* Build OTcl-1.9
============================================================
No .configure file found in current directory
Continuing with default options...
checking build system type... Invalid configuration `x86_64-unknown-linux-gnu': machine `x86_64-unknown' not recognized
configure: error: /bin/sh ./config.sub x86_64-unknown-linux-gnu failed
otcl-1.9 configuration failed! Exiting ...
Please check http://www.isi.edu/nsnam/ns/ns-problems.html
for common problems and bug fixes.
Please help.
Thanks.
 
Old 03-21-2013, 04:09 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,539

Rep: Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506
Ns2 is for a 32bits OS. 64bits can most often be used, but :
1) Poor validate results. 2) Other issues / troubles.


ns228 / 64bits : Please edit the 'install' script to cheat it to accept 64bit :
Line 473 to : ./configure --build=i686 || die "otcl-$OTCLVER configuration failed! Exiting ...";
Line 498 to : ./configure --build=i686 || die "tclcl-$TCLCLVER configuration failed! Exiting ..."

Fedora : The "install" command is : export CC=gcc34 CXX=g++34 && ./install
( That's also the install command for all other versions, ns2.26..2.34.)


-

Last edited by knudfl; 03-21-2013 at 04:12 AM.
 
Old 03-21-2013, 05:21 AM   #3
linuxuday
Member
 
Registered: Mar 2013
Posts: 31

Original Poster
Rep: Reputation: Disabled
Thanks,

I tried your suggestion but I get following error, I think it is not recognizing the gcc compiler, or do I have to install the compatible gcc first ?

Please let me know what might be the problem, I get following error

Code:
creating cache ./config.cache
checking whether to use symlinks for manpages... no
checking compression for manpages... no
checking for gcc... gcc34
checking whether the C compiler (gcc34  ) works... no
configure: error: installation or configuration problem: C compiler cannot create executables.
tcl8.3.2 configuration failed! Exiting ...
Tcl is not part of the ns project.  Please see www.Scriptics.com
to see if they have a fix for your platform.
Thanks.
 
Old 03-21-2013, 05:27 AM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,539

Rep: Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506
# 3 .
Quote:
checking whether the C compiler (gcc34 ) works... no
C compiler cannot create executables
Yes. You will have to install the compilers. First then they will work.

# yum install compat-gcc-34-c++

All ns2 prerequisites : # yum install \
gcc-c++ compat-gcc-34-c++ automake autoconf make patch libtool libXmu-devel

-

Last edited by knudfl; 03-21-2013 at 05:29 AM.
 
1 members found this post helpful.
Old 03-21-2013, 11:07 AM   #5
linuxuday
Member
 
Registered: Mar 2013
Posts: 31

Original Poster
Rep: Reputation: Disabled
It is not working.

I tried a lot. After installing gcc it shows latest version of gcc is installed. I've also installed the other pre-requisites.

Quote:
# yum install compat-gcc-34-c++

All ns2 prerequisites : # yum install \
gcc-c++ compat-gcc-34-c++ automake autoconf make patch libtool libXmu-devel
And now trying to install it again with unpacked NS2, it is showing following error. what might be the problem now?
Code:
No .configure file found in current directory
Continuing with default options...
checking build system type... Invalid configuration `x86_64-unknown-linux-gnu': machine `x86_64-unknown' not recognized
configure: error: /bin/sh ./config.sub x86_64-unknown-linux-gnu failed.
otcl-1.8 configuration failed! Exiting ...
Please check http://www.isi.edu/nsnam/ns/ns-problems.html
for common problems and bug fixes.
I have installed NS2.33 and NS2.34 on the same Fedora17, so I dont think it needs anymore pre-requisites, those should already be present, right?
Please let me know whats going wrong now.

Many thanks..
 
Old 03-21-2013, 12:06 PM   #6
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,539

Rep: Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506
# 5 .
Quote:
`x86_64-unknown-linux-gnu': machine `x86_64-unknown' not recognized
Did you do the required edits in the 'install' script ?
Please see post #2.
 
Old 03-23-2013, 07:07 AM   #7
linuxuday
Member
 
Registered: Mar 2013
Posts: 31

Original Poster
Rep: Reputation: Disabled
Sorry for late reply.

Yes I have done the changes in 'install' script as you suggested in #2, followed your instructions step by step, still same error
 
Old 03-23-2013, 08:03 AM   #8
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,539

Rep: Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506
# 7.

Same errors ? Shouldn't be possible at all. But other errors will appear.
Seems the otcl etc. got too old? for the 64bits Fedora 17 ?
So we will have to use the alternative method, post # 10 here :
http://www.linuxquestions.org/questi...led-732164/#10
a) tar xvf ns-allinone-2.28.tar.gz && tar xvf ns-allinone-2.34.tar.gz
b) sh script_228.txt
c) cd ns-allinone-2.28/ && export CC=gcc34 CXX=g++34 && ./install
.... Result : No errors.

-
 
1 members found this post helpful.
Old 03-24-2013, 05:27 AM   #9
linuxuday
Member
 
Registered: Mar 2013
Posts: 31

Original Poster
Rep: Reputation: Disabled
You are right 'knudfl'.
I was doing other things in parallel, I got confused. I was getting same error for NS-2.27 installation not NS-2.28 after making changes in 'install' script.
Also, as you mentioned next error was related to OTCL.

I will try the alternate method as you suggested here,
Quote:
so we will have to use the alternative method, post # 10 here :
http://www.linuxquestions.org/questi...led-732164/#10
Thanks a lot for the help.

P.S : Yesterday this website was not opening at all, might be overloaded I'm not sure, so could not see the replies yesterday.
 
Old 04-04-2013, 12:19 AM   #10
linuxuday
Member
 
Registered: Mar 2013
Posts: 31

Original Poster
Rep: Reputation: Disabled
Hi,

I was busy with some other work, had not tried it. Now continuing.

I'm getting the following error now
Code:
rm -f libotcl.so otcl.o so_locations
gcc -c -g -O2 -DNDEBUG -DUSE_SHM -fpic -I. -I/usr/src/ns-allinone-2.28/include -I/usr/src/ns-allinone-2.28/include -I/include  otcl.c
ld -shared -o libotcl.so otcl.o
rm -f libotcl.so
gcc -o otclsh  -g -O2 -I. -I/usr/src/ns-allinone-2.28/include -I/usr/src/ns-allinone-2.28/include -I/include  otclAppInit.c \
-L. -lotcl -L/usr/src/ns-allinone-2.28/lib -ltk8.4 -L/usr/src/ns-allinone-2.28/lib -ltcl8.4 -lXext -lX11  -lnsl -lm
/usr/bin/ld: /usr/src/ns-allinone-2.28/lib/libtcl8.4.a(tclLoadDl.o): undefined reference to symbol 'dlclose@@GLIBC_2.2.5'
/usr/bin/ld: note: 'dlclose@@GLIBC_2.2.5' is defined in DSO /lib64/libdl.so.2 so try adding it to the linker command line
/lib64/libdl.so.2: could not read symbols: Invalid operation
collect2: error: ld returned 1 exit status
make: *** [otclsh] Error 1
otcl-1.9 make failed! Exiting ...
See http://www.isi.edu/nsnam/ns/ns-problems.html for problems
Please help.

P.S : Its NS-2.28 installation on Fedora17.
 
Old 04-04-2013, 01:23 AM   #11
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,539

Rep: Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506
# 10 .

You are using the wrong gcc.
The text says : export CC=gcc34 CXX=g++34 && ./install ( post #8 )
.. which will then use gcc34 / g++34 , not gcc and g++.
 
Old 04-04-2013, 01:34 AM   #12
linuxuday
Member
 
Registered: Mar 2013
Posts: 31

Original Poster
Rep: Reputation: Disabled
Thanks for the quick reply..

I have tried following,
Code:
export CC=gcc34 CXX=g++34 && ./install
and it is showing same error,

Code:
rm -f libotcl.so otcl.o so_locations
gcc34 -c -g -O2 -DNDEBUG -DUSE_SHM -fpic -I. -I/usr/src/ns-allinone-2.28/include -I/usr/src/ns-allinone-2.28/include -I/include  otcl.c
ld -shared -o libotcl.so otcl.o
rm -f libotcl.so
gcc34 -o otclsh  -g -O2 -I. -I/usr/src/ns-allinone-2.28/include -I/usr/src/ns-allinone-2.28/include -I/include  otclAppInit.c \
-L. -lotcl -L/usr/src/ns-allinone-2.28/lib -ltk8.4 -L/usr/src/ns-allinone-2.28/lib -ltcl8.4 -lXext -lX11  -lnsl -lm
/usr/bin/ld: /usr/src/ns-allinone-2.28/lib/libtcl8.4.a(tclLoadDl.o): undefined reference to symbol 'dlclose@@GLIBC_2.2.5'
/usr/bin/ld: note: 'dlclose@@GLIBC_2.2.5' is defined in DSO /lib64/libdl.so.2 so try adding it to the linker command line
/lib64/libdl.so.2: could not read symbols: Invalid operation
collect2: ld returned 1 exit status
make: *** [otclsh] Error 1
otcl-1.9 make failed! Exiting ...
See http://www.isi.edu/nsnam/ns/ns-problems.html for problems
How to use " gcc34 / g++34" ?
What did I do wrong?
 
Old 04-04-2013, 02:06 AM   #13
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,539

Rep: Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506
# 12.
Quote:
What did I do wrong ?
The wrong compiler was used.

Please run 'make distclean' in tcl8.4.18/unix/, tk8.4.18/unix/, otcl-1.13/.
And start again with : export CC=gcc34 CXX=g++34 && ./install

And may be you are using the wrong { tcl tk otcl tclcl } ?
These four must be the "ns-allinone-2.34 versions".

Also : Be aware that the export command is temporary.
Will reset to gcc / g++ when you exit the terminal.

-

Last edited by knudfl; 04-04-2013 at 02:07 AM.
 
Old 04-04-2013, 02:44 AM   #14
linuxuday
Member
 
Registered: Mar 2013
Posts: 31

Original Poster
Rep: Reputation: Disabled
Thanks..

I'm not getting about this line,

Quote:
And may be you are using the wrong { tcl tk otcl tclcl } ?
These four must be the "ns-allinone-2.34 versions".
I'm trying to install NS-2.28, how would files of NS-2.34 would affect? Sorry I didn't get you, please explain.

I tried your suggestion,
Quote:
Please run 'make distclean' in tcl8.4.18/unix/, tk8.4.18/unix/, otcl-1.13/.
And start again with : export CC=gcc34 CXX=g++34 && ./install
but same error occuring

Please guide me how can I install gcc34-permanent installation, and can I have two versions of gcc running at a time ?
 
Old 04-04-2013, 03:54 AM   #15
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,539

Rep: Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506Reputation: 2506
# 14.

Please read this carefully ( # 10 ) :
http://www.linuxquestions.org/questi...led-732164/#10
.. To know what is happening :
The {tcl tk otcl tclcl} in ns-allinone-2.28
is replaced by the {tcl tk otcl tclcl} from ns-allinone-2.34.


Quote:
how can I install gcc34-permanent installation,
and can I have two versions of gcc running at a time ?
1) You can have as many versions of gcc/g++ as you want,
installed at the same time. They all have unique file names : No conflicts.

2) Using : Simply learn how to handle the export command.

-
 
1 members found this post helpful.
  


Reply

Tags
ns228-64bit


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error installing Fedora 16 ceantuco Linux - Newbie 8 01-14-2012 06:02 PM
Installing Fedora 12 getting error when booting Preshv Linux - Laptop and Netbook 2 08-20-2010 02:11 PM
Facing an error while installing Fedora 9 shivoy Linux - General 11 10-24-2008 05:03 AM
error while installing nctuns 4.0 on fedora 7 perfectvijay Linux - Software 1 09-14-2008 01:57 PM
Fedora 4 - installing rpm's - error Xristo Linux - Software 5 01-07-2006 01:40 AM


All times are GMT -5. The time now is 12:33 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration