LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-09-2009, 02:42 AM   #1
prasanthp
LQ Newbie
 
Registered: Mar 2009
Posts: 21

Rep: Reputation: 15
Error while building a package.


while building a package i got this error. Package name is python-gnomecanvas and i am working in debian.



root@boss[gnome-python-2.22.0]#dpkg-buildpackage -r -us -uc -sa
dpkg-buildpackage: source package gnome-python
dpkg-buildpackage: source version 2.22.0-0midboss
dpkg-buildpackage: source changed by Prasanth P <prasanthp@cdac.in>
dpkg-buildpackage: host architecture i386
debian/rules clean
debian/rules:4: /usr/share/gnome-pkg-tools/1/rules/uploaders.mk: No such file or directory
make: *** No rule to make target `/usr/share/gnome-pkg-tools/1/rules/uploaders.mk'. Stop.
dpkg-buildpackage: failure: debian/rules clean gave error exit status 2


I am not able to get it correct.
Can anybody plz help...
 
Old 11-09-2009, 03:15 AM   #2
evo2
LQ Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Mostly Debian and Scientific Linux
Posts: 5,753

Rep: Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288
Looks like you may not have installed the build-depends; ie the packages required to do the build.

On my system /usr/share/gnome-pkg-tools/1/rules/uploaders.mk
is in the gnome-pkg-tools package. To automatically install required packages you can run:
Code:
apt-get build-dep gnome-python
Where gnome-python is the package you want to build.

See: http://www.debian.org/doc/manuals/ap...ml#s-build-dep
for details.

HTH,

Evo2.
 
Old 11-09-2009, 05:21 AM   #3
prasanthp
LQ Newbie
 
Registered: Mar 2009
Posts: 21

Original Poster
Rep: Reputation: 15
hii evo2.. thanks for ur reply..

apt-get build-dep gnome-python is not working for me since i have downloaded that package from other repositary than mine.
 
Old 11-09-2009, 05:40 AM   #4
evo2
LQ Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Mostly Debian and Scientific Linux
Posts: 5,753

Rep: Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288
Ok, so you are trying to backport gnome python bindings?

If could be quite difficult to resolve all the dependencies. What version of Debian are you using and what version of gnome-python do you need?

Evo2.
 
Old 11-11-2009, 12:27 AM   #5
prasanthp
LQ Newbie
 
Registered: Mar 2009
Posts: 21

Original Poster
Rep: Reputation: 15
hello evo2.

I want to build python-gnomeca 2.22.0 and i am using an OS which is Debian flavour, based on Debian lenny.
 
Old 11-11-2009, 12:42 AM   #6
evo2
LQ Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Mostly Debian and Scientific Linux
Posts: 5,753

Rep: Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288
Quote:
Originally Posted by prasanthp View Post
I want to build python-gnomeca 2.22.0 and i am using an OS which is Debian flavour, based on Debian lenny.
Sorry don't know what python-gnomeca is. All I can suggest is that you install the packages that provides the files it needs to compile. If you have trouble finding what packages provide what files, you can try using the apt-file command (in the apt-file pacakge).

EVo2.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Building a Slackware package... Alexvader Slackware 3 10-21-2009 05:00 PM
RPM Package building harish.patel Linux - Newbie 2 12-26-2008 12:57 AM
Yum Error: Transaction Check Error package x(which is newer than package y)... godsk Linux - Newbie 0 06-05-2006 08:13 AM
Error in building glibc2.3.2---using lfs-package-5.0 oldmanpushcar Linux From Scratch 0 04-19-2005 09:55 AM
package building dockpunk Slackware 10 03-23-2005 10:46 AM


All times are GMT -5. The time now is 01:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration