LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-20-2004, 08:01 AM   #1
Thaidog
Member
 
Registered: Sep 2002
Location: Hilton Head, SC
Distribution: Gentoo
Posts: 637

Rep: Reputation: 32
Question Error when trying to install GIMP 2.0


I got the following error when trying to ./configure GIMP 2.0:

checking for libart-2.0... Package libart-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libart-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libart-2.0' found

configure: error: Library requirements (libart-2.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
Punisher:~/gimp-2.0.0 #checking for libart-2.0... Package libart-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libart-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libart-2.0' found

configure: error: Library requirements (libart-2.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
Punisher:~/gimp-2.0.0 #

I know I have a libart-2.0 package... but what do I need to do here to make it visible?
 
Old 09-20-2004, 10:44 AM   #2
mhearn
LQ Guru
 
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 47
You need to install the development files. Or use a binary.

Using a binary would be easier.
 
Old 09-20-2004, 12:11 PM   #3
Thaidog
Member
 
Registered: Sep 2002
Location: Hilton Head, SC
Distribution: Gentoo
Posts: 637

Original Poster
Rep: Reputation: 32
Quote:
Originally posted by mhearn
You need to install the development files. Or use a binary.

Using a binary would be easier.
Well I'm trying to compile for smp... i've got a dual athlon. So what development files do I need to install? I've already got gcc and libraries installed on my system...
 
Old 09-21-2004, 09:09 AM   #4
mhearn
LQ Guru
 
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 47
You don't need to compile for SMP, or shouldn't do. How you install the developer tools varies from distro to distro, on Fedora you just check the boxes in Add/Remove Packages.

Are you *sure* you need to compile? Gimp will use multiple processors with no special compiling necessary.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
gimp error korotania Linux - Software 1 11-26-2005 02:44 AM
error with gimp vivek_nz76 Fedora 1 04-16-2005 05:10 AM
Gimp 2.0 Error LinuxBlackBox Linux - Software 3 04-23-2004 05:27 PM
Gimp 2.0 libart-2.0 compile error darin3200 Linux - Software 7 04-12-2004 07:32 PM
The Gimp: Segmentation Fault error Mega Man X Linux - Software 8 10-04-2003 08:07 PM


All times are GMT -5. The time now is 03:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration