LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Error when running example on ns-2.33 (http://www.linuxquestions.org/questions/linux-newbie-8/error-when-running-example-on-ns-2-33-a-936417/)

vip2442 03-25-2012 11:59 PM

Error when running example on ns-2.33
 
Hi There,

I have ns-2.33 patched with lte on Ubuntu 11.10.
When I try to run example "web-traffic.tcl" I get the following message ?

Code:

user@ubuntu:~/ns-allinone-2.33/ns-2.33/tcl/ex$ ns web-traffic.tcl
Invalide class id in DropTail::enque, Packet's class id is 4

Could you please tell me how to solve that error and if there are example for lte I can run and study ?

Thank You

knudfl 03-26-2012 03:03 AM

Quote:

ns web-traffic.tcl
Invalid class id in DropTail::enque, Packet's class id is 4
Default files are not supposed to work with an LTE patched 'ns'.
You will have to use a binary 'ns' from an unpatched ns-2.33.
The "ns-LTE" binary will work with dedicated "lte.tcl" files only.


A random 'ns<233>' will work OK. Example : /usr/local/bin/ns233-el5 :
$ ns233-el5 web-traffic.tcl : The nam window opens OK.

( ns233-el5 is a binary once created on CentOS 5.)
You can have as may binary ns versions as you want,
just rename ns to a recognizable name.
https://docs.google.com/open?id=0B7S...bjdMNUxheHFLUQ

.

vip2442 03-26-2012 05:37 PM

Thanks a lot it worked perfectly

Code:

user@ubuntu:~/ns-allinone-2.33/ns-2.33/tcl/ex$ sudo /home/user/ns-allinone-2.33/ns-2.33/ns233 web-traffic.tcl
running nam...


knudfl 03-26-2012 05:42 PM

One thing :
"sudo /home/user/ns-allinone-2.33/ns-2.33/ns233 web-traffic.tcl"

'sudo' is not required for any ns2 files, when ns2 is located in /home//.
May cause some troubles.

knudfl 03-26-2012 06:15 PM

1 Attachment(s)
Quote:

... if there are example for lte I can run and study ?
Besides the file lte.tcl in ns-2.33/lte-model-read-only ,
... I have another one : eyana.tcl , which works OK.
http://www.linuxquestions.org/questi...930/page3.html
> post # 42.
.

vip2442 03-26-2012 09:19 PM

Thank you so much for all these information.

The example you attached and example "simple-rtp.tcl" are giving me these warnings?
is there a way to fix that? should I worry about them ?

Code:

user@ubuntu:~/ns-allinone-2.33/ns-2.33/tcl/ex$ ns simple-rtp.tcl
warning: no class variable Session/RTP::debug_

        see tcl-object.tcl in tclcl for info about this warning.

warning: no class variable Session/RTP::debug_

        see tcl-object.tcl in tclcl for info about this warning.

warning: no class variable Session/RTP::debug_

        see tcl-object.tcl in tclcl for info about this warning.

warning: no class variable Session/RTP::debug_

        see tcl-object.tcl in tclcl for info about this warning.

Invalide class id in DropTail::enque, Packet's class id is 30
user@ubuntu:~/ns-allinone-2.33/ns-2.33/tcl/ex$


knudfl 03-27-2012 02:51 AM

# 10 :

'simple-rtp.tcl' is not an lte file. Use the "unpatched ns binary".


'eyana.tcl' : The warnings doesn't really matter. Not errors.
( There may be a work around, that I don't know about.)

.

Farf 04-09-2013 10:29 AM

Invalide class id in DropTail::enque, Packet's class id is 30
 
Hi!
I have a problem when compile the lte.tcl.
The error that appears is:
warning: no class variable Session/RTP::debug_

see tcl-object.tcl in tclcl for info about this warning.

Invalide class id in DropTail::enque, Packet's class id is 30
someone knows how to help me??
Thank you!

knudfl 04-09-2013 11:48 AM

Post # 8, @Farf : Welcome to LQ.

'lte.tcl' : Please use an edited "lte.tcl", like eyana.tcl :
The file is attached to post # 5.
If $ 'ns eyana.tcl' fails : You have a corrupt build.

LTE examples : lte-examples-0213.tar.gz
https://docs.google.com/file/d/0B7S2...it?usp=sharing

All LTE at LQ : http://www.linuxquestions.org/questions/tags/lte/

-

sfsfajri 03-13-2014 12:39 AM

invalid ID
 
Hello..
I'm still having a problem when running eyana.tcl
there are some warning, but in the last line on warning there is a message:
Invalide class id in DropTail::enque, Packet's class id is 30
when I try run lte.tcl I got these message:

All the UEs are empty in DLS1Queue!
UE 9 is demarked in DLAirQueue.
UE 4 is demarked in DLAirQueue.
DLQueue::deque(), all the queues are empty, no packet to be sent.
UE 5 is demarked in DLAirQueue.
All the UEs are empty in DLS1Queue!
UE 6 is blocked in DLS1Queue.
All the UEs are blocked in DLS1Queue!
UE 11 is demarked in DLAirQueue.
UE 6 is blocked in DLS1Queue.
UE 10 is blocked in DLS1Queue.
All the UEs are blocked in DLS1Queue!
invalid classid 30


I'm using ns2.33 ubuntu 12.04 (64bit).
I hope anyone can help me solve this, I really need it for my project.
thank you

knudfl 03-13-2014 07:01 AM

Post #10, @sfsfajri : Welcome to LQ.

Generally : All ns2 is for a 32bits (i686) OS.
Some versions / patches / modifications will however also work with 64bits.
( You will always get an inferior validate result with 64bits.)

LTE has been done with 64bits : Works in Slackware64 - 13.37 →
See the LTE threads → http://www.linuxquestions.org/questions/tags/lte/
** But : No guaranty that anything ns2 will work well with Ubuntu 12.04 - 64.

-

sfsfajri 03-13-2014 08:29 AM

Okay, I'll try that one.
and thanks for helping me.

sfsfajri 03-18-2014 12:05 AM

dear sir knudfl
I have a question, is it possible to make UE become mobile using LTE patch?
if it possible could you make an example in tcl file
because I'm still a newbie, and I tried to make it and it goes to error.
thanks a lot

knudfl 03-18-2014 04:59 AM

# 13 .
Quote:

.. is it possible to make UE become mobile using LTE patch ?
I don't think I know what UE is.
And "make UE become mobile" is probably beyond my knowledge.

Please try asking at http://network-simulator-ns-2.7690.n7.nabble.com/
.. and https://groups.google.com/forum/?fro...forum/ns-users

-

sfsfajri 03-18-2014 05:03 AM

I mean to make a mobile node, not a static node
is it possible?


All times are GMT -5. The time now is 04:12 AM.