LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-22-2006, 08:07 PM   #1
Robert Diggs
Member
 
Registered: Dec 2006
Location: Florida
Distribution: The ones that come in magazines and books.
Posts: 136

Rep: Reputation: 15
Error saving to FAT32 partition


Here is the next installment of my epic story,

With the help of you gracious people I have been able to create, format and mount my 30GB VFAT hard drive. Now, when I attempt to write to it, I get an error saying 'Saving using protocol 'media' not allowed." I've tried tinkering around with the fstab file, using different options and I've gotten the same result each time. I tried changing the permissions and same thing. I've even looked online and haven't found a solution. Any help you provide is greatly, greatly appreciated.

Thanks,

Brandon

p.s. When I was finally able to mount it, I got a new drive showing up in My Computer an (x) unmounted drive. This just came up out of nowhere. I don't if this is affecting my writing capabilities to the drive.

Last edited by Robert Diggs; 12-22-2006 at 08:09 PM.
 
Old 12-22-2006, 09:57 PM   #2
blackhole54
Senior Member
 
Registered: Mar 2006
Posts: 1,896

Rep: Reputation: 61
More Info Please

It sounds like you have previously received help on a different thread related to this issue. It might be helpful to provide a link to that thread so we can see what has already transpired.

Also, please post what distro you are using, what exactly you are doing when you get this error, and the contents of your /etc/fstab file.
 
Old 12-22-2006, 10:22 PM   #3
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Rep: Reputation: 49
My guess is since fat32 is a crap filesystem that doesn't support *nix style permissions, you probably need to be root to write to it, unless you got fancy with the mount command. Try creating a file on it as root. That should work if I am correct. I haven't played with fat32 in years.

Peace,
JimBass
 
Old 12-22-2006, 11:14 PM   #4
blackhole54
Senior Member
 
Registered: Mar 2006
Posts: 1,896

Rep: Reputation: 61
Quote:
Originally Posted by JimBass
you probably need to be root to write to it, unless you got fancy with the mount command.
On my system, trying to write to FAT32 w/o permission just gives the standard "Permission denied".

You can use uid=, gid=, and umask= either with the mount command (when done as root) or in /etc/fstab to establish permissions. This then determines ownership and permissions on every file and directory in the file system.
 
Old 12-23-2006, 09:01 AM   #5
Robert Diggs
Member
 
Registered: Dec 2006
Location: Florida
Distribution: The ones that come in magazines and books.
Posts: 136

Original Poster
Rep: Reputation: 15
Sorry about not giving more information, I know better. Jim, I actually tried logging into the system as root and it does not allow me to save to it. Blackhole, I'm using SUSE 10.0. I'm just trying to save a file in Linux to this drive that is being shared with Windows XP. All I'm doing is saving a simple text file to the drive media:/dev/hda7/Linux and it says "Saving using protocol 'media' not supported. After posting the initial cry for help last night, I came back to it and made an observation... on my hda6 drive (the root for Linux) it generates the SAME error. However, when a path you're saving to doesn't include the word 'media' you can save to it. Such as the desktop. Maybe that's an indication of my problem? I only remember the line for my hda7 drive in my fstab file (because I entered it myself) and that is:

/dev/hda7 /mnt/osshare Vfat defaults 0 0

I've tried different items with the 'options' portion of the file such as: user,rw,auto (all of those at once and just defaults. Let me know if I can provide any more information.

Thanks,

Brandon

Last edited by Robert Diggs; 12-23-2006 at 09:03 AM.
 
Old 12-23-2006, 09:07 AM   #6
itz2000
Member
 
Registered: Jul 2005
Distribution: Fedora fc4, fc7, Mandrake 10.1, mandriva06, suse 9.1, Slackware 10.2, 11.0, 12.0,1,2 (Current)]
Posts: 732

Rep: Reputation: 30
a. never log in as root.
b. I think it's like ntfs where you must reconfigure your kernel so you'll have writing permissions into fat32.
c. also, don't load fat32 drive as ro
 
Old 12-23-2006, 09:10 AM   #7
Robert Diggs
Member
 
Registered: Dec 2006
Location: Florida
Distribution: The ones that come in magazines and books.
Posts: 136

Original Poster
Rep: Reputation: 15
I know of the golden rule to never log in as root, but I was desperate and I'm not worried about anyone getting access to my computer. I'm not that stupid. If I do have to reconfigure my kernel, what are the steps necessary? It sounds like a daunting task. I've heard of people doing this with absolutely no problem (just loading a fat32fs and being able to immediately write to it). Not sure why I'd be a special case, but anything is possible.

Thanks,

Brandon
 
Old 12-23-2006, 09:22 AM   #8
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
I have NEVER had to do anything to a kernel in order to access a FAT32 partition.

Here is maybe the heart of the matter:
Quote:
All I'm doing is saving a simple text file to the drive media:/dev/hda7/Linux and it says "Saving using protocol 'media' not supported. After posting the initial cry for help last night, I came back to it and made an observation... on my hda6 drive (the root for Linux) it generates the SAME error. However, when a path you're saving to doesn't include the word 'media' you can save to it.
If you want to copy a file to this partition--mounted at /mnt/osshare--you would do something like:
cp <filename> /mnt/osshare
Does that work?
In the GUI, can you simply drag an icon to the folder?
 
Old 12-23-2006, 09:23 AM   #9
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
It might help if you say what exactly you're using to try and save files to the partition. Also, you shouldn't be using "/dev/hda7", you should be using the mount point, i.e. "/mnt/osshare". Can you write to that partition in the terminal?

A bit OT, but meh: Wu-Tang fan are we?
 
Old 12-23-2006, 09:33 AM   #10
Robert Diggs
Member
 
Registered: Dec 2006
Location: Florida
Distribution: The ones that come in magazines and books.
Posts: 136

Original Poster
Rep: Reputation: 15
Nylex,

Yes, I am a Wu fan. I never thought someone would know that. I use it as an alias sometimes. I have not tried using the terminal to put any files on that drive. Pixellany, I have tried dragging files to the drive in the GUI and no dice. I will trying using the copy command in terimnal and I'll let you know how that works out. I've also tried saving a file with this path /mnt/osshare/ and saving the file there and no luck either.

Thanks,

Brandon
 
Old 12-23-2006, 09:42 AM   #11
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
I use fat16, fat32, ntfs and Ext3 everyday and cannot believe people can equate it as restrictive as writing a ntfs filing system.

In a nutshell if you can log in as root to a desktop with the partition mounted the files can be transferred by "drag and drop". It is the system's duty to convert the file from one format to another.

If your fat32 partition say is hda12 these will work in any Linux root terminal
Code:
mkdir /mnt/hda12
mount /dev/hda12 /mnt/hda12
Thereafter you can kick the files like footballs in the desktop or a Bash shell. Modern Linux don't even need its filing type to declared when being mounted. The fat32 files in this case is in /mnt/hda12 as a general case. The poster information should be available in /mnt/osshare

The only problem I could think of is fat32 supports a maximum file size of 4Gb so Linux will be in distress if you push it to drop a file bigger than 4Gb into a fat32 partition because technically the fat32 system cannot take it. It it does the data is not readable elsewhere and be totally reliable.

Last edited by saikee; 12-23-2006 at 09:45 AM.
 
Old 12-23-2006, 09:26 PM   #12
blackhole54
Senior Member
 
Registered: Mar 2006
Posts: 1,896

Rep: Reputation: 61
Quote:
Originally Posted by Robert Diggs
After posting the initial cry for help last night, I came back to it and made an observation... on my hda6 drive (the root for Linux) it generates the SAME error. However, when a path you're saving to doesn't include the word 'media' you can save to it. Such as the desktop. Maybe that's an indication of my problem?
I agree with pixellany that the above is likely the heart of the matter. But I am confused. Part of this may be because I am running old software on old hardware (something I hope to be remedying soon ). But I don't understand how the word "media" is (apparently, to me) being arbitrarily inserted into path names. But I do wonder if it isn't a keyword that initiates some kind of special treatment.

I did some searching on the Internet, but didn't really find anything definitive. One thing lead me to wonder if it could have something to do with HAL, but that was only a hint that never panned out for me. Maybe more exhaustive searching would reveal something ... (You're on your own there!)

Assuming the capital "V" on "Vfat" was an error because you were posting from memory, your fstab entry looks OK to me.

If you still haven't sovled this problem, maybe you could post the output of the mount command?

I am confident that the stock Suse kernel would have the support you need for vfat. On my system, the only modules loaded for this are fat and vfat. There is no special kernel compilation needed to enable writing. (I don't know what the current situation is, but historically there have been some issues with NTFS on Linux because the developers have to reverse engineer the format specs, and it is a moving target -- changing again with MS Windows Vista. For this reason, writing to NTFS from Linux has frequently been disabled by default because it was risky. But there has never been such an issue with FAT because the format is well known and stable.)

Last edited by blackhole54; 12-23-2006 at 09:28 PM.
 
Old 12-26-2006, 03:39 PM   #13
Robert Diggs
Member
 
Registered: Dec 2006
Location: Florida
Distribution: The ones that come in magazines and books.
Posts: 136

Original Poster
Rep: Reputation: 15
Thanks,

Using the terminal remedies my problem. Just the fact that I can't do it within the GUI is pretty annoying, but I can live with it.

Thanks,

Brandon
 
Old 12-26-2006, 07:10 PM   #14
dinojerm
Member
 
Registered: Apr 2004
Location: NJ,US
Distribution: Debian Sid
Posts: 33

Rep: Reputation: 15
If you access it from the GUI (KDE), make sure you are using the full path (/mnt/osshare), not one using media:/ (maybe that is what caused the "Saving using protocol 'media' not allowed." error)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to format to FAT32, and how to mount my FAT32 partition. bonniehandi Linux - Newbie 16 03-05-2006 08:54 PM
Error creating shared FAT32 partition robalo Linux - Newbie 1 07-13-2004 07:42 PM
Partition mounting/KDE errors after creating Fat32 Partition BertBert Linux - General 1 07-07-2004 11:59 AM
Mounting fat32 partition... wierd error msg. Wraith2288 Linux - Software 22 01-09-2004 09:01 AM
Should be Simple: RH9 Error mounting FAT32 partition lsgko Linux - Newbie 2 08-16-2003 07:24 AM


All times are GMT -5. The time now is 07:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration