LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-22-2014, 01:17 AM   #1
TheIndependentAquarius
Senior Member
 
Registered: Dec 2008
Posts: 4,680
Blog Entries: 29

Rep: Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917
error: Package Qt5GStreamer-0.10 not found


The auto generated .pro file contains:

Code:
# This is a qmake project file, provided as an example on how to use qmake with QtGStreamer.

TEMPLATE = app
TARGET = qmlplayer

# produce nice compilation output
CONFIG += silent

# Tell qmake to use pkg-config to find QtGStreamer.
CONFIG += link_pkgconfig

# Now tell qmake to link to QtGStreamer and also use its include path and Cflags.
contains(QT_VERSION, ^4\\..*) {
  PKGCONFIG += QtGStreamer-0.10 QtGStreamerUi-0.10
}
contains(QT_VERSION, ^5\\..*) {
  PKGCONFIG += Qt5GStreamer-0.10 Qt5GStreamerUi-0.10
  QT += widgets
}

# Recommended if you are using g++ 4.5 or later. Must be removed for other compilers.
#QMAKE_CXXFLAGS += -std=c++0x

# Recommended, to avoid possible issues with the "emit" keyword
# You can otherwise also define QT_NO_EMIT, but notice that this is not a documented Qt macro.
DEFINES += QT_NO_KEYWORDS

# link against QtDeclarative and QtOpenGL
QT += declarative opengl

# Input
HEADERS += player.h
SOURCES += main.cpp player.cpp
RESOURCES += qmlplayer.qrc

.bashrc
Code:
export PATH=/opt/Qt5.1.0/5.1.0/gcc_64/bin/:$PATH
export PKG_CONFIG_PATH=~/Desktop/newGSTr/qt-gstreamer-0.10.3/lib/x86_64-linux-gnu/pkgconfig/:$PKG_CONFIG_PATH
Code:
:~/Desktop/newGSTr/qt-gstreamer-0.10.3/lib/x86_64-linux-gnu/pkgconfig$ ls

Qt5GLib-2.0.pc        Qt5GStreamerUi-0.10.pc
Qt5GStreamer-0.10.pc  Qt5GStreamerUtils-0.10.pc
Code:
~$ locate Qt5GStreamer-0.10

.../Desktop/backupqt-gst/lib/x86_64-linux-gnu/libQt5GStreamer-0.10.so
.../Desktop/backupqt-gst/lib/x86_64-linux-gnu/libQt5GStreamer-0.10.so.0
.../Desktop/backupqt-gst/src/Qt5GStreamer-0.10.pc
.../Desktop/qt-gstreamer-0.10.3/lib/x86_64-linux-gnu/libQt5GStreamer-0.10.so
.../Desktop/qt-gstreamer-0.10.3/lib/x86_64-linux-gnu/libQt5GStreamer-0.10.so.0
.../Desktop/qt-gstreamer-0.10.3/lib/x86_64-linux-gnu/libQt5GStreamer-0.10.so.0.10.3
.../Desktop/qt-gstreamer-0.10.3/lib/x86_64-linux-gnu/pkgconfig/Qt5GStreamer-0.10.pc
.../Desktop/qt-gstreamer-0.10.3/src/Qt5GStreamer-0.10.pc
.../Desktop/qt-gstreamer-0.10.3/src/QGst/libQt5GStreamer-0.10.so
.../Desktop/qt-gstreamer-0.10.3/src/QGst/libQt5GStreamer-0.10.so.0
.../Desktop/qt-gstreamer-0.10.3/src/QGst/libQt5GStreamer-0.10.so.0.10.3
/usr/lib64/libQt5GStreamer-0.10.so
/usr/lib64/pkgconfig/Qt5GStreamer-0.10.pc
Code:
sudo apt-get install libgstreamer0.10-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libgstreamer0.10-dev is already the newest version.
The following packages were automatically installed and are no longer required:
  language-pack-kde-en kde-l10n-engb language-pack-kde-en-base
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 89 not upgraded.

What's the point that I am missing? Yes, I ran ldconfig too from root.

Last edited by TheIndependentAquarius; 01-22-2014 at 01:28 AM.
 
Old 01-22-2014, 05:43 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016 CentOS6.9 CentOS7.3 + 50+ other Linux OS, for test only.
Posts: 16,657

Rep: Reputation: 3281Reputation: 3281Reputation: 3281Reputation: 3281Reputation: 3281Reputation: 3281Reputation: 3281Reputation: 3281Reputation: 3281Reputation: 3281Reputation: 3281
Quote:
error: Package Qt5GStreamer-0.10 not found
Means : No "Package config file" by name "Qt5GStreamer-0.10.pc" was found.

Solution, something like this :

export PKG_CONFIG_LIBDIR=/home/anisha/Desktop/newGSTr/qt-gstreamer-0.10.3/lib/x86_64-linux-gnu/pkgconfig

The full path should be preferred.
No guaranties that " ~/ " will work.

-
 
1 members found this post helpful.
Old 01-22-2014, 06:21 AM   #3
TheIndependentAquarius
Senior Member
 
Registered: Dec 2008
Posts: 4,680
Blog Entries: 29

Original Poster
Rep: Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917
Thankful to you.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to solve "Package bluez was not found" error? JoeStrout Linux - Newbie 2 03-17-2013 05:02 PM
[SOLVED] BLFS ,error: xproto package not found while compiling makedepend-1.0.4 aashayshah Linux From Scratch 11 03-10-2013 09:25 AM
[SOLVED] x-windows-system package not found, other packages not found. bwilky11 Debian 3 04-12-2012 12:39 PM
E:Package Not found:The error i get on :sudo apt-get install kde phpserver Ubuntu 2 02-14-2009 02:14 PM
firefox configure error : No package 'xft' found logicalfuzz Linux - Software 2 09-30-2005 05:38 AM


All times are GMT -5. The time now is 08:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration