LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-13-2008, 05:41 PM   #1
DarkLevi
LQ Newbie
 
Registered: Feb 2008
Posts: 7

Rep: Reputation: 0
Exclamation error output by compiling from ndiswrapper - kernel not configured


hello,

at first i had to excuse but my english is not that good at all

my problem is quietly simple, i wanted to compile ndiswrapper but i got an error-message:

Makefile:35: *** Cannot find kernel version in /usr/src/linux-2.6.8-24-obj/i386/smp, is it configured?. Stop.
make[1]: Leaving directory `/root/bin/ndiswrapper/ndiswrapper/driver'
make: *** [install] Error 2

i heard that i had to configure or install kernel-headers by yast but i haven't any idea how to do that pls help me and pls remember im not that good in english

thx for helping m8s

edit: sry i forgotten to say i use Novell SuSE Linux 9.2 Prof (hope i'm right in this forum )

Last edited by DarkLevi; 02-13-2008 at 05:42 PM.
 
Old 02-13-2008, 05:51 PM   #2
Uncle_Theodore
Member
 
Registered: Dec 2007
Location: Charleston WV, USA
Distribution: Slackware 12.2, Arch Linux Amd64
Posts: 896

Rep: Reputation: 60
Well, your English is fine, no worse than mine, anyway... But you shouldn't post the same message on two different boards, the moderators will get angry.

About your problem. Go to your kernel source directory
cd /usr/src/linux
and run
make oldconfig
there.

Then, try to compile ndiswrapper again.
 
Old 02-13-2008, 06:15 PM   #3
DarkLevi
LQ Newbie
 
Registered: Feb 2008
Posts: 7

Original Poster
Rep: Reputation: 0
thx for your answer and ure opinion about my englisch
i will try it instantly, and sry for posting it two times, i don`t want to do so
i will give u a feedback as soon as possible
best regards
levi

Last edited by DarkLevi; 02-13-2008 at 06:22 PM.
 
Old 02-13-2008, 07:08 PM   #4
DarkLevi
LQ Newbie
 
Registered: Feb 2008
Posts: 7

Original Poster
Rep: Reputation: 0
im sorry but i think im to stupid to do this
in the directory /usr/src/linux...... is not an makefile theres only another directory called /i684 or something like that what means that comes another error-message to me if i say "make" xD
in my other thread i get an answer i should install over yast and there was a ndiswrapper but it was an old version an works only with wlan-cards not with sticks *cry*

but theres something i do not understand in the install file of ndiswrapper there stand that in the directory (this one in the error message) had to be an *.config file, but there is none

had i to propably to config the kernel manually?
and in this case how i had to do this?
 
Old 02-13-2008, 07:53 PM   #5
Uncle_Theodore
Member
 
Registered: Dec 2007
Location: Charleston WV, USA
Distribution: Slackware 12.2, Arch Linux Amd64
Posts: 896

Rep: Reputation: 60
OK, what exactly do you have in the /usr/src directory? There should be a symbolic link linux pointing to the source tree of the kernel you're currently running. Do you have that?
The topmost directory of the kernel source tree looks like this
Code:
ls -a /usr/src/linux/
.           COPYING        Makefile        block    init    net
..          CREDITS        Module.symvers  crypto   ipc     scripts
.config     Documentation  README          drivers  kernel  security
.gitignore  Kbuild         REPORTING-BUGS  fs       lib     sound
.mailmap    MAINTAINERS    arch            include  mm      usr
if you have the full kernel sources installed. Check if you have them.
 
Old 02-13-2008, 08:27 PM   #6
DarkLevi
LQ Newbie
 
Registered: Feb 2008
Posts: 7

Original Poster
Rep: Reputation: 0
theres only ati and linux-x.x.x...-obj nothing else
how do i install full kernel sources? i nothing found about tha in yast

Last edited by DarkLevi; 02-13-2008 at 08:28 PM.
 
Old 02-13-2008, 08:51 PM   #7
DarkLevi
LQ Newbie
 
Registered: Feb 2008
Posts: 7

Original Poster
Rep: Reputation: 0
im sorry i looked up yast one times more and found kernel-src and installed them

now i have next error message xD but theres only one thing i have to do that is to get a newer version of gcc

thx for all ure help
regards levi
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
error output by compiling from ndiswrapper - kernel not configured DarkLevi Linux - Newbie 2 02-13-2008 06:19 PM
Error compiling NdisWrapper Ian Paul Freely Linux - Newbie 1 07-26-2006 10:37 PM
compiling Ndiswrapper kernel joshknape Linux - Wireless Networking 1 07-17-2005 03:18 AM
Wifi configured with ndiswrapper now what? DeadPenguin Linux - Wireless Networking 8 04-20-2005 10:52 AM
error compiling ndiswrapper jkfff Linux - Wireless Networking 2 04-04-2005 09:32 PM


All times are GMT -5. The time now is 12:59 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration