LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-17-2014, 12:06 PM   #1
jyunker
Member
 
Registered: Aug 2009
Posts: 167

Rep: Reputation: 0
Error of configure of aide 01.5


I am trying to install aide 0.15. At the configure stage it fails with a warning and
an error:

the output:

Code:
checking for mhash_get_block_size in -lmhash... no
configure: WARNING: No mhash means no hmac.
checking for gpg_strerror in -lgpg-error... no
configure: error: You need to have libgpg-error.a installed to use libgcrypt.

Let us take the error first. It says that I must have libgpg-error.a installed
in order to use libcrypt. Now I have installed libgpg-error.so, but no libgpg-error.a
how do I correct this?

Do I install libgpg-error.a or do I do something else?

I am using Centos 6.5, 64 bit version.


Any help appreciated.

Thanks,


jyunker
 
Old 03-17-2014, 12:15 PM   #2
estabroo
Senior Member
 
Registered: Jun 2008
Distribution: debian, ubuntu, sidux
Posts: 1,117
Blog Entries: 2

Rep: Reputation: 113Reputation: 113
You need to install the -dev package in order to be able to compile against it. Look for libgpg-error-dev, you might also need to install libgcrypt-dev as well if it isn't already installed.
 
Old 03-17-2014, 12:16 PM   #3
jyunker
Member
 
Registered: Aug 2009
Posts: 167

Original Poster
Rep: Reputation: 0
Errror on previuos post

I made an error. I have these two packages installed on my system

/lib64/libgpg-error.so.0.5.0
/lib64/libgpg-error.so.0

Not what I said in the previous post.

Sorry.

Thanks,

jyunker
 
Old 03-17-2014, 02:03 PM   #4
jyunker
Member
 
Registered: Aug 2009
Posts: 167

Original Poster
Rep: Reputation: 0
These packages are there, how do I install libgpg-error.a

In this post:

Code:
You need to install the -dev package in order to be able to compile against it. Look for libgpg-error-dev, you might also need to install libgcrypt-dev as well if it isn't already installed.
both of these packages are already installed.

Code:
[root@james aide-0.15.1]# sudo yum install libgpg-error-devel
Loaded plugins: downloadonly, fastestmirror, priorities, refresh-packagekit, security
Loading mirror speeds from cached hostfile
 * base: centos-distro.cavecreek.net
 * elrepo: ftp.colocall.net
 * epel: csc.mcs.sdsmt.edu
 * extras: mirror.sanctuaryhost.com
 * rpmforge: ftp.colocall.net
 * updates: mirror.linux.duke.edu
Setting up Install Process
Package libgpg-error-devel-1.7-4.el6.x86_64 already installed and latest version
Nothing to do
Code:
[root@james aide-0.15.1]# sudo yum install  libgcrypt-devel
Loaded plugins: downloadonly, fastestmirror, priorities, refresh-packagekit, security
Loading mirror speeds from cached hostfile
 * base: centos.mirror.lstn.net
 * elrepo: ftp.colocall.net
 * epel: csc.mcs.sdsmt.edu
 * extras: centos-distro.cavecreek.net
 * rpmforge: ftp.colocall.net
 * updates: mirror.cs.vt.edu
Setting up Install Process
Package libgcrypt-devel-1.4.5-11.el6_4.x86_64 already installed and latest version
Nothing to do
I assume that it is looking for libgpg-error.a,
but it is not there.

Code:
 
[root@james aide-0.15.1]# sudo find / -name libgpg-error.a
[root@james aide-0.15.1]#
I did a sudo yum provides libgpg-error.a and got nothing helpful.

Any other thoughts. I have some files libgpg-error (for shared objects, but not for a.

R,

jyunker
 
Old 03-17-2014, 04:52 PM   #5
estabroo
Senior Member
 
Registered: Jun 2008
Distribution: debian, ubuntu, sidux
Posts: 1,117
Blog Entries: 2

Rep: Reputation: 113Reputation: 113
The .a file is only needed for static compilations. Have you tried running ldconfig to rebuild the library cache? Another thing might be to specify where the headers/libraries are for libgpg-error. If you do a ./configure --help check to see if there is an option to specify that location. Are you running a mixed 32/64 bit setup? Could be the compiler is trying 32bit and the devel installed is 64bit (unlikely though).
 
Old 03-18-2014, 02:11 PM   #6
jyunker
Member
 
Registered: Aug 2009
Posts: 167

Original Poster
Rep: Reputation: 0
It works prob-solved

Yes, I did and it works. Thanks for your help.

R,

jyunker
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Install and Configure AIDE on Slackware 14? mutt4xtreme Slackware 1 08-11-2013 08:00 AM
How to configure aide in linux karthikgm Linux - Server 2 12-20-2010 01:33 PM
How to Configure AIDE , Snort, ttywatch ? Peter_APIIT Linux - Security 3 07-06-2007 10:35 PM
aide configure can't see libmhash yocompia Linux - Security 14 09-09-2005 05:06 PM
how to configure Aide? moonloader Linux - Software 5 08-18-2004 08:24 PM


All times are GMT -5. The time now is 08:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration