LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-26-2014, 01:01 PM   #1
ken7
LQ Newbie
 
Registered: Apr 2014
Location: Manitoba
Distribution: Ubuntu Anti-x
Posts: 17

Rep: Reputation: Disabled
Error messages when trying to open Cruzer memory stick in Anti-X


My stick appears as sdb1 when I open SpaceFM desktop. However when I try to open it I get this error message:
Run:Mount /dev/sdb1
Status:Finished with error ( exit status 4 )
Error:mount point /media/sdb1 is already in /etc/fstab, associated to device UUID=D19A-3623

I am positive I accessed the files in the stick before simply by clicking on the icon and clicking open on the drop down menu. I went to the Office Libre Writer files and I even have the files listed I had opened and worked on. It says now they do not exist. They do I can access them on WIndows XP which I also have on this computer. No doubt I am making some stupid mistake. I wish Linux had a simple My computerk screen where I could just click on the image of my USB stick in the port.
I get the same error if I try to mount or remount the device. Perhaps I am just in the wrong place to open it. The light is on on the stick and when I remove the stick the sdb1 icon disappears.
 
Old 04-26-2014, 01:28 PM   #2
ken7
LQ Newbie
 
Registered: Apr 2014
Location: Manitoba
Distribution: Ubuntu Anti-x
Posts: 17

Original Poster
Rep: Reputation: Disabled
I just went to Anti-X control center and they have a section on managing disks and one is for USB2. My Cruze is listed there and I just clicked refresh. When I went back to the icon in the Space FM desktop I was able to open the disk and access the files with no problem. Sorry to bother people. THe issue seems solved. I will try the same process if it happens again.
 
Old 04-26-2014, 06:13 PM   #3
ken7
LQ Newbie
 
Registered: Apr 2014
Location: Manitoba
Distribution: Ubuntu Anti-x
Posts: 17

Original Poster
Rep: Reputation: Disabled
What I did in the AntX control center must have been just concidentally related to my problem. Now I have rebooted the same issue and same error message is appearing and going back and doing what I did before did not help. In any event it looks as if the directions there have to do with creating a a live boot from a USB stick. It seems that from time to time the system just decides to open the files but mostly I get the error message as first described. So I still do not have a solution.
 
Old 04-26-2014, 07:06 PM   #4
JeremyBoden
Senior Member
 
Registered: Nov 2011
Distribution: Debian
Posts: 1,129

Rep: Reputation: 232Reputation: 232Reputation: 232
You should not get the error
Quote:
Error:mount point /media/sdb1 is already in /etc/fstab, associated to device UUID=D19A-3623
/etc/fstab is a file which holds mount details of permanent disks.
USB sticks are automatically mounted (and unmounted if you click the safely remove icon); they do not appear in /etc/fstab.

If you enter the following command (no parameters)
Code:
mount
you should see 10-20 lines of output - what do the last 3 or 4 look like?
Some sample output:-
Quote:
...
none on /sys/fs/cgroup type tmpfs (rw,relatime,size=4k,mode=755)
systemd on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,name=systemd)
/dev/sdc1 on /media/jeremy/E90D-5E23 type vfat (rw,nosuid,nodev,relatime,uid=1000,gid=1000,fmask=0022,dmask=0077,codepage=437,iocharset=utf8,shortn ame=mixed,showexec,utf8,flush,errors=remount-ro,uhelper=udisks2)
BTW That last entry refers to a bootable USB stick.

Your output may look considerably different.
 
Old 04-26-2014, 08:58 PM   #5
ken7
LQ Newbie
 
Registered: Apr 2014
Location: Manitoba
Distribution: Ubuntu Anti-x
Posts: 17

Original Poster
Rep: Reputation: Disabled
Here is the entire output when I typed in the command "mount"
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
udev on /dev type devtmpfs (rw,relatime,size=10240k,nr_inodes=218000,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=622,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,noexec,relatime,size=206312k,mode=755)
/dev/sda5 on / type ext4 (rw,noatime,data=ordered)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
tmpfs on /run/shm type tmpfs (rw,nosuid,nodev,noexec,relatime,size=412600k)

Hope this helps thanks for your reply. I don't really need to use the USB stick on Antix since I can just switch to Windows XP. I am only here a few days each month and there is no problem with my other computers. I will be leaving here tomorrow at noon so I may not be able to test out your replies for another couple of weeks. Thanks for your help.
 
Old 04-26-2014, 10:28 PM   #6
ken7
LQ Newbie
 
Registered: Apr 2014
Location: Manitoba
Distribution: Ubuntu Anti-x
Posts: 17

Original Poster
Rep: Reputation: Disabled
I went to control center and then to the mount devices section. In the dialogue it had a different device listed to mount but there was also an icon titled list. When I clicked on that I got a list of all the connected devices including sbd1 which is the Cruzer memory stick. I just erased the device name that was in the box and typed /dev/sdb1 and then I deleted the mount point since it was related to the cdrom. I clicked on mount and a window at the side appeared with all the appended devices as icons. I clicked on the sdb1 icon and all the files appeared and were listed in a window below. I then closed the windows and went back to the Space FM file manager and found sdb1 again and clicked on it and lo and behold the files appeared. However when I log off and try to access sdb1 again the same error message appears. However I now know how to get around the problem but it still seems a bit weird that it should keep happening this way.
I opened a file and entered several paragraphs of text. I then rebooted into Windows XP and looked at the file. Antix had properly saved the text to the disk.

Last edited by ken7; 04-26-2014 at 10:31 PM. Reason: addition
 
Old 04-27-2014, 07:17 AM   #7
JeremyBoden
Senior Member
 
Registered: Nov 2011
Distribution: Debian
Posts: 1,129

Rep: Reputation: 232Reputation: 232Reputation: 232
I'm glad you found a workround.

I'm not familiar with SpaceFM - it seems to be very complex.
If your system allows it, you may find a more lightweight desktop/file manager to be more user friendly.
 
Old 04-27-2014, 08:22 AM   #8
antiX-Dave
LQ Newbie
 
Registered: Dec 2013
Distribution: antiX
Posts: 22

Rep: Reputation: Disabled
Could you please post your etc/ fstab here?
If it is complaining about an entry already in etc / fstab it sounds like the automatic disk mount from live (or use with rox-filer) is still enabled.
 
Old 04-27-2014, 10:49 AM   #9
JeremyBoden
Senior Member
 
Registered: Nov 2011
Distribution: Debian
Posts: 1,129

Rep: Reputation: 232Reputation: 232Reputation: 232
Note:- my /etc/fstab is a bit nonstandard - but basically reasonable:-
Quote:
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda1
UUID=51fe6ca2-9ab9-4b52-8ae5-35770fede582 / ext4 rw,errors=remount-ro,noatime 0 1
# /dev/sda2
#UUID=0648d2d1-9a41-4257-8b79-dfc7bc227e82 /home ext4 rw,errors=remount-ro 0 0
/dev/sda2 /home ext4 defaults,noatime,user_xattr 0 2
/dev/sda3 /mnt/video ext4 defaults,noatime 0 2
/dev/sdb2 /mnt/backup ext3 defaults,noatime 0 2
/dev/sdb3 /mnt/filestore ext4 defaults,noatime 0 2
/swapfile none swap sw 0 0

NAS:/mnt/C/ /media/NAS nfs rw,hard,intr,users,noauto,noatime,namlen=250 0 2

/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
Note that there are two disks, sda and sdb, also a connection to a small Network Attached Storage (NAS) device;
I have no swap partition, but I do have a swapfile in /
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
PNY 512M Memory stick error- cannot read sector 0 hal8000b Linux - Hardware 1 12-16-2007 12:16 AM
usb memory stick (cruzer mini) problem on mandrake10.1 yyang Linux - General 8 09-13-2005 04:39 PM
I/O error when copying large file from Memory Stick airman99 Linux - General 3 08-22-2005 09:26 AM
memory stick returns error no medium found newusermike Linux - Newbie 1 08-04-2005 11:02 AM
SCSI Error with memory stick drben Linux - Hardware 2 07-27-2005 04:56 PM


All times are GMT -5. The time now is 08:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration