LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 12-01-2010, 01:18 PM   #1
Actionscript3
LQ Newbie
 
Registered: Jan 2009
Posts: 19

Rep: Reputation: 0
Error message of configure file


Hi,

When I am compiling from the src, I run the ./configure script. While there might be error sometimes, I 'd like to ask, what're the 3 stars( ***) in front of the msg stand for? Do they stand for critical errors?

E.g.

checking for GLIB - version >= 2.0.0... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
configure: error: GLib2 distribution not found.


Thanks for replying.
 
Old 12-01-2010, 01:44 PM   #2
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 14,456

Rep: Reputation: 2538Reputation: 2538Reputation: 2538Reputation: 2538Reputation: 2538Reputation: 2538Reputation: 2538Reputation: 2538Reputation: 2538Reputation: 2538Reputation: 2538
Quote:
Originally Posted by Actionscript3 View Post
Hi,
When I am compiling from the src, I run the ./configure script. While there might be error sometimes, I 'd like to ask, what're the 3 stars( ***) in front of the msg stand for? Do they stand for critical errors?

E.g.
checking for GLIB - version >= 2.0.0... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
configure: error: GLib2 distribution not found.
No, they're just output by the script.

Might help if you told us WHAT you're compiling from source, on what version/distro of Linux, etc., for more details. Otherwise, open the configure script, and search for the ***.
 
Old 12-01-2010, 02:53 PM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,547

Rep: Reputation: 2509Reputation: 2509Reputation: 2509Reputation: 2509Reputation: 2509Reputation: 2509Reputation: 2509Reputation: 2509Reputation: 2509Reputation: 2509Reputation: 2509
Quote:
checking for GLIB - version >= 2.0.0... no
You have glib2 ( libglib2.0 ? ) installed.

But the development files are missing.
Use the Package Manager and install glib2-devel, libglib2.0-dev
or whatever the library name is for your OS.
..
 
Old 12-05-2010, 05:30 AM   #4
Actionscript3
LQ Newbie
 
Registered: Jan 2009
Posts: 19

Original Poster
Rep: Reputation: 0
Thanks,

I am installing Wireshark on Ubuntu 10.10, and I've compiled GLIB 2.26.1
$pkg-config glib-2.0 --modversion
2.26.1

and still get the following error:



checking for GTK+ - version >= 2.0.0... no
*** Could not run GTK+ test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GTK+ is incorrectly installed.
checking for pkg-config... (cached) /usr/bin/pkg-config
checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.26.1, but GLIB (2.26.0)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error: GLib2 distribution not found.
 
Old 12-05-2010, 05:45 AM   #5
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
You should use the Synaptic Package Manager to install the glib development files. That will ensure that they are put in the correct place and have the correct file ownership and permissions.
 
Old 12-05-2010, 06:06 AM   #6
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,547

Rep: Reputation: 2509Reputation: 2509Reputation: 2509Reputation: 2509Reputation: 2509Reputation: 2509Reputation: 2509Reputation: 2509Reputation: 2509Reputation: 2509Reputation: 2509
The system version of glib2 cannot be changed.
A different version will usually stop all Gnome
+ all other applications, that use glib2 / gtk2.

The latest wireshark-1.4.2 will work perfectly with e.g. glib2-2.12.3,
which is the system glib2 in Redhat EL5, CentOS 5.


You are just missing the development part of glib2.
Please read post # 3 : Glib2 is always installed by default.
..

EDIT : Ref post # 5 @stress_junkie : The package name
for Ubuntu 10.10 is 'libglib2.0-dev'.
sudo apt-get install libglib2.0-dev libgtk2.0-dev libpcap-dev
..

Last edited by knudfl; 12-05-2010 at 06:17 AM.
 
Old 12-05-2010, 06:51 AM   #7
Actionscript3
LQ Newbie
 
Registered: Jan 2009
Posts: 19

Original Poster
Rep: Reputation: 0
Thanks very much!


>>The system version of glib2 cannot be changed.

In this case, we've to re-install the OS if updated of glib2 is necessary?
 
Old 12-05-2010, 07:10 AM   #8
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,547

Rep: Reputation: 2509Reputation: 2509Reputation: 2509Reputation: 2509Reputation: 2509Reputation: 2509Reputation: 2509Reputation: 2509Reputation: 2509Reputation: 2509Reputation: 2509
May be you have no internet connection ? ?

? ? Or why is it, that you can't install those three packages
required for wireshark ?

The packages are here
http://packages.ubuntu.com/maverick/libgtk2.0-dev
http://packages.ubuntu.com/maverick/libglib2.0-dev
http://packages.ubuntu.com/maverick/libpcap-dev
The red dots show all the required dependencies.


But there is really no reason to build wireshark.
Is also available ..
http://packages.ubuntu.com/maverick/wireshark

..

Last edited by knudfl; 12-05-2010 at 09:07 AM.
 
Old 12-05-2010, 12:12 PM   #9
Actionscript3
LQ Newbie
 
Registered: Jan 2009
Posts: 19

Original Poster
Rep: Reputation: 0
Thanks,


(wireshark:2705): GLib-GObject-WARNING **: gsignal.c:3081: signal name `depressed' is invalid for instance `0xa0265e8'

I've installed but when I am using Wireshark, there are errors out in the console.
And there're no interfaces to be chosen in "Capture Options".
 
Old 12-05-2010, 12:24 PM   #10
Actionscript3
LQ Newbie
 
Registered: Jan 2009
Posts: 19

Original Poster
Rep: Reputation: 0
oh.. sorry. it's the permission issue!
 
  


Reply

Tags
configure, error


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot run ./configure (Qt error message) dantux Linux - Software 2 09-04-2007 08:35 PM
I get error message when I try to use ,/configure command royeo Linux - Newbie 10 08-11-2006 06:16 AM
Error message in ./configure during the installation of Rosegarden-4-1.0 King_Loz Linux - Software 5 10-11-2005 07:07 PM
Error message when doing ./configure geran Linux - Newbie 19 07-24-2004 05:14 AM
Error message when ./configure 'ing quanta madd matt Linux - Software 2 06-18-2004 04:28 PM


All times are GMT -5. The time now is 08:01 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration