LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Error message of configure file (http://www.linuxquestions.org/questions/linux-newbie-8/error-message-of-configure-file-847743/)

Actionscript3 12-01-2010 02:18 PM

Error message of configure file
 
Hi,

When I am compiling from the src, I run the ./configure script. While there might be error sometimes, I 'd like to ask, what're the 3 stars( ***) in front of the msg stand for? Do they stand for critical errors?

E.g.

checking for GLIB - version >= 2.0.0... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
configure: error: GLib2 distribution not found.


Thanks for replying.

TB0ne 12-01-2010 02:44 PM

Quote:

Originally Posted by Actionscript3 (Post 4177318)
Hi,
When I am compiling from the src, I run the ./configure script. While there might be error sometimes, I 'd like to ask, what're the 3 stars( ***) in front of the msg stand for? Do they stand for critical errors?

E.g.
checking for GLIB - version >= 2.0.0... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
configure: error: GLib2 distribution not found.

No, they're just output by the script.

Might help if you told us WHAT you're compiling from source, on what version/distro of Linux, etc., for more details. Otherwise, open the configure script, and search for the ***.

knudfl 12-01-2010 03:53 PM

Quote:

checking for GLIB - version >= 2.0.0... no
You have glib2 ( libglib2.0 ? ) installed.

But the development files are missing.
Use the Package Manager and install glib2-devel, libglib2.0-dev
or whatever the library name is for your OS.
..

Actionscript3 12-05-2010 06:30 AM

Thanks,

I am installing Wireshark on Ubuntu 10.10, and I've compiled GLIB 2.26.1
$pkg-config glib-2.0 --modversion
2.26.1

and still get the following error:



checking for GTK+ - version >= 2.0.0... no
*** Could not run GTK+ test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GTK+ is incorrectly installed.
checking for pkg-config... (cached) /usr/bin/pkg-config
checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.26.1, but GLIB (2.26.0)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error: GLib2 distribution not found.

stress_junkie 12-05-2010 06:45 AM

You should use the Synaptic Package Manager to install the glib development files. That will ensure that they are put in the correct place and have the correct file ownership and permissions.

knudfl 12-05-2010 07:06 AM

The system version of glib2 cannot be changed.
A different version will usually stop all Gnome
+ all other applications, that use glib2 / gtk2.

The latest wireshark-1.4.2 will work perfectly with e.g. glib2-2.12.3,
which is the system glib2 in Redhat EL5, CentOS 5.


You are just missing the development part of glib2.
Please read post # 3 : Glib2 is always installed by default.
..

EDIT : Ref post # 5 @stress_junkie : The package name
for Ubuntu 10.10 is 'libglib2.0-dev'.
sudo apt-get install libglib2.0-dev libgtk2.0-dev libpcap-dev
..

Actionscript3 12-05-2010 07:51 AM

Thanks very much!


>>The system version of glib2 cannot be changed.

In this case, we've to re-install the OS if updated of glib2 is necessary?

knudfl 12-05-2010 08:10 AM

May be you have no internet connection ? ?

? ? Or why is it, that you can't install those three packages
required for wireshark ?

The packages are here
http://packages.ubuntu.com/maverick/libgtk2.0-dev
http://packages.ubuntu.com/maverick/libglib2.0-dev
http://packages.ubuntu.com/maverick/libpcap-dev
The red dots show all the required dependencies.


But there is really no reason to build wireshark.
Is also available ..
http://packages.ubuntu.com/maverick/wireshark

..

Actionscript3 12-05-2010 01:12 PM

Thanks,


(wireshark:2705): GLib-GObject-WARNING **: gsignal.c:3081: signal name `depressed' is invalid for instance `0xa0265e8'

I've installed but when I am using Wireshark, there are errors out in the console.
And there're no interfaces to be chosen in "Capture Options".

Actionscript3 12-05-2010 01:24 PM

oh.. sorry. it's the permission issue!


All times are GMT -5. The time now is 09:41 PM.