LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-13-2006, 03:08 AM   #1
Arkan123
LQ Newbie
 
Registered: Jan 2006
Location: Canada
Distribution: Mandrake
Posts: 28

Rep: Reputation: 15
error message from real player when streaming video


i get this error message when i try to stream a video


could not find appropriate hxplay or realplay om system path to use as an embedded player

i am using mozilla


any suggestions?
 
Old 01-13-2006, 03:46 AM   #2
Flesym
Member
 
Registered: Aug 2005
Location: Germany
Distribution: Ubuntu, Debian
Posts: 189

Rep: Reputation: 31
Did you try what the message suggest you to do? -Often it is as easy as that! -Link 'realplay' to your system path. I.e:

Code:
ln -s /[path-to-realplayer]/realplay /usr/bin/
You should also have a link from their plugin within the mozilla plugins directory (if not yet):
Code:
ln -s /[path-to-realplayer]/mozilla/nphelix.so ~/.mozilla/plugins/nphelix.so
 
Old 01-13-2006, 04:31 AM   #3
Arkan123
LQ Newbie
 
Registered: Jan 2006
Location: Canada
Distribution: Mandrake
Posts: 28

Original Poster
Rep: Reputation: 15
i typed in

ln -s /[home/rob]/realplay /usr/bin/

as root user then i when i typed in



ln -s /home/rob/realplayer/mozilla/nphelix.so ~/.mozilla/plugins/nphelix.so

i get this message

ln: when making multiple links, last argument must be a directory

whats going wrong?
 
Old 01-13-2006, 05:08 AM   #4
Flesym
Member
 
Registered: Aug 2005
Location: Germany
Distribution: Ubuntu, Debian
Posts: 189

Rep: Reputation: 31
Quote:
ln -s /[home/rob]/realplay /usr/bin/
From this i guess, your Realplayer-path is: /home/rob/realplay ? -If so, then go there and you should see the executable file 'realplay', right? You have to link this file to a directory of your PATH environment variable ('/usr/bin/' is common for this). I guess what you have done so far is linking the 'realplay'-directory(!) to '/usr/bin'. So go to '/usr/bin' an look if there is a directory named 'realplay' - delete that! Now again (supposed, that that '/home/rob/realplay' is your Realplayer-directory):

Code:
ln -s /home/rob/realplay/realplay /usr/bin/
The other thing:
Quote:
ln -s /home/rob/realplayer/mozilla/nphelix.so ~/.mozilla/plugins/nphelix.so
I don't think that you have typed that. This error comes up, when you give 'ln' more then one "link source" and the last argument is not a directory. -So i guess there was a ' '(space) too much in whatever you typed. Make sure that there is no such space within any of the to paths or, if needed, put them in quotations or lead the space with a backslash ('\'); but from what you gave me, there should be no space in any of the paths.

Last edited by Flesym; 01-13-2006 at 05:12 AM.
 
Old 01-13-2006, 08:02 PM   #5
Arkan123
LQ Newbie
 
Registered: Jan 2006
Location: Canada
Distribution: Mandrake
Posts: 28

Original Poster
Rep: Reputation: 15
ok i did all that but when i type in

ln -s /home/rob/realplayer/mozilla/nphelix.so ~/.mozilla/plugins/nphelix.so

it says


ln: `/home/rob/.mozilla/plugins/nphelix.so': File exists

whats going on?
 
Old 01-14-2006, 04:27 AM   #6
Flesym
Member
 
Registered: Aug 2005
Location: Germany
Distribution: Ubuntu, Debian
Posts: 189

Rep: Reputation: 31
Quote:
ln: `/home/rob/.mozilla/plugins/nphelix.so': File exists
This does only mean, that the link already exists. If the link points to the correct file (check it) then this is not bad, but exactly what you want(you cannot create the same link twice). Did you try if the plugin already words?

Last edited by Flesym; 01-14-2006 at 04:29 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Real Player 10 video freezes Barry Bingham Linux - Software 6 09-29-2006 06:02 AM
Real Player Integrated Video Streams in Firefox W0bbles Linux - Software 7 12-15-2005 07:17 AM
Have downloaded & installed Real Player on my FC2. audio appears to work but video no aschandru Linux - Software 2 04-26-2005 10:38 AM
Real Player live streaming error hand of fate Linux - Software 1 02-14-2005 07:05 AM
player/plugin for nsv (nullsoft streaming video) jmr71769 Linux - Software 0 02-19-2004 01:55 PM


All times are GMT -5. The time now is 05:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration