LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 08-27-2004, 02:17 AM   #1
marksman
LQ Newbie
 
Registered: Aug 2004
Posts: 8

Rep: Reputation: 0
Unhappy "Error Loading OS" Fedora Vs XP - Either will work, Sys wont boot


Right,

I installed Fedora Core 2 on to the 2nd HDD "hdb" but i understand that it still screws with ur MBR on the Master drive.
Installed ok linux ran ok, but on boot when i seclected "windows" it just went to another screen and hung.

I then removed linux partitons on Disk E then formated and installed XP on C.

Didnt work "Error Loading OS"

Tryed installing XP on disk E where linux was and rebooted "Error loading OS"

I have looked about and i think its 2 do with the MBR.

I ran XP recovery and did fixboot and fixmbr writing a new boot thing which worked, sed "done" etc...

Still no joy "error loading os"

I dont no what to do :'(!

Can any of u masterminds help this poor :P

Spec :

AMD 2500+ O/C to 2800
1GB DDR 400
Asus Mobo
1 40GB WD
1 160GB Max
 
Old 08-27-2004, 02:42 AM   #2
masand
Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 57
hi
boot from a win98 cd
at the command prompt
#fdisk /mbr
will remve grub and rewrite the windows MBR to it


regards
 
Old 08-27-2004, 02:48 AM   #3
marksman
LQ Newbie
 
Registered: Aug 2004
Posts: 8

Original Poster
Rep: Reputation: 0
surly thats what happed when i did it on XP, "fixboot" and "fixmbr"?

(which still didnt stop the error)
 
Old 08-27-2004, 02:53 AM   #4
Demonbane
Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
use fdisk and make sure your Windows partition is set to active/boot, and is not hidden in any way.

Last edited by Demonbane; 08-27-2004 at 02:56 AM.
 
Old 08-27-2004, 02:55 AM   #5
marksman
LQ Newbie
 
Registered: Aug 2004
Posts: 8

Original Poster
Rep: Reputation: 0
think i tryed that, used fdisk and did "set partition to active".

No joy
 
Old 08-27-2004, 03:15 AM   #6
Demonbane
Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
what's set to the first boot device in bios?
 
Old 08-27-2004, 03:56 AM   #7
marksman
LQ Newbie
 
Registered: Aug 2004
Posts: 8

Original Poster
Rep: Reputation: 0
CD
HDD0
HDD1

Tryed booting from 1 and 2, Same error.
 
Old 08-27-2004, 04:17 AM   #8
masand
Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 57
hi
when u try installing Xp then does it say "that a previous windows inatallation.was detected do want to correct that" etc etc

also try that doing from win98 CD as i toild earlier, or check again whcih partition is active
regards
 
Old 08-27-2004, 04:23 AM   #9
marksman
LQ Newbie
 
Registered: Aug 2004
Posts: 8

Original Poster
Rep: Reputation: 0
ummm, I *think* i have done that still didnt work.

Made sure the part is active.

And as far as windows 98 goes i dont have a copy, But i dont see what it will do that XP dosnt.
But if u think it will make a diffrance, Ill nick 1 from work.

I have dont most of the normal krap Fdisk \ MBR repairs \ Repair XP etc....

Any other things that i ant thought of? (there must be quite alot :P)

AJM
 
Old 08-27-2004, 04:41 AM   #10
masand
Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 57
hiu
u can get a windows startup floppy to work tooo

and what i have seen is that u do not need third party softwares for MBR problems, these standard ones are good

also tell whcih partion is active and where do u have ur boot.ini
regards
 
Old 08-27-2004, 04:55 AM   #11
marksman
LQ Newbie
 
Registered: Aug 2004
Posts: 8

Original Poster
Rep: Reputation: 0
confusing,

I have an "ultamate boot cd" with every util and tool under the sun.
Including boot utils etc, but buggered if i no what i post 2 be doing \ trying to do!

ne ideas, i can boot fine of this CD.

Link : http://www.ultimatebootcd.com/

AJM
 
Old 08-27-2004, 05:21 AM   #12
Demonbane
Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
you mean using something like "smart boot manager" works? can you post the output of "fdisk -l" using any Linux live cd/bootdisk?

btw if it says "Error Loading OS" then it means Windows/Dos MBR is installed.

Last edited by Demonbane; 08-27-2004 at 05:22 AM.
 
Old 08-27-2004, 05:24 AM   #13
marksman
LQ Newbie
 
Registered: Aug 2004
Posts: 8

Original Poster
Rep: Reputation: 0
ummm Demonbane,

I just mean i can boot that cd and its got shit lots on it.

So u think try "smart boot manager"?

Or summit?

AJM
 
Old 08-27-2004, 05:28 AM   #14
masand
Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 57
HI
the above link is a good one and good compilation tooo,

is this also not able to solve ur problem
regards
 
Old 08-27-2004, 05:32 AM   #15
marksman
LQ Newbie
 
Registered: Aug 2004
Posts: 8

Original Poster
Rep: Reputation: 0
thats what im saying, there is so much on there i dont no what im supost 2 be using \ doing. lol

i will try "smart boot manager" and have a play. but i dought it will work i tryed sum of the fdisk utils on it, but didnt do alot.

"error loading OS"

Arghhhh.

AJM
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Reboot Error: "initlog: error while loading shared libraries: libpopt.so.0" saranga2000 Linux - Enterprise 4 04-26-2013 06:50 PM
Boot problem: "GRUB Loading stage2read Error" after installing PCI Ethernet card nsyng Fedora - Installation 1 06-06-2005 06:53 AM
Box wont boot after kernel upgrade "Dump Card State Ends" error with scsi card abefroman Mandriva 0 03-25-2004 03:42 PM
Linux boot hang : "init: error loading shared libraries" colinprice72 Linux - General 0 01-16-2004 09:04 AM
su wont work, cant "su root" as a normal user lukeorun Linux - General 5 10-17-2002 07:25 AM


All times are GMT -5. The time now is 11:32 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration