LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-24-2008, 01:57 PM   #1
greg@methods.com
LQ Newbie
 
Registered: Dec 2008
Posts: 3

Rep: Reputation: 0
Error loading Java 1.4.2_06 in Enterprise Server


I get the following error when tring to install java 1.4.2_06 in Redhat Enterprise server 5.

tail: cannot open `+480' for reading: No such file or directory
Checksumming...
1
The download file appears to be corrupted. Please refer
to the Troubleshooting section of the Installation
Instructions on the download page for more information.
Please do not attempt to install this archive file.


I do not have this problem with Redhat 8. I tried Fedora 9 before our company deciced on Enterprise and got the same error.

Any help or suggestion would be great.
 
Old 12-24-2008, 04:11 PM   #2
vladmihaisima
Member
 
Registered: Oct 2002
Location: Delft, Netherlands
Distribution: Gentoo
Posts: 196

Rep: Reputation: 33
I think the problem is related to the tail command. Some accept the syntax "tail +480" some insist on the syntax "tail -n 480". In my opinion the easiest solution would be to edit the installation file. Search for "tail +480" and replace it with "tail -n 480". If they do some fancy checksum on all the install script (and not just the binary file) this will not work, but as it is very easy it is worth trying.
 
Old 12-25-2008, 01:10 PM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
And it would probably be easier to install
java 5 (=1.5) or java 6 (=1.6) .

Java-1.4 is really old.
 
Old 12-26-2008, 11:21 AM   #4
greg@methods.com
LQ Newbie
 
Registered: Dec 2008
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks for the suggestion vladmihaisima, I will give it a try.

Knudfl, I would like to use a new version of Java, but Progress 10.1A requires the version I am trying to install. Thanks for the input.
 
Old 12-26-2008, 07:30 PM   #5
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
The installer is asking for a file by name " +486 "
Make an empty text file and see the message disappear.

But the 1.4.2_06 packages from Sun are corrupted,
"rpm.bin" and ".bin"

A usable package can probably probably be found on
the Suse 10 install DVD :
java-1_4_2-sun-1.4.2.06-5.i586.rpm
java-1_4_2-sun-devel-1.4.2.06-5.i586.rpm
java-1_4_2-sun-src-1.4.2.06-5.i586.rpm
( I have a copy )

j2sdk-1_4_2_04-i586-3.tgz is here
ftp://ftp.heanet.ie/mirrors/ftp.slac....0/slackware/d
....
 
Old 12-29-2008, 09:20 PM   #6
greg@methods.com
LQ Newbie
 
Registered: Dec 2008
Posts: 3

Original Poster
Rep: Reputation: 0
One of our programmers edited the install file, the 'tail +480' was part of the problem, he said there were some other adjustments he had to make as well. The 'tail +480' was used in an older version of redhat (8.0). Sorry I could not be more specific with the adjustments he made, but he did not go into details.
Thanks for the suggestions, they pointed us in the right direction and the problem was resolved. If there is a need for the adjustments made to the install file, I can ask and report them.
Thanks again!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing JAVA APACHE MAIL ENTERPRISE SERVER revanth_86 Linux - General 0 01-22-2007 09:09 AM
error loading dynamic library with Java trutnev Programming 4 06-01-2005 04:33 PM
Where is java 1.4.2_06 package acanton Slackware 2 12-27-2004 09:05 AM
Fedora Core 3 Firefox Crashes With Java 1.5 and 1.4.2_06 webterractive Linux - Software 4 12-04-2004 01:00 PM
Firefox crashes with latest Java (j2re_1.4.2_06-1_i386) gorby Linux - Software 1 10-28-2004 01:53 PM


All times are GMT -5. The time now is 12:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration