LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-17-2013, 05:40 PM   #1
Salinn
LQ Newbie
 
Registered: Jun 2013
Posts: 3

Rep: Reputation: Disabled
Error Installing Programs (Redhat 6.4)


Hey everyone, I am still fairly new to linux and this is the second time I have run into this problem. The first time I tried some things I saw online and I just ended up making the problem worse. So I re installed the vm and started again. It has been a bit since I ran into this problem, but currently I am receiving this error whenever I try to download anything.

yum install ruby

Loaded plugins: amazon-id, rhui-lb, security
http://services.dtosolutions.com/rer...ta/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: rerun-modules. Please verify its path and try again

The VM is running Red Hat Enterprise Linux Server release 6.4 (Santiago). Any help would be appreciated!
 
Old 06-17-2013, 05:58 PM   #2
lleb
Senior Member
 
Registered: Dec 2005
Location: Florida
Distribution: CentOS/Fedora
Posts: 2,630

Rep: Reputation: 495Reputation: 495Reputation: 495Reputation: 495Reputation: 495
can the VM get online?

error 404 means one of a few things. one of them is a lack of connectivity with the specified URL, the other is the URL you are attempting to gain access to is either down or has moved without a forwarding link from the old URL.

In addition this is RHEL, you are paying for support. If your VM has access and you can get access to the URL manually via a web browser, then you need to contact RH as that is what you are paying for.
 
Old 06-17-2013, 07:19 PM   #3
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,258

Rep: Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328
This system needs to be registered with RH or you won't get updates and support.
If you won't/can't pay(!) for this, switch over to Centos (free rebuild; updates, no support)
 
Old 06-18-2013, 08:57 AM   #4
Salinn
LQ Newbie
 
Registered: Jun 2013
Posts: 3

Original Poster
Rep: Reputation: Disabled
@lleb Sorry I forgot to mention that the VM is an EC2 instance on Amazon Web Services, I don't think that it makes a difference, does it? Also when I type ipconfig I get

[ec2-user@ip-10-236-19-115 ~]$ ifconfig
eth0 Link encap:Ethernet HWaddr 16:00:68:2F:A6:42
inet addr:10.236.19.115 Bcast:10.236.19.255 Mask:255.255.255.0
inet6 addr: fe80::1400:68ff:fe2f:a642/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:173759 errors:0 dropped:0 overruns:0 frame:0
TX packets:99606 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:215399054 (205.4 MiB) TX bytes:9182252 (8.7 MiB)
Interrupt:247

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:234 errors:0 dropped:0 overruns:0 frame:0
TX packets:234 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:12378 (12.0 KiB) TX bytes:12378 (12.0 KiB)

when I try to manually pull it from the website with wget and the link that is provided when I use yum install ruby I get

wget http://services.dtosolutions.com/rer...ata/repomd.xml
--2013-06-18 08:50:59-- http://services.dtosolutions.com/rer...ata/repomd.xml
Resolving services.dtosolutions.com... 199.71.214.155
Connecting to services.dtosolutions.com|199.71.214.155|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2013-06-18 08:50:59 ERROR 404: Not Found.

It looks like I need a new mirror I think. Should I be contacting Amazon about this?

@chrism01 I am actually using centos for my regular vm.
 
Old 06-18-2013, 09:05 AM   #5
mddnix
Member
 
Registered: Mar 2013
Distribution: Redhat, Ubuntu
Posts: 516

Rep: Reputation: 139Reputation: 139
You are hitting dead page.
 
Old 06-18-2013, 09:53 AM   #6
k.s.rakeshsharma
LQ Newbie
 
Registered: Jun 2013
Posts: 4

Rep: Reputation: Disabled
i also faced the problem like this in my personel redhat system,
for me it is beacuse of yum repository not installed perfectly
for that i did the following steps
hope this helps you

For Creating YUM we have to configure Yum first.

step1:create yum repository
vim /etc/yum.repos.d/soft.repo
step2: In soft.repo we have write following

[Software]
name=this is software repository
baseurl=file:///softwares
enabled=1
gpgcheck=0
step3:Install “rpm -ivh createrepo-0.3.2.1.rpm” from rpm packages.
step4: then do the following:
createrepo /softwares

this is for local system you have to give path for remote
 
Old 06-18-2013, 10:38 AM   #7
Salinn
LQ Newbie
 
Registered: Jun 2013
Posts: 3

Original Poster
Rep: Reputation: Disabled
Ok so my co-worker found the problem. I am not sure if anyone has used the rerun package out there for software but when I used yum install rerun it installed a mirror and so yum first checked that and once it failed then it just gave up so we disabled that mirror and it is not working correctly
 
Old 06-19-2013, 02:44 AM   #8
dushyantgohil
Member
 
Registered: Aug 2011
Location: India
Distribution: Cent OS & Ubuntu
Posts: 107

Rep: Reputation: 3
have you tried changing the mirror of yum?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
error installing programs.... alrave Linux - Software 6 07-22-2005 07:36 PM
Error installing Gnome developer programs SilverXXX Fedora 0 07-20-2004 03:31 AM
Some newbie tryin to get help Installing Programs on RedHat again. (help dubdub57 Linux - Software 5 04-20-2004 07:10 PM
help w\ installing programs on RedHat Linux 9 bshelton Linux - General 7 09-11-2003 02:52 PM
installing programs, no sound, and mandrake - am using redhat 8 johan the olive Linux - Newbie 1 02-11-2003 07:04 PM


All times are GMT -5. The time now is 06:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration