LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-17-2013, 05:01 PM   #1
jim.thornton
Member
 
Registered: May 2007
Posts: 404

Rep: Reputation: 19
Error installing headers


I'm trying to install Asterisk/FreePBX onto a new machine running Ubuntu 12.04 LTS.

During the installation it says that I have to install linux headers however I'm getting an error when trying to install it.
Code:
# apt-get install -y linux-headers-`uname -r`
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package linux-headers-2.6.32-042stab076.8
E: Couldn't find any package by regex 'linux-headers-2.6.32-042stab076.8'
Can someone help me get this installed please? I've been using linux for a while now but have never had success in installing new headers and have abondoned previous tasks that required it. I can't abandon this one though.

If it matters, this is inside a VPS. I think it is running OpenVZ but I'm guessing.
 
Old 05-17-2013, 05:37 PM   #2
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Quote:
Originally Posted by jim.thornton View Post
I'm trying to install Asterisk/FreePBX onto a new machine running Ubuntu 12.04 LTS.

During the installation it says that I have to install linux headers however I'm getting an error when trying to install it.
Code:
# apt-get install -y linux-headers-`uname -r`
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package linux-headers-2.6.32-042stab076.8
E: Couldn't find any package by regex 'linux-headers-2.6.32-042stab076.8'
Can someone help me get this installed please? I've been using linux for a while now but have never had success in installing new headers and have abondoned previous tasks that required it. I can't abandon this one though.

If it matters, this is inside a VPS. I think it is running OpenVZ but I'm guessing.
Ubuntu 12.04's kernel is/was at 3.2 you are trying to install the wrong headers for the machine. Try using package manager or apt-get.
http://www.cyberciti.biz/faq/howto-i...aders-package/

Last edited by EDDY1; 05-17-2013 at 05:40 PM.
 
Old 05-17-2013, 05:40 PM   #3
jim.thornton
Member
 
Registered: May 2007
Posts: 404

Original Poster
Rep: Reputation: 19
How should I change the command that is there in order to make it work with the software that I'm trying to install and the system Ubuntu 12.04?
 
Old 05-17-2013, 05:43 PM   #4
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Quote:
Originally Posted by jim.thornton View Post
How should I change the command that is there in order to make it work with the software that I'm trying to install and the system Ubuntu 12.04?
Check my previous post. what kernel are you running?
 
Old 05-17-2013, 05:50 PM   #5
jim.thornton
Member
 
Registered: May 2007
Posts: 404

Original Poster
Rep: Reputation: 19
I have no idea how to check the kernel.

This is what I typed in though:
apt-get install linux-headers-$(uname -r)

# uname -r:
2.6.32-042stab076.8
 
Old 05-17-2013, 06:45 PM   #6
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
2.6.32 kernel for ubuntu desktop was in 10.04LTS which dropped support May 9 2013.
https://en.wikipedia.org/wiki/List_of_Ubuntu_releases
You'll need to upgrade or reinstall OS.
You can find release version here.
http://ubuntu-tutorials.com/2007/01/...ernel-version/

Last edited by EDDY1; 05-17-2013 at 06:52 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
error in installing (glibc-headers) packages raja.sa Linux - Newbie 3 01-19-2013 08:41 AM
LFS 6.5 : Step 6.7 Installing Linux API headers : make headers_check/install error tsong99 Linux From Scratch 12 12-25-2012 05:26 PM
Error installing Linux-3.2.6 API Headers cola Linux From Scratch 1 03-07-2012 06:39 PM
Error Installing the "linux-headers-2.6.22-14-generic" update. solitaire Linux - Newbie 1 02-15-2008 09:09 PM
Problems installing program: error: Qt (>= Qt 3.0.3) (headers and libraries) Anjin Mandriva 4 04-26-2004 11:54 AM


All times are GMT -5. The time now is 10:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration