LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-27-2005, 04:44 AM   #1
thandermax
Member
 
Registered: Jun 2005
Distribution: OpenSUSE 10.3 , 11.2 , Solaris 10, Ubuntu 9.10
Posts: 84

Rep: Reputation: 16
Error in starting XServer in 2.6.12.1 kernel


Recently I downloaded and compiled the 2.6.12.1 Kernel and set it up properly in "grub.conf" as I am using the GRUB for booting.


After I start booting it gives no error and i can see familiar
loding XXXXX [OK]

and then when it switches to Graphics mode (i.e. XServer) it just hangs showing only the cross (X) cursor in black background . Instead of loading the GUI Login screen.


I had setup all necessery files (such as system.map, vmlinuz.2.6.12.1 ,initrd-2.6.12.1.img etc).




No error is presented in bootup screen, only problem is in loading XServer.
 
Old 06-27-2005, 07:39 AM   #2
Zero-0-Effect
Member
 
Registered: Sep 2002
Location: Texas
Distribution: SlackWare - Current LFS - CVS
Posts: 267

Rep: Reputation: 31
Looks like the kernel works and the Xserver is working... sorta.. You will need to boot into runlevel 3 and fix it from there. After you login try starting X with the startx command and specify the windows manager as well and see if it will bring it up. If you get the same thing hit ctrl-alt-backspace and look to see what it was doing last that made it hang. If it does bring it up you may just have a incorrect setting in kdm or gdm or whatever you using for the login manager.

You specify the window manager like:

startx /usr/X11R6/bin/startfluxbox

or whatever one you like to run.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error in starting XServer in 2.6.12.1 kernel thandermax Linux - Software 1 06-27-2005 12:59 PM
xserver not starting locke105 Slackware 4 03-25-2005 07:56 AM
Xserver not starting meenalborkar Red Hat 5 03-04-2005 08:25 PM
XServer not starting. velan Red Hat 1 05-10-2004 07:05 AM
stopping xserver from starting up? Zaskar Debian 17 03-20-2004 07:59 PM


All times are GMT -5. The time now is 01:29 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration