LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 02-05-2011, 08:05 AM   #1
preetb123
LQ Newbie
 
Registered: Jan 2011
Posts: 28

Rep: Reputation: 0
Post error in package installation


i was installing some C/C++ plug-ins for codelite IDE before actually installing Codelite IDE(from the .deb packege available), and the installation didnt complete successfully, it left errors in the system. now evrytime i install something from terminal i get following error and the application doesnt get installed.
i am a newbie to linux and ubuntu, so i dont knw how to remove some packages or to restore the system from last restore point before this errors started, what i shud do to resolve this problem.
following, is just an example:

preetam@ubuntu:~$ sudo apt-get install mplayer
Reading package lists... Done
Building dependency tree
Reading state information... Done
Suggested packages:
mplayer-doc netselect fping
The following NEW packages will be installed:
mplayer
0 upgraded, 1 newly installed, 0 to remove and 262 not upgraded.
1 not fully installed or removed.
Need to get 0B/2,901kB of archives.
After this operation, 5,513kB of additional disk space will be used.
Selecting previously deselected package mplayer.
(Reading database ... 124062 files and directories currently installed.)
Unpacking mplayer (from .../mplayer_2%3a1.0~rc4~try1.dsfg1-1ubuntu1_i386.deb) ...
Processing triggers for man-db ...
Setting up firmware-b43-installer (4.150.10.5-4) ...
Not supported low-power chip with PCI id 14e4:4315!
Aborting.
dpkg: error processing firmware-b43-installer (--configure):
subprocess installed post-installation script returned error exit status 1
Setting up mplayer (2:1.0~rc4~try1.dsfg1-1ubuntu1) ...
Errors were encountered while processing:
firmware-b43-installer
E: Sub-process /usr/bin/dpkg returned an error code (1)
preetam@ubuntu:~$



in this case, the mplayer is not installed, and this error appears...and same way if i try to remove codelite, then also it gives errors, so is there any way to remove all these packages which caused problems...? please help.

another case:::

preetam@ubuntu:~$ sudo apt-get remove codelite
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package codelite is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 262 not upgraded.
1 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Setting up firmware-b43-installer (4.150.10.5-4) ...
Not supported low-power chip with PCI id 14e4:4315!
Aborting.
dpkg: error processing firmware-b43-installer (--configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
firmware-b43-installer
E: Sub-process /usr/bin/dpkg returned an error code (1)
preetam@ubuntu:~$



what is the solution?
 
Old 02-05-2011, 08:47 AM   #2
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,570

Rep: Reputation: 510Reputation: 510Reputation: 510Reputation: 510Reputation: 510Reputation: 510
Try removing firmware-b43-installer.
 
1 members found this post helpful.
Old 02-07-2011, 11:42 AM   #3
preetb123
LQ Newbie
 
Registered: Jan 2011
Posts: 28

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by AlucardZero View Post
Try removing firmware-b43-installer.
thank you. that helped....
 
  


Reply

Tags
package management, removal


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Try to remove previous installation and create a package but got an error ethereal1m Linux - Newbie 4 04-09-2010 12:08 PM
Installation error of RPM Package soni_silver17 Linux - Software 1 10-28-2009 05:39 AM
supertux auto package installation error myhumandreams Linux - Software 2 02-14-2009 02:12 AM
Fatal Error: Package Installation Nathanh Slackware - Installation 4 06-14-2006 12:13 PM
Error In Package Installation rajaniyer123 Solaris / OpenSolaris 4 02-27-2006 10:48 AM


All times are GMT -5. The time now is 10:03 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration