LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-18-2013, 07:47 PM   #1
raja.sa
LQ Newbie
 
Registered: Jan 2013
Posts: 3

Rep: Reputation: Disabled
error in installing (glibc-headers) packages


Hi all ..

im trying to install oracle 11g r2 using red hat 5 OS

when i tried to install these packages i got an error msg:

rpm -Uvh glibc-devel-2.*
rpm -Uvh glibc-headers-2.*

the error msgs were :

#rpm -Uvh glibc-headers-2.*
warning: glibc-headers-2.5-34.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 37017186
error: Failed dependencies:
kernel-headers is needed by glibc-headers-2.5-34.x86_64
kernel-headers >= 2.2.1 is needed by glibc-headers-2.5-34.x86_64

--------------

# rpm -Uvh glibc-devel-2.*
warning: glibc-devel-2.5-34.i386.rpm: Header V3 DSA signature: NOKEY, key ID 37017186
error: Failed dependencies:
glibc-headers is needed by glibc-devel-2.5-34.i386
glibc-headers = 2.5-34 is needed by glibc-devel-2.5-34.i386
glibc-headers is needed by glibc-devel-2.5-34.x86_64
glibc-headers = 2.5-34 is needed by glibc-devel-2.5-34.x86_64

-----------
kindly ... can anyone help me plz ...
thnx all
 
Old 01-18-2013, 09:58 PM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
Welcome to LQ.

The packages you are trying to install are three years old.
The current update version : glibc-2.5-81.el5_8.7
And : One package is missing : 'kernel-headers'.

How about : # yum install glibc-devel.i386

If you want to use 'rpm -Uvh', please use chain install :
# rpm -Uvh <package>.rpm <package>.rpm <package>.rpm
Required when the packages depend on each other : "Circular dependency".

-
 
1 members found this post helpful.
Old 01-19-2013, 08:11 AM   #3
raja.sa
LQ Newbie
 
Registered: Jan 2013
Posts: 3

Original Poster
Rep: Reputation: Disabled
thnk you knudfl for ur answer

i tried the following command

# rpm -Uvh gcc-4.*.rpm gcc-c++-4.*.rpm glibc-2.*.rpm glibc-common-2.*.rpm glibc-devel-2.*.rpm glibc-headers-2.*.rpm libaio-devel-0.*.rpm

and got this error :
# rpm -Uvh gcc-4.*.rpm gcc-c++-4.*.rpm glibc-2.*.rpm glibc-common-2.*.rpm glibc-devel-2.*.rpm glibc-headers-2.*.rpm libaio-devel-0.*.rpm
warning: gcc-4.1.2-44.el5.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 37017186
error: Failed dependencies:
kernel-headers is needed by glibc-headers-2.5-34.x86_64
kernel-headers >= 2.2.1 is needed by glibc-headers-2.5-34.x86_64
-----------------------
and tried the following command :
yum install glibc-devel.i386

and got this error:
# yum install glibc-devel.i386
Loaded plugins: rhnplugin, security
This system is not registered with RHN.
RHN support will be disabled.
Setting up Install Process
Parsing package install arguments
No package glibc-devel.i386 available.
Nothing to do

-----------------

sorry for that ... could u tell me plz what should i do clearly because im a C# programmer and not familiar with linux OS and how can i get the last version of packages ... what should i do first to fix that problem

thank you guy

Last edited by raja.sa; 01-19-2013 at 08:26 AM.
 
Old 01-19-2013, 08:41 AM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
# 3
Quote:
... what should i do first to fix that problem
Migrate the OS to the free version = CentOS
http://wiki.centos.org/HowTos/MigrationGuide
(The main action is to point the repo files to the identical CentOS packages.)


-
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Error installing Linux-3.2.6 API Headers cola Linux From Scratch 1 03-07-2012 06:39 PM
[SOLVED] glibc and glibc-i18n packages contain redundant files H_TeXMeX_H Slackware 7 06-25-2011 02:58 PM
Which Packages Depend Upon Kernel Headers, glibc, gcc, etc.? Woodsman Slackware 3 06-05-2009 03:05 PM
Error during installing glibc-2.2.5 giri616 Linux From Scratch 3 11-10-2006 12:34 AM
Problems installing program: error: Qt (>= Qt 3.0.3) (headers and libraries) Anjin Mandriva 4 04-26-2004 11:54 AM


All times are GMT -5. The time now is 05:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration