LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-20-2011, 12:17 PM   #1
Hevithan
Member
 
Registered: Apr 2011
Location: Washington State
Distribution: Zorin5-(Ubuntu 11.04) // Backtrack 5-(Ubuntu 10.04) // Dreamlinux 3.5-(Debian)
Posts: 275
Blog Entries: 5

Rep: Reputation: 40
Error in Flash Game-(All other flash works video/games/menus)-ERROR msg included


I've been playing flash games, and they all work fine, but there is one on facebook that keeps giving me an error. The error is rather descriptive, but damn if I know what it is. I am running Dreamlinux (Built on Debian) w/Xfce desktop, here is my error:


ERROR: FlashTransceiver constructor expected a reference to an <embed> or <object> tag

function create(swfElement, requires) { var theId; if (!isValidSwfElement(swfElement)) { throw PF.Errors.createError({locatedInModule: "PF.MessageBroker.Flash.Transceiver", locatedInFunction: "create", messageToThrow: "FlashTransceiver constructor expected a reference to an <embed> or <object> tag"}); } else { theId = swfElement.id; if (!theId) { throw PF.Errors.createError({locatedInModule: "PF.MessageBroker.Flash.Transceiver", locatedInFunction: "create", messageToThrow: "SWF element requires an HTML ID attribute"}); } else if (PF.Util.Core.arrayContains(createdTransceivers, theId)) { throw PF.Errors.createError({locatedInModule: "PF.MessageBroker.Flash.Transceiver", locatedInFunction: "create", messageToThrow: "Transceiver already created for this SWF element"}); } else { if (!createdTransceivers) { createdTransceivers = []; } createdTransceivers.push(theId); return new FlashTransceiver(swfElement, requires); } } }

IN: PF.MessageBroker.Flash.Transceiver

All I've really done is look through my /etc file ... Checked in module and whatnot ...I don't know what to do with it though lol... I could use a little help here ... Thanks for your time.
 
Old 04-21-2011, 05:15 AM   #2
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Rep: Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957
I doubt this has anything to do with Linux itself. It looks to me like a communication problem between the flash object and the script(s) on the page it's embedded in.

The only thing I can suggest is to check the security features (adblock/noscript/etc.) of your browser and make sure it's not blocking the connection.

Just where are you seeing this error message anyway?
 
Old 04-21-2011, 06:03 AM   #3
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Even wit sunjava jre I had problems until I found a key in /usr/lib/flashpluggin and double-clicked and imported key.
 
Old 04-21-2011, 02:28 PM   #4
Hevithan
Member
 
Registered: Apr 2011
Location: Washington State
Distribution: Zorin5-(Ubuntu 11.04) // Backtrack 5-(Ubuntu 10.04) // Dreamlinux 3.5-(Debian)
Posts: 275
Blog Entries: 5

Original Poster
Rep: Reputation: 40
Quote:
Originally Posted by David the H. View Post
I doubt this has anything to do with Linux itself. It looks to me like a communication problem between the flash object and the script(s) on the page it's embedded in.

The only thing I can suggest is to check the security features (adblock/noscript/etc.) of your browser and make sure it's not blocking the connection.

Just where are you seeing this error message anyway?
it is on a facebook game, that is embedded on the facebook apps page. it's called Pet Society ... it super gay, But for some reason I play it anyway (them games is addictive) ... but all my other facebook games are good. They run smooth and start up immediately, but this one always shows me this message. I am at first able to see the loading screen, but before it can make it to 3% the ERROR pops up and takes up the whole page (it repeats about 5 times)
 
Old 04-21-2011, 02:38 PM   #5
Hevithan
Member
 
Registered: Apr 2011
Location: Washington State
Distribution: Zorin5-(Ubuntu 11.04) // Backtrack 5-(Ubuntu 10.04) // Dreamlinux 3.5-(Debian)
Posts: 275
Blog Entries: 5

Original Poster
Rep: Reputation: 40
Quote:
Originally Posted by EDDY1 View Post
Even wit sunjava jre I had problems until I found a key in /usr/lib/flashpluggin and double-clicked and imported key.
Now I admit my wrong and feel retarded ... Here we go:

I went to usr/lib, and saw the folder Adobeflash ... So I click it, and lo and behold it was empty. Went back to the lib file and was scrolling around, and see libflashplayer.so sitting all by it lonesome. made a copy of it, and inserted the flash.so file into the ADOBE folder, and my game is now working. Why it was out I don't know ... But thanks for the tip that lead the way
 
Old 04-21-2011, 03:14 PM   #6
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
You're welcome
I found by mistake.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
streaming video, flash games painfully sluggish with IGP320 video chipset Pete Yank Linux - Hardware 0 02-06-2011 02:56 PM
Firefox / Flash Player problem: Sometimes only audio works, video is white screen. NOoBuntuLinux Ubuntu 1 03-28-2009 11:16 PM
Fedora 9: error when compiling flash plug-in with error failed dependencies seow_ming Fedora 2 06-17-2008 08:17 PM
IceCast Problems [Error msg included] Nihilist Linux - Software 0 02-22-2006 09:54 PM
X won't load - no error msg - Windows works though lrt2003 Linux - General 2 04-28-2004 04:09 AM


All times are GMT -5. The time now is 03:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration