LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-14-2010, 06:15 AM   #1
your_shadow03
Senior Member
 
Registered: Jun 2008
Location: Germany
Distribution: Slackware
Posts: 1,461
Blog Entries: 6

Rep: Reputation: 51
Error during restarting apache


I have just compiled apache with the following command:

Code:
[root@ads-client bin]# ./configure --prefix=/opt/apache2 --enable-so --enable-rewrite --disable-cgi --disable-cgid --disable-autoindex --enable-nonportable-atomics=yes  --enable-setenvif  --enable-lib64 --libdir=/usr/lib64 --enable-proxy  --enable-modules=all
make and make install went fine.
But when I tried restarting apache through

cd /opt/apache2
cd bin
./apachectl -k restart

It threw error saying:
Code:
[root@ads-client bin]# ./apachectl -k restart
Syntax error on line 624 of /opt/apache2/conf/httpd.conf:
Invalid command 'IndexOptions', perhaps mis-spelled or defined by a module not included in the server configuration

[root@ads-client bin]#
I did googled and found a site http://www.netadmintools.com/part398.html which says Just load the module mod_autoindex into /opt/apache2/module and it will work. Is it correct way?

Last edited by your_shadow03; 02-14-2010 at 06:27 AM.
 
Old 02-14-2010, 07:08 AM   #2
smoker
Senior Member
 
Registered: Oct 2004
Distribution: Fedora Core 4, 12, 13, 14, 15, 17
Posts: 2,279

Rep: Reputation: 249Reputation: 249Reputation: 249
First I would check to see if autoindex_module is included in the LoadModule list in httpd.conf
If it is and it's commented out, uncomment it.
if it's not, then try commenting out line 624 of httpd.conf and see if the server starts ok without it. It's only for pretty icons when listing a directory.
Check to see if autoindex_module is actually in the modules directory too before adding another one.

Maybe you shouldn't have compiled with --disable-autoindex in the command !

The line to load the module should look like :
LoadModule autoindex_module modules/mod_autoindex.so

it should be with the others.

If it's there but looks like this :
#LoadModule autoindex_module modules/mod_autoindex.so
it's commented out, remove the #

Last edited by smoker; 02-14-2010 at 07:16 AM. Reason: more info
 
Old 04-14-2010, 10:43 PM   #3
johnh10000
Member
 
Registered: Nov 2008
Distribution: Ubuntu Lucid Lynx
Posts: 541

Rep: Reputation: 33
I would look in /etc/apache2/mods-available

see if required module is there.

if it is, brill!

then make a symlink to it in
root@tux:/etc/apache2/mods-enabled

example
/etc/apache2/mods-available/actions.conf

then to make availible

sudo ln -s /etc/apache2/mods-available/actions.conf /etc/apache2/mods-enabled/actions.conf

sudo services apache2 restart

Last edited by johnh10000; 04-14-2010 at 10:44 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache keeps restarting and slows down breadfan311 Linux - Server 0 05-06-2008 04:01 AM
Restarting Apache Server cooljai Linux - Server 2 12-14-2007 04:54 AM
Restarting apache fof3 Linux - Newbie 2 07-22-2006 11:01 PM
Apache keeps restarting with DaemonTools humbletech99 Linux - Networking 4 11-14-2005 11:51 AM
restarting Apache Xiled Linux - Networking 7 10-09-2001 11:24 AM


All times are GMT -5. The time now is 08:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration