LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-15-2008, 05:50 AM   #1
DRZ4007
LQ Newbie
 
Registered: Nov 2008
Posts: 7

Rep: Reputation: 0
"Error: Dependency is not justifiable: libglib 1.2".


Hello. I am trying to istall a .deb package and i keep getting the message "Error: Dependency is not justifiable: libglib 1.2". I installed through the synaptic all the packages that are related to libglib, but i keep getting the same message. The package i am trying to install is on a cd and it is a digital dictionary (if that helps). Does anybody have a clue? Thanx guys.
 
Old 11-16-2008, 09:37 AM   #2
NL-Stitch
Member
 
Registered: Jul 2004
Posts: 75

Rep: Reputation: 16
Please check if the package you want to install is available by apt, yum or a synaptic repository.

If it is, but installing still doesn't work try:

(Apt example):
Code:
apt-get install *package-name* --fix-missing
Hope that helps,

Cheers,
 
Old 11-16-2008, 11:51 AM   #3
DRZ4007
LQ Newbie
 
Registered: Nov 2008
Posts: 7

Original Poster
Rep: Reputation: 0
Unfortunately it doesn't exist over the internet. It's something i bought from a store...

When i try to install it in a terminal i get this:

va@va-desktop:~/Desktop$ sudo dpkg -i mgde_2006_i386.deb
Selecting previously deselected package mgde.
(Reading database ... 136917 files and directories currently installed.)
Unpacking mgde (from mgde_2006_i386.deb) ...
dpkg: dependency problems prevent configuration of mgde:
mgde depends on libgdk-pixbuf2 (>= 0.22.0); however:
Package libgdk-pixbuf2 is not installed.
mgde depends on libglib1.2 (>= 1.2.0); however:
Package libglib1.2 is not installed.
mgde depends on libgtk1.2 (>= 1.2.10-4); however:
Package libgtk1.2 is not installed.
dpkg: error processing mgde (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:


However, when i try to install all these "missing" packages i get the message that all of them are installed and up-to-date.

Any clues??

Last edited by DRZ4007; 11-17-2008 at 02:11 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
error: Error for wireless request "Set Mode" (8B06) : invalid argument "roaming" penguin chick Linux - Wireless Networking 5 08-22-2008 02:16 PM
Error When Installing Beryl "Dependency is not satisfiable" Heliodor Felpipe Ubuntu 4 02-02-2008 07:17 AM
Receiving constant error "Missing Dependency: /usr/bin/php is needed" GreenDragonComputers Linux - Software 3 05-09-2007 02:40 AM
"list dynamic dependency" of an executable using command other than "ldd" Amrita@3086 Solaris / OpenSolaris 3 04-04-2007 05:56 AM
apt-get upgrade error (stops at kernel due to "dependency issues") n0dl Debian 2 02-16-2007 07:20 PM


All times are GMT -5. The time now is 05:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration