LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-29-2013, 10:40 PM   #1
padalia.rushabh
LQ Newbie
 
Registered: Nov 2013
Location: Singapore
Distribution: Fedora , Ubuntu , Linux Mint
Posts: 8

Rep: Reputation: 0
Error compiling a package: "configure: error: no gstreamer-1.0 >= 1.0.0"


I am trying to compile a package, which requires gstreamer-1.0 >= 1.0.3. I think I have an older vesion installed on my system. So I downloaded and compiled gstreamer-1.0.4 and it got installed in /usr/local/lib/gstreamer-1.0.

After I did that, I again tried to compile the package but it still gives the same error that I dont have "gstreamer-1.0 >= 1.0.3" .

I also tried to export the path
"export LD_LIBRARY_PATH=/usr/local/lib/gstreamer-1.0"


"whereis gstreamer-1.0" outputs
gstreamer-1: /usr/lib64/gstreamer-1.0 /usr/local/lib/gstreamer-1.0 /usr/libexec/gstreamer-1.0 /usr/share/gstreamer-1.0

Actual Error Message
.....
.....
.....
checking for ORC... no
checking for GST... no
configure: No package 'gstreamer-1.0' found
configure: error: no gstreamer-1.0 >= 1.0.0 (GStreamer) found




I am using Fedora 19 64 bit

I need help because I am still trying to learn the basics!!
Thank you!!
 
Old 11-30-2013, 12:16 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016 CentOS6.9 CentOS7.3 + 50+ other Linux OS, for test only.
Posts: 16,684

Rep: Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284
Quote:
configure: No package 'gstreamer-1.0' found
The exact meaning is :
Not found = /usr/lib64/pkgconfig/gstreamer-1.0.pc ,
.. I.e. "package" means `package configuration file' : "gstreamer-1.0.pc" .

Solution : # yum install gstreamer1-devel
.. Which will provide version 1.0.7 :
/usr/lib64/pkgconfig/gstreamer-1.0.pc
http://dl.fedoraproject.org/pub/fedo...os/Packages/g/

Remark : All packages required for compiling must be <name>-devel.

-

Last edited by knudfl; 11-30-2013 at 12:19 AM.
 
1 members found this post helpful.
Old 02-28-2014, 09:06 AM   #3
rebncs
LQ Newbie
 
Registered: Feb 2014
Posts: 1

Rep: Reputation: Disabled
Exact same problem in Ubuntu

I'm having this exact issue in Ubuntu 13.10. Any chance of translating your excellent answer from Fedora to Ubuntu?

Thank you!

//Reid
 
Old 02-28-2014, 09:38 AM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016 CentOS6.9 CentOS7.3 + 50+ other Linux OS, for test only.
Posts: 16,684

Rep: Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284
Post #3, @rebncs : Welcome to LQ.

No "gstreamer-1.0.pc" ?

Ubuntu 13.10 : $ sudo apt-get install libgstreamer1.0-dev
 
1 members found this post helpful.
  


Reply

Tags
compile error, fedora 19, packages


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
server-error-internal-error with CUPS "Configure Printer" fskmh Slackware 6 06-05-2013 01:51 PM
configure error while cross compiling gstreamer for arm divya s Programming 2 11-23-2011 05:01 AM
"dpkg error in --configure" in most all (508) programs after "apt-get dist-upgrade" fluffymuffins Debian 3 08-09-2010 03:47 AM
receive error : "Configure : error: libxml2 must be installed" jonathan.vanderwatt Linux - Software 2 10-22-2007 02:16 PM
perl install error: Can't locate object method "new" via package "Module::Build::Vers powah Linux - Software 0 10-24-2006 01:57 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration