LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-03-2007, 11:34 PM   #16
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198

fdisk -l does nothing says something very odd about your drives. It means they are not detected (Ubuntu thinks there are no drives plugged in). Which is odd if the installation went without a hitch (the installer obviously saw them!)

Try entering your BIOS settings, hunt down the bit where SATA connections are set. Set to "legacy IDE" or equivalent (they call it different things).

The good news is that, apart from the ATA card, your HW is 100% Linux compatible. Feisty comes with a proprietary driver that should handle your cards special features.
 
Old 07-03-2007, 11:55 PM   #17
seanjc
LQ Newbie
 
Registered: Jul 2007
Posts: 11

Original Poster
Rep: Reputation: 0
EDIT:** Going through my BIOS again I didn't see anything that said SATA connection (or anything relatively close). The only part that I could think you were talking about was this:
SATA Primary Drive.......Off
SATA Secondary Drive.....Off
Primary Master Drive.....Hard Drive
Primary Slave Drive......Off
Secondary Master Drive...CD-ROM Device
Secondary Slave Drive....Off

IDE Drive UDMA...........On



I have to go to sleep for a small meeting tommorow, I'll be on around 8am Eastern.
Thanks you for your continued help,
Sean C.

Last edited by seanjc; 07-04-2007 at 12:17 AM.
 
Old 07-04-2007, 12:18 AM   #18
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 14,838

Rep: Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822
Quote:
Originally Posted by Simon Bridge
fdisk -l does nothing says something very odd about your drives.
Nope - Ubuntu requires sudo, else you get nothing. Real friendly - *NOT*
@seanjc,try this from a terminal
Code:
sudo fdisk -l
(will require your password)
In future, if you find trouble with commands, stick the "sudo" in front of it - it makes you root authorized ("god" for that command).
 
Old 07-04-2007, 12:19 AM   #19
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Quote:
I didn't (and still don't) know how to set up the bios for duel boot.
You don't need to do that... dual boot is set up in the bootloader (GRUB) and Ubuntu does that automagically... remember how you said yes to migrating windows?

To boot windows, when you see "grub loading", hit escape. This produces a menu (fingers crossed) and you highlight the option you want with the arrow keys, and hit enter to boot it.

However... this menu lives in sdb, which may not be accessible.

While we are talking about BIOS: it is possible that your BIOS is switching the drives off (as part of it's power saving routines). When you get into BIOS, try to switch off any "advanced power control" or similarily named "features". The linux kernel handles this anyway.

The url you gave doesn't take me to your machine... perhaps I need the right cookies? It is as support site that wants a customer or product ID. But I did find a wiki about the DELL PowerEdge 400sc... this it?

The wiki states that it will run Ubuntu 6.06 LTS ... so 7.04 should go.
While I see a lot of threads about this machine and Ubuntu, they have all got the install going right away.

This suggests something you could try... do a fixboot on the windows drive (so you can get back to XP if you need to ), switch off, and remove it. Set the 100GiB drive for primary master and reboot with the live CD. Now what does fdisk -l do?
 
Old 07-04-2007, 12:21 AM   #20
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Quote:
SATA Primary Drive.......Off
SATA Secondary Drive.....Off
... well: what happens when you switch them "On"?
 
Old 07-04-2007, 12:26 AM   #21
seanjc
LQ Newbie
 
Registered: Jul 2007
Posts: 11

Original Poster
Rep: Reputation: 0
yes that is the link to my machine, and what do you mean by a fixbot? <--software noob



EDIT:** Can't turn them on, there is no other option

Last edited by seanjc; 07-04-2007 at 12:28 AM.
 
Old 07-04-2007, 12:27 AM   #22
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Never mind, I think I know what is happening...
Quote:
SATA Primary Drive.......Off
SATA Secondary Drive.....Off
Primary Master Drive.....Hard Drive
Primary Slave Drive......Off
Secondary Master Drive...CD-ROM Device
Secondary Slave Drive....Off
... this is quite informative.

The 100GiB drive is not, in fact, the primary slave.
It is a sata drive and should show up as one of those sata connections.

My suspicion that the drive may be switched off in bios seems correct.

If you get to toggle on/off, that is fine. Double-check that the drive is correctly seen by BIOS and hunt the menus to see where to switch the SATA drives on. Switch off the advanced power management stuff (also called power save and ACPI and so on) hile you are there.



In root terminal, try "sudo fdisk -l" (JIC)
In the top panel, look at Places > Computer

Last edited by Simon Bridge; 07-04-2007 at 12:38 AM.
 
Old 07-04-2007, 12:42 AM   #23
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Quote:
Originally Posted by syg00
Nope - Ubuntu requires sudo, else you get nothing. Real friendly - *NOT*
@seanjc,try this from a terminal
Code:
sudo fdisk -l
(will require your password)
In future, if you find trouble with commands, stick the "sudo" in front of it - it makes you root authorized ("god" for that command).
These commands are being entered into a root terminal of the Ubuntu Desktop running in live mode.

I would have figured that these commands will run with root... however, I can see why this terminal may want to have restricted god-ness... but: there will be trouble if a password is required in sudo in live mode.
 
Old 07-04-2007, 12:49 AM   #24
seanjc
LQ Newbie
 
Registered: Jul 2007
Posts: 11

Original Poster
Rep: Reputation: 0
Disk /dev/sda: 40.0 GB, 40000000000 bytes
255 heads, 63 sectors/track, 4863 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sda1 * 1 4862 39053983+ 7 HPFS/NTFS

Disk /dev/sdb: 100.2 GB, 100256292864 bytes
255 heads, 63 sectors/track, 12188 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sdb1 * 1 11811 94871826 83 Linux
/dev/sdb2 11812 12188 3028252+ 5 Extended
/dev/sdb5 11812 12188 3028221 82 Linux swap / Solaris

sudo worked
i turned the SATA primary and secondary on but
what if i was wrong and they aren't SATA, I was sure i bought SATA but..

oh and I can see the hard drives when I go through computer part in linux

Last edited by seanjc; 07-04-2007 at 12:53 AM.
 
Old 07-04-2007, 01:02 AM   #25
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Cool! and thanks sig00.

/dev/sda1 = windows
(Hey: you don't have a system partition!)

/dev/sdb1 is linux root... good.

You would know if you installed sata... the connector is very small compared with the IDE connector. The cable is also different.

Remove the CD and reboot... see what happens.

Last edited by Simon Bridge; 07-04-2007 at 01:07 AM.
 
Old 07-04-2007, 01:18 AM   #26
seanjc
LQ Newbie
 
Registered: Jul 2007
Posts: 11

Original Poster
Rep: Reputation: 0
Bad News: same error and no option to boot into either OS

Good News: I was an idiot and I do have PATA hard drives... I just checked... guess i'm just used to my work computer...
 
Old 07-04-2007, 01:20 AM   #27
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Your BIOS says the primary slave is "Off".
Find out how to turn it "On".
Oh... nad make sure it is jumpered to slave.

Last edited by Simon Bridge; 07-04-2007 at 01:21 AM.
 
Old 07-04-2007, 01:22 AM   #28
seanjc
LQ Newbie
 
Registered: Jul 2007
Posts: 11

Original Poster
Rep: Reputation: 0
That was it! Thank you so much! I know have the options to what I want to boot to when I start my computer, i'm on XP right now posting this.

Thank you so much for your time and help!
I'm going to bed at 1:30am, way earlier than I would have without your help.
Sean C.

Last edited by seanjc; 07-04-2007 at 01:30 AM.
 
Old 07-04-2007, 01:40 AM   #29
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Excellent... notice that this was not a linux problem. This was a BIOS "gotcha": everything is working as designed, but not as expected - leading to confusion.

Try booting into Ubuntu as a regular user... you will not have a root terminal as a regular user but you don't normally need one.

I sense that you are already feeling much more confident about your computer skills and have a better understanding of computer internals

I'm gonna give you a basic tutorial about the gnome desktop and the gnome terminal. Also a good wiki page.

http://ualug.ece.auckland.ac.nz/tutorial.tar.gz
... the tutorial is specific to UA (NZ) but is easy to parse. You have to download the tarball (.tar.gz file) and double-click it to open it. The tutorials are pdf files in there and provide a crash-course.

http://ubuntuguide.org/wiki/Ubuntu_Feisty
... a set of howto's for common things people want to do... including how to set up Beryl (ta da!)

Some notes:

Beryl + ATI is annoying (ATI linux support has really slumped lately ... politics and contracts) but doable. If you have the option to use nvidia, do so.

Beryl is alpha code - and quite unstable. But not nastily so. (Should it crash, it just drops down to a non 3D desktop... no data loss, no system freeze, no blue screen.)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Error.. I got during Restart Linux System is " [drm-i830-wait-ring] *Error*Lookup" zameer_india Linux - Networking 0 09-29-2004 05:25 AM


All times are GMT -5. The time now is 07:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration