LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-12-2014, 10:46 AM   #1
normt2707
LQ Newbie
 
Registered: Nov 2014
Posts: 2

Rep: Reputation: Disabled
Smile Epson Workforce 520 Printer Scanner Copier


Hi, I have an Epson Workforce 520 Printer Scanner Copier and am using Linux Mint 17 Cinamon. The drivers have installed. When I try to print a test page, the status shows that it is 17% done and it stalls there. Does anyone have any suggestions to correct this problem? Thank you from a newbie who wants to learn and use Linux exclussively.

Norm

Last edited by normt2707; 11-12-2014 at 12:29 PM. Reason: Software installed but not printing yet.
 
Old 11-12-2014, 11:51 AM   #2
DavidMcCann
Senior Member
 
Registered: Jul 2006
Location: London
Distribution: CentOS, Salix
Posts: 4,271

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Welcome to Linux Questions!

If the Ubuntu icon under your signature is what you're using, you've got the wrong driver: the extension should be .deb and not .rpm.

Go here
http://download.ebz.epson.net/dsc/se...search/?OSC=LX
and enter the name of the device. You'll be taken to a page where you can select both printer and scanner drivers. Choose full-feature driver for the printer, accept the conditions, and download the deb file for i386 (32-bit) or amd64 (64-bit).

To install, see this guide
http://www.cyberciti.biz/faq/ubuntu-...-deb-packages/

PS You really shouldn't use an email address as a signature: there are spiders out there searching for them, so it's the quickest way to build a world-class spam collection!

Last edited by DavidMcCann; 11-12-2014 at 11:55 AM.
 
Old 11-12-2014, 10:32 PM   #3
normt2707
LQ Newbie
 
Registered: Nov 2014
Posts: 2

Original Poster
Rep: Reputation: Disabled
Thank you
Quote:
Originally Posted by normt2707@gmail.com View Post
Hi, I have an Epson Workforce 520 Printer Scanner Copier and am using Linux Mint 17 Cinamon. The drivers have installed. When I try to print a test page, the status shows that it is 17% done and it stalls there. Does anyone have any suggestions to correct this problem? Thank you from a newbie who wants to learn and use Linux exclussively.

Norm
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Epson Workforce 840 Scanner pablo27 Linux Mint 9 10-16-2013 12:53 AM
[SOLVED] LM13, Epson workforce 520 wireless network printer was there, gone after update travalon Linux - Hardware 1 06-24-2012 01:45 AM
[SOLVED] Epson Workforce 520 on Fedora 15 prints blank pages dchester11 Linux - Hardware 4 10-12-2011 01:35 PM
Epson CX3810 printer/scanner/copier d1l2w3 Linux - Hardware 4 08-19-2006 10:59 AM
Epson CX3200 Printer/Scanner/Copier ksilver Linux - Hardware 1 12-01-2003 01:08 AM


All times are GMT -5. The time now is 10:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration