LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 12-27-2001, 06:42 AM   #1
kyutums
LQ Newbie
 
Registered: Dec 2001
Posts: 6

Rep: Reputation: 0
entering RedHat 7.2 in text mode


Is there a way to enter my RedHat 7.2 system in text mode? I have to change monitor settings because the new one can't handle the refresh rates of my old setting. I don't have my rescue disk nor my RedHat 7.2 cds with me.

Thanks for all your help.
 
Old 12-27-2001, 09:42 AM   #2
d3funct
Member
 
Registered: Jun 2001
Location: Centralia, WA
Posts: 274

Rep: Reputation: 31
I assume that your system starts you in an X session (KDE, GNOME etc..) and you want to exit this session? If this is correct all you have to do is type [CTRL]+[ALT]+backspace to exit your x session, then (AS ROOT) edit the /etc/inittab and change the line that reads:

id:5:initdefault:

to read

id:3:initdefault:

This will make it so you start in text mode upon restart.

You can run the "setup'" command (as root) to reconfigure X.
 
Old 12-27-2001, 09:56 AM   #3
bluecadet
Member
 
Registered: Oct 2001
Distribution: MD81 RH71
Posts: 555

Rep: Reputation: 30
well, if you're on runlevel 5, then ctrlaltbackspace will will X, but respawn xdm, so tha's no use. just edit the text file in a terminal window, or wherever else you feel like.
 
Old 12-27-2001, 01:03 PM   #4
kyutums
LQ Newbie
 
Registered: Dec 2001
Posts: 6

Original Poster
Rep: Reputation: 0
I try to exit X via ctrl-alt-backspace in order to edit /etc/inittab, but X just restarts. Is there still any way to edit the /etc/inittab file?

Thanks.
 
Old 12-28-2001, 03:06 AM   #5
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
Try ctrl-alt-f1...f6 and see if you can get a console window. If you do, log in as root and run the command ' init 3 '. That will take you out of runlevel 5 and you can redo your X settings. When you want to try out your new settings, just run ' init 5 '. I hope this helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't install RedHat in text mode Walt.H. Red Hat 5 09-02-2004 05:27 PM
Problem with Geforce FX 5200 when entering text/console mode psandhu Linux - Newbie 3 03-22-2004 04:51 PM
How to configure network in text mode (RedHat 7.3) exceter Red Hat 5 10-01-2003 01:23 AM
Switching RedHat to boot into Text Mode quordandis Linux - Newbie 1 09-12-2003 07:13 PM
Redhat 7.0 text mode Nocona Linux - Newbie 2 06-30-2001 11:18 AM


All times are GMT -5. The time now is 06:28 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration