LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 09-15-2011, 08:43 AM   #1
paruhang
Member
 
Registered: Aug 2011
Location: /home
Posts: 96

Rep: Reputation: Disabled
enter password for default keyring to unlock


hellow everybody,
when i try to connect my local wireless the following messages appear

enter a password for default keyring to unlock

the application 'NetworkManager Applet' (/usr/bin/nm-applet) wants access to the default keyring, but it is locked.


i havent changed anything in /usr/bin/nm-applet but how it happen.can anybody help me iam new linux user and i don't know about that,i'll be greatful if anybody guide me in right way.
 
Old 09-15-2011, 09:53 AM   #2
ifranklin
Member
 
Registered: May 2010
Location: Nairobi, Kenya
Distribution: Ubuntu
Posts: 66

Rep: Reputation: 3
this happens if your machine is configure to auto-login as of the time of installing the operating system. but there is a workaround guide to disable this, however considering your problem happens when you want to connect to a wireless network, the fastest and safe way to correct your problem is by doing:
- Right click on your Network Icon (Wireless manager) in the tray and click edit connections
- click on the wireless tab
- highlight your wireless connection and click edit;
- at the bottom there is a checkbox called "Available to all users", click on it
- click 'apply' to save your changes
- it will ask you for your password because that is a change that will affect the whole system, enter the password and click enter, thats ok now, your network will always be available without necessarily asking for your password and anyone can always use it.
 
1 members found this post helpful.
Old 09-15-2011, 01:05 PM   #3
samtoddler
Member
 
Registered: Jul 2011
Location: Delhi
Distribution: Cent OS/RHEL
Posts: 37

Rep: Reputation: Disabled
enter password for default keyring to unlock

Quote:
Originally Posted by ifranklin View Post
this happens if your machine is configure to auto-login as of the time of installing the operating system.
no its not like that I've configured my machine as autologin but still it asks me for the same question
You can manage the keyring password with system -> administration ->keyring .
You can even make them<password> different or even can delete that.


samtoddler


but there is a workaround guide to disable this, however considering your problem happens when you want to connect to a wireless network, the fastest and safe way to correct your problem is by doing:
- Right click on your Network Icon (Wireless manager) in the tray and click edit connections
- click on the wireless tab
- highlight your wireless connection and click edit;
- at the bottom there is a checkbox called "Available to all users", click on it
- click 'apply' to save your changes
- it will ask you for your password because that is a change that will affect the whole system, enter the password and click enter, thats ok now, your network will always be available without necessarily asking for your password and anyone can always use it.[/QUOTE]
 
1 members found this post helpful.
Old 09-16-2011, 02:00 PM   #4
paruhang
Member
 
Registered: Aug 2011
Location: /home
Posts: 96

Original Poster
Rep: Reputation: Disabled
thank you ifranklin and samtoddler;
 
Old 02-19-2012, 07:46 PM   #5
1GnuPenguin
LQ Newbie
 
Registered: Mar 2011
Location: Manchester, NH USA
Distribution: Linux Mint 9
Posts: 2

Rep: Reputation: 0
Smile Password for Keyring to access network

Thanks, ifranklin:

I was having the same problem, signing on to network that was set up as auto-connect, but had to change the user password because I lost it, but Keyring still had the original user password, and I couldn't access it.
I could get onto the network, but had to enter the "Key" each time I signed on. Then it would prompt me to enter the Keyring password, and I found that when I cancelled that, it still let me sign on.

I used your procedure to make "available for all users" and now it works fine. It connects automatically without having to enter the key and doesn't prompt me for Keyring password.

Thanks

1GnuPenguin

Last edited by 1GnuPenguin; 02-19-2012 at 07:50 PM. Reason: Change Title
 
Old 03-28-2013, 05:57 PM   #6
akuang
LQ Newbie
 
Registered: Mar 2013
Location: costamesa, ca
Posts: 1

Rep: Reputation: Disabled
Encountered the same issue with "keyring"

some provided instructions were not cleared.
I have a Linux OS on ThinkPad and my "network connection icon did not display the same options as provided.
Please help.
Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with "Enter password to unlock your login keyring" varunkernex Linux - Newbie 4 06-30-2011 03:57 AM
Enter password to unlock your login keyring TigerLinux Ubuntu 4 06-29-2011 12:45 PM
how to remove "Enter password for default keyring tu unlock" Revanvar Linux - Newbie 2 03-19-2011 12:01 PM
Enter Password for Default Keyring to Unlock Ubuntu213 Linux - Newbie 4 12-30-2010 03:05 PM
The "Enter Password to Unlock Desktop" disappears after 4 seconds? as400 Solaris / OpenSolaris 3 05-07-2006 12:20 PM


All times are GMT -5. The time now is 09:51 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration