LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   enter password for default keyring to unlock (http://www.linuxquestions.org/questions/linux-newbie-8/enter-password-for-default-keyring-to-unlock-903166/)

paruhang 09-15-2011 08:43 AM

enter password for default keyring to unlock
 
hellow everybody,
when i try to connect my local wireless the following messages appear

enter a password for default keyring to unlock

the application 'NetworkManager Applet' (/usr/bin/nm-applet) wants access to the default keyring, but it is locked.


i havent changed anything in /usr/bin/nm-applet but how it happen.can anybody help me iam new linux user and i don't know about that,i'll be greatful if anybody guide me in right way.

ifranklin 09-15-2011 09:53 AM

this happens if your machine is configure to auto-login as of the time of installing the operating system. but there is a workaround guide to disable this, however considering your problem happens when you want to connect to a wireless network, the fastest and safe way to correct your problem is by doing:
- Right click on your Network Icon (Wireless manager) in the tray and click edit connections
- click on the wireless tab
- highlight your wireless connection and click edit;
- at the bottom there is a checkbox called "Available to all users", click on it
- click 'apply' to save your changes
- it will ask you for your password because that is a change that will affect the whole system, enter the password and click enter, thats ok now, your network will always be available without necessarily asking for your password and anyone can always use it.

samtoddler 09-15-2011 01:05 PM

enter password for default keyring to unlock
 
Quote:

Originally Posted by ifranklin (Post 4472504)
this happens if your machine is configure to auto-login as of the time of installing the operating system.

no its not like that I've configured my machine as autologin but still it asks me for the same question
You can manage the keyring password with system -> administration ->keyring .
You can even make them<password> different or even can delete that.


samtoddler


but there is a workaround guide to disable this, however considering your problem happens when you want to connect to a wireless network, the fastest and safe way to correct your problem is by doing:
- Right click on your Network Icon (Wireless manager) in the tray and click edit connections
- click on the wireless tab
- highlight your wireless connection and click edit;
- at the bottom there is a checkbox called "Available to all users", click on it
- click 'apply' to save your changes
- it will ask you for your password because that is a change that will affect the whole system, enter the password and click enter, thats ok now, your network will always be available without necessarily asking for your password and anyone can always use it.[/QUOTE]

paruhang 09-16-2011 02:00 PM

thank you ifranklin and samtoddler;

1GnuPenguin 02-19-2012 07:46 PM

Password for Keyring to access network
 
Thanks, ifranklin:

I was having the same problem, signing on to network that was set up as auto-connect, but had to change the user password because I lost it, but Keyring still had the original user password, and I couldn't access it.
I could get onto the network, but had to enter the "Key" each time I signed on. Then it would prompt me to enter the Keyring password, and I found that when I cancelled that, it still let me sign on.

I used your procedure to make "available for all users" and now it works fine. It connects automatically without having to enter the key and doesn't prompt me for Keyring password.

Thanks

1GnuPenguin

akuang 03-28-2013 05:57 PM

Encountered the same issue with "keyring"
 
some provided instructions were not cleared.
I have a Linux OS on ThinkPad and my "network connection icon did not display the same options as provided.
Please help.
Thanks


All times are GMT -5. The time now is 07:44 PM.