LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-16-2012, 08:48 PM   #1
minty33
Member
 
Registered: Aug 2012
Location: earth
Distribution: Mint Xfce, Korora Gnome3, Ubuntu Server NoGui,
Posts: 136

Rep: Reputation: 1
encrypted home passphrase ?


i just installed mint13 xfce w/ encrypted home directory. When i booted up the normal prompt that asks to run utility to get your 32 digit passphrase never started. I tried to enter ecryptfs-unwrap-passphrase but it asks for a file (i.e ecryptfs-unwrap-passphrase [file]) what do i enter as the [file].
i also used ecryptfs-recover-private and got a 16 digit auth tok added to the user session keyring and then it mounted my un-encrypted home directory into /tmp. first did i mess anything up doing this and second i'm pretty sure that the auth tok is not the passphrase i'm looking for. (i unmounted that directory from /tmp is that o.k also)
any help appreciated.
 
Old 09-24-2012, 05:42 PM   #2
SecretCode
Member
 
Registered: Apr 2011
Location: UK
Distribution: Kubuntu 11.10
Posts: 562

Rep: Reputation: 102Reputation: 102
Quote:
Originally Posted by minty33 View Post
I tried to enter ecryptfs-unwrap-passphrase but it asks for a file (i.e ecryptfs-unwrap-passphrase [file]) what do i enter as the [file].
Try
Code:
ecryptfs-unwrap-passphrase ~/.ecryptfs/wrapped-passphrase
 
Old 09-24-2012, 06:41 PM   #3
minty33
Member
 
Registered: Aug 2012
Location: earth
Distribution: Mint Xfce, Korora Gnome3, Ubuntu Server NoGui,
Posts: 136

Original Poster
Rep: Reputation: 1
Cool thanx secretcode

Unfortunately I reinstalled the OS w/ out encrypted home. I really didn't need encryption on this machine as there is nothing personal or sensitive on it. Part of the reason I reinstalled is because in my trials at some point I got output that said ecrypt was not installed correctly. I don't remember what command gave me that feedback but I just gave up. I was too busy w/ school to worry about a feature I don't need on that box anyway. Thanx for your feedback though. I'll keep this in mind when I get around to trying ecrypt on mint in the future. I will say it shouldn't give the option if its not going to launch the set up part like Ubuntu or xubuntu does. OH well.
i'll assume your answer and mark this solved anway

Last edited by minty33; 09-28-2012 at 08:33 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Encrypted, LVM volume /home not recognizing (global) passphrase and so not mounting saivnoba Fedora 3 10-30-2011 11:24 AM
How to use USB key for passphrase for encrypted /Data? tommyttt Linux - General 1 05-18-2011 03:37 AM
[SOLVED] How does one change login passphrase (to unlock encrypted home directory) tonyfreeman Linux - Security 4 11-22-2010 09:12 PM
[SOLVED] Encrypted partition get mounted without being asked for a passphrase? x111 Linux - Security 6 09-25-2010 05:46 AM
Sucessfully encrypted partition with a passphrase bobbelfield Linux - Security 1 02-04-2006 10:37 PM


All times are GMT -5. The time now is 02:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration