LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 02-23-2002, 12:04 AM   #1
pacifist
LQ Newbie
 
Registered: Feb 2002
Posts: 3

Rep: Reputation: 0
Question enabling the "talk" in linux


i am trying to use the talk utility on the linux.

i am a total newcommer to linux but know a few things here and there.

when i type talk and the user name, i always get the follwing message..

" Error on read from talk daemon : Connection refused"

I do not know whats going wrong. is these something wrong with the configuration.. ??

Please help me out...

thanks..
 
Old 02-24-2002, 10:35 PM   #2
crabboy
Moderator
 
Registered: Feb 2001
Location: Atlanta, GA
Distribution: Slackware
Posts: 1,823

Rep: Reputation: 120Reputation: 120
Check the file /etc/inetd.conf and look for the line:
Code:
# talk  dgram   udp     wait    root    /usr/sbin/tcpd  in.talkd
If there is a #, remove it.

If you make changes to inetd.conf you will need to either reboot, restart the inetd or send the inetd process a HUP signal to tell it to reread the inetd.conf.

Code:
ps -ef | grep inetd
kill -HUP <pid of inetd>
 
Old 02-25-2002, 12:56 AM   #3
kausik
LQ Newbie
 
Registered: Feb 2002
Location: Baruipur, India
Distribution: Red Hat 9.0
Posts: 29

Rep: Reputation: 15
Start talkd and 'talk'

Hello!

Do the following :

linuxconf > Control > Control Panel > Control Service Activity.

Select 'talk' and 'start' it.
If status is not changed to 'Running' - 'talkd' is not installed on ur server. Install that from CD.

If it starts and u always need 'talkd' to start check Automatic.

Kausik

 
Old 02-25-2002, 11:44 PM   #4
pacifist
LQ Newbie
 
Registered: Feb 2002
Posts: 3

Original Poster
Rep: Reputation: 0
Thankx for the replies..
i tried the things that you told me...

I do not have a inetd.conf instead "xinetd.conf" . i guess its equivelent to the former.

I saw the contents of the xinetd.conf . The dir. xinetd.d was included in that file.
In that dir. there is a talk file which has some parameters for talk.
i made disable=no , all other parameters have the default values.
the wait=yes, user=nobody, socket_type=dgram, server=/usr/sbin/in.talkd

then i restarted the linux server,, but still i have the same problem and the same error message.

Did I do something wrong ? is there anything more to do ?

PL. tell.
 
Old 02-26-2002, 12:02 AM   #5
crabboy
Moderator
 
Registered: Feb 2001
Location: Atlanta, GA
Distribution: Slackware
Posts: 1,823

Rep: Reputation: 120Reputation: 120
oops... I should have tested it. To enable talk on my system I also had to uncomment the next line:
Code:
# ntalk dgram   udp     wait    root    /usr/sbin/tcpd  in.talkd
I'm guessing you can figure out what you have to do for your distro.
 
Old 09-13-2002, 02:44 AM   #6
bock
LQ Newbie
 
Registered: May 2002
Location: sacramento
Distribution: Bock Hat 7.2
Posts: 11

Rep: Reputation: 0
Thumbs up try ntalk

try:

vim /etc/xinet.d/ntalk

and setting disable = no

NOTE ntalk (not sure if it has to be in conjunction wth talk or not).

-bock
 
Old 10-01-2002, 12:56 AM   #7
micxz
Senior Member
 
Registered: Oct 2002
Location: CA
Distribution: openSuSE, Cent OS, Slackware
Posts: 1,131

Rep: Reputation: 75
Did anyone figure this out?

[root@zeus micxz]# /usr/sbin/in.talkd
Socket operation on non-socket

I'm trying the get the same thing working on three servers. ?? Still having issues.
 
Old 09-16-2003, 02:14 PM   #8
kwiks
LQ Newbie
 
Registered: Sep 2003
Posts: 2

Rep: Reputation: 0
Socket op on non-socket

This is simply driving me up the proverbial tree :-)

Has anyone given a working solution to this problem? I would be very grateful if someone could indicate or hint at how to start in.talkd (or in.ntalkd) on a Redhat 9.0 system WITHOUT getting a "Socket operation on non-socket" error.

MANY MANY THANKS,

Kwiks.
 
Old 09-16-2003, 02:33 PM   #9
micxz
Senior Member
 
Registered: Oct 2002
Location: CA
Distribution: openSuSE, Cent OS, Slackware
Posts: 1,131

Rep: Reputation: 75
OK this is how I fixed it.

1. cd /etc/xinetd.d/

2. Use vi or your favorite text ditor as root to edit the files,
"talk" and "ntalk" Change the lines, "disable = yes" to "disable = no" in both files

3. /etc/init.d/xinetd restart

Done.
Should work to all local users, you may experience issues if trying to connect to remote computer or trying to use talk over the local network or the internet for that matter. Good luck'

Micxz
 
Old 09-16-2003, 03:03 PM   #10
micxz
Senior Member
 
Registered: Oct 2002
Location: CA
Distribution: openSuSE, Cent OS, Slackware
Posts: 1,131

Rep: Reputation: 75
Also Note:

talk requires:
libc.so.6
libncurses.so.5

And

ntalk requires:
libc.so.6
libncurses.so.5
libtinfo.so.5
glibc
ncurses

Last edited by micxz; 09-16-2003 at 03:07 PM.
 
Old 09-17-2003, 02:21 PM   #11
kwiks
LQ Newbie
 
Registered: Sep 2003
Posts: 2

Rep: Reputation: 0
in.talk on RH9

Thanks for your prompt reply. Had already done all of that and checked the libs. No joy!

I am trying to get people over a network to "talk" to each other and it's turning out to be a nightmare with RH9. Maybe I should switch distros. :-(

Cheers,
Kwiks.
 
Old 09-17-2003, 05:05 PM   #12
micxz
Senior Member
 
Registered: Oct 2002
Location: CA
Distribution: openSuSE, Cent OS, Slackware
Posts: 1,131

Rep: Reputation: 75
Does it work locally?
Do you run a firewall on either of the networked boxes?
Are you using inetd or xinetd?
 
Old 11-11-2003, 03:41 PM   #13
crickett
LQ Newbie
 
Registered: Jun 2003
Posts: 13

Rep: Reputation: 0
i'm having the same problems.
i'm running redhat 9
all the /etc/xinnet.d/talk ntalk ktalk have the disable=no
i have restarted xinetd service
i am on a single switch from
i can talk on local account
yet not over the network ie. talk crickett@192.168.0.2 from 192.168.0.3

suggestions

there seems to be no howto;s out there that discuss this

uggh

Crickett
 
Old 11-11-2003, 03:55 PM   #14
micxz
Senior Member
 
Registered: Oct 2002
Location: CA
Distribution: openSuSE, Cent OS, Slackware
Posts: 1,131

Rep: Reputation: 75
If you guys are getting this to work locally, then it's another network configuration that are preventing this to work over the "network".

Does it work on the internal "network"? and localhost? If yes and not on the "internet". Then you consider most likely a firewall is blocking the port this service uses? Or the firewall on the host your trying to talk to has this port closed also. See what I getting at here guys?
 
Old 11-11-2003, 04:16 PM   #15
crickett
LQ Newbie
 
Registered: Jun 2003
Posts: 13

Rep: Reputation: 0
ok this is located on a local network
ie computers are both connected into a switch
port 517 518 are closed
this is the issue
i'm needing to open these ports

yet i understand that xinetd manages the ports and services and keeps them closed until needed. so do i open the ports to allow the talkd? should i goto inetd instead of xinetd?

Crickett
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
chrooted user: "write" and "talk" don't work. ldp Linux - Software 2 04-12-2005 03:05 AM
enabling "cool 'n' quiet" on linux guy24x Linux - Hardware 2 03-24-2005 06:49 PM
"Could not start process - Can't talk to Klauncher" ?? Sean Murphy Linux - Newbie 3 10-21-2003 12:28 PM
making 2 wireless pci cards "talk" yocompia Slackware 1 08-01-2003 06:29 PM
why cannot "talk" to others,since mesg is yes and disable = no(in /etc/xinetd.c/talk) whepin Linux - Newbie 0 12-31-2001 03:04 AM


All times are GMT -5. The time now is 12:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration