LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-18-2004, 06:25 AM   #1
vickr1z
Member
 
Registered: Mar 2004
Location: manila, philippines
Distribution: RH 7.3
Posts: 63

Rep: Reputation: 15
enabling tcp/ip connection via pg_ctl


good day to all. how can i add this '-i' option for tcp/ip enable on my rc.postgres script?
here's my script:
Code:
#! /bin/sh

# chkconfig: 2345 98 02
# description: PostgreSQL RDBMS

# This is an example of a start/stop script for SysV-style init, such
# as is used on Linux systems.  You should edit some of the variables
# and maybe the 'echo' commands.
#
# Place this file at /etc/rc.d/rc.postgresql (or
# /etc/rc.d/init.d/rc.postgresql) and make symlinks to
#   /etc/rc.d/rc0.d/K02postgresql
#   /etc/rc.d/rc1.d/K02postgresql
#   /etc/rc.d/rc2.d/K02postgresql
#   /etc/rc.d/rc3.d/S98postgresql
#   /etc/rc.d/rc4.d/S98postgresql
#   /etc/rc.d/rc5.d/S98postgresql
# Or, if you have chkconfig, simply:
# chkconfig --add postgresql
#
# Proper init scripts on Linux systems normally require setting lock
# and pid files under /var/run as well as reacting to network
# settings, so you should treat this with care.

# Original author:  Ryan Kirkpatrick <pgsql@rkirkpat.net>

# $Header: /cvsroot/pgsql/contrib/start-scripts/linux,v 1.3 2001/07/30 

## EDIT FROM HERE

# Installation prefix
prefix=/usr/local/pgsql

# Data directory
PGDATA="/var/pgsql/data"

# Who to run pg_ctl as, should be "postgres".
PGUSER=postgres

# Where to keep a log file
PGLOG="$PGDATA/server.log"

## STOP EDITING HERE

# Check for echo -n vs echo \c
if echo '\c' | grep -s c >/dev/null 2>&1 ; then
     ECHO_N="echo -n"
     ECHO_C=""
else
     ECHO_N="echo"
     ECHO_C='\c'
fi

# The path that is to be used for the script
PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/pgsql/bin

# What to use to start up the postmaster
DAEMON="$prefix/bin/pg_ctl"

set -e

# Only start if we can find pg_ctl.
test -f $DAEMON || exit 0

# Parse command line parameters.
case $1 in
   start)
         $ECHO_N "Starting PostgreSQL: "$ECHO_C
         su - $PGUSER -c "$DAEMON start -D '$PGDATA' -s -l $PGLOG"
         echo "ok"
         ;;
   stop)
         echo -n "Stopping PostgreSQL: "
         su - $PGUSER -c "$DAEMON stop -D '$PGDATA' -s -m fast"
         echo "ok"
         ;;
   restart)
         echo -n "Restarting PostgreSQL: "
         su - $PGUSER -c "$DAEMON restart -D '$PGDATA' -s -m fast"
         echo "ok"
         ;;
   status)
         su - $PGUSER -c "$DAEMON status -D '$PGDATA'"
         ;;
   *)
         # Print help
         echo "Usage: $0 {start|stop|restart|status}" 1>&2
         exit 1
         ;;
esac

exit 0
When i try editing the script at line case$1 like this:
Code:
 ....su - $PGUSER -c "$DAEMON start -D '-i-' '$PGDATA' -s 'l $PGLOG"
It doesnt work..

hope u can help me.. any idea will appreciate very much thanks you.
 
Old 10-19-2004, 05:02 AM   #2
iluvatar
Member
 
Registered: Jul 2003
Location: netherlands
Distribution: debian
Posts: 403

Rep: Reputation: 30
I think you should change the '-i-' to -i (leave the quotes!). second way is to edit the /var/pgsql/data/postgresql.conf file and search for 'tcpip_socket' and set it to true. in the config file you may change more options for the connections

greetz,
.-=~ iluvatar ~=-.
 
Old 10-19-2004, 05:27 AM   #3
vickr1z
Member
 
Registered: Mar 2004
Location: manila, philippines
Distribution: RH 7.3
Posts: 63

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by iluvatar
I think you should change the '-i-' to -i (leave the quotes!). second way is to edit the /var/pgsql/data/postgresql.conf file and search for 'tcpip_socket' and set it to true. in the config file you may change more options for the connections

greetz,
.-=~ iluvatar ~=-.
hi thanks for ur reply.

the -i option on pg_ctl does not support it alone so they say it has to be with single quote. the postmaster only has this -i option. anyways i tried it ur suggestion but it does not work either..

any other suggestion will appreciate very much.
 
Old 10-19-2004, 07:21 AM   #4
iluvatar
Member
 
Registered: Jul 2003
Location: netherlands
Distribution: debian
Posts: 403

Rep: Reputation: 30
didn't know about the -i thing, but editing the config file should work... at least it does so on my systems. is there some error message maybe while starting postgresql?

greetz,
.-=~ iluvatar ~=-.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
TCP/IP enabling linuxhippy Slackware 5 06-12-2005 08:36 PM
hijacking tcp connection atul_mehrotra Linux - Networking 4 04-30-2005 01:50 AM
Enabling X11 external connection for X Win32 Wags Linux - Networking 0 12-03-2003 10:25 PM
MySQL connection over TCP/IP fails Rukawa Linux - Software 4 11-30-2003 12:30 AM
Unable to get TCP/IP connection kgunnar Linux - Newbie 9 05-01-2002 05:24 AM


All times are GMT -5. The time now is 08:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration