LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 11-24-2003, 11:58 AM   #1
DogTags
LQ Newbie
 
Registered: Nov 2003
Posts: 24

Rep: Reputation: 15
Enabling SSH in mandrake 9.2 - sshd vs. sshd-xinetd


Hi All

Been trying to get ssh to work on Mandrake 9.2, reading lots-o-threads

Services

- The sshd service is running, but there is no /etc/xinetd.d/sshd file

- The sshd-xinetd service is not running, but a /etc/xinetd.d/sshd-xinetd file exists

- Another thing about the sshd-xinetd service is that it has an empty checkbox next to "Start when requested", but when you click the Info button, it tells you "sshd server, xinetd version. Don't run the standalone version if you run this."

------

1. Which version should we try to run? sshd or sshd-xinetd? How are they different?

2. What are we missing? We've tried to access via ssh by running first the sshd and then sshd-xinetd, but can't connect through either a user account or root

Thanks very much
 
Old 11-24-2003, 01:25 PM   #2
Mikhail_16
Member
 
Registered: Oct 2003
Distribution: Gentoo rules them all
Posts: 279

Rep: Reputation: 31
sshd is good. Thats all you need.

do 'locate ssh_config' to find out where the config file is.

Last edited by Mikhail_16; 11-24-2003 at 01:31 PM.
 
Old 11-24-2003, 03:38 PM   #3
DogTags
LQ Newbie
 
Registered: Nov 2003
Posts: 24

Original Poster
Rep: Reputation: 15
Okay, I've located ssh_config:

/etc/ssh/ssh_config

There is also:

/etc/ssh/sshd_config

-----

Here is my ssh_config:

Code:
#	$OpenBSD: ssh_config,v 1.16 2002/07/03 14:21:05 markus Exp $

# This is the ssh client system-wide configuration file.  See
# ssh_config(5) for more information.  This file provides defaults for
# users, and the values can be changed in per-user configuration files
# or on the command line.

# Configuration data is parsed as follows:
#  1. command line options
#  2. user-specific file
#  3. system-wide file
# Any configuration value is only changed the first time it is set.
# Thus, host-specific definitions should be at the beginning of the
# configuration file, and defaults at the end.

# Site-wide defaults for various options

# Host *
#   ForwardAgent no
#   ForwardX11 no
#   RhostsAuthentication no
#   RhostsRSAAuthentication no
#   RSAAuthentication yes
#   PasswordAuthentication yes
#   HostbasedAuthentication no
#   BatchMode no
#   CheckHostIP yes
#   StrictHostKeyChecking ask
#   IdentityFile ~/.ssh/identity
#   IdentityFile ~/.ssh/id_rsa
#   IdentityFile ~/.ssh/id_dsa
#   Port 22
#   Protocol 2,1
#   Cipher 3des
#   Ciphers aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour,aes192-cbc,aes256-cbc
#   EscapeChar ~

Host *
  ForwardX11 yes
  Protocol 2,1
    StrictHostKeyChecking no
-------------------------------------

1. Should I change anything?

2. In the Mandrake Control Panel, there is no "ssh" service. There ones listed are:

- sshd (which is started at boot)
- sshd-xinetd (which is dormant until called)

3. Is something missing? Should there be an "ssh" service listed in the Mandrake Control Panel?

-------------------------------------

Thanks for your help

Last edited by DogTags; 11-24-2003 at 03:44 PM.
 
Old 11-24-2003, 03:41 PM   #4
Mikhail_16
Member
 
Registered: Oct 2003
Distribution: Gentoo rules them all
Posts: 279

Rep: Reputation: 31
remove protocol 1's, just leave 2. Security issue.
Everything else is fine.
 
Old 11-24-2003, 03:53 PM   #5
DogTags
LQ Newbie
 
Registered: Nov 2003
Posts: 24

Original Poster
Rep: Reputation: 15
Okay, I knocked it down to:

Protocol 2

and restarted the sshd service, but no luck

Should I add something to hosts.allow maybe?

Thanks
 
Old 11-24-2003, 04:08 PM   #6
Mikhail_16
Member
 
Registered: Oct 2003
Distribution: Gentoo rules them all
Posts: 279

Rep: Reputation: 31
oh, make sure that you disable your firewall/iptables, or change the settings to allow ssh connections.
 
Old 11-25-2003, 09:43 AM   #7
DogTags
LQ Newbie
 
Registered: Nov 2003
Posts: 24

Original Poster
Rep: Reputation: 15
Quote:
oh, make sure that you disable your firewall/iptables, or change the settings to allow ssh connections.
No firewall is enabled.

I searched for the iptables, and it appears that this has not been enabled, either. I found the iptables setup script - /etc/rc.d/init.d/iptables, and in there it says that the iptables file should exist at /etc/sysconfig/iptables, but it doesn't anywhere. I did a locate for iptables, but /etc/sysconfig/iptables was nowhere.

However, in webmin, there was a spot to start/stop the iptables service, but I can't officially say that it did either because the /etc/sysconfig/iptables file still doesn't show up.

Regarding allowing ssh connections, is there a setting somewhere? I am able to turn the service on, but I haven't found a config file so far that has something like ssh=yes

Thanks, again, for all your help
 
Old 11-25-2003, 12:17 PM   #8
DogTags
LQ Newbie
 
Registered: Nov 2003
Posts: 24

Original Poster
Rep: Reputation: 15
I got both ftp and ssh figured out

The key was the hosts.deny file

Look here:

http://www.linuxquestions.org/questi...351#post619351

Thanks for all your help and suggestions

HTH
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mac OS X ssh client / linux sshd : ssh hangs/disconnects Apollo77 Linux - Networking 1 05-24-2006 11:53 AM
sshd I can't ssh to my machine - Please help! dhbiker Slackware 18 03-12-2005 11:14 PM
Enabling SSHd on redhat 9 jon_k Linux - Software 3 03-05-2004 11:02 AM
sshd / ssh question.. doublefailure Linux - Networking 1 09-13-2002 08:51 AM
sshd, ssh, scp, help Stimm Linux - Security 3 03-25-2001 05:17 PM


All times are GMT -5. The time now is 11:36 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration