LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-09-2008, 10:18 PM   #1
khalidorama
LQ Newbie
 
Registered: Feb 2008
Posts: 8

Rep: Reputation: 0
Enabling Remote Desktop in Fedora using SSH.


Hi ,
I recently purchased one month Linux virtual dedicated server from GoDaddy. I am able to connect to it using SSH. However, Remote desktop is not enabled. I can't connect to it using remote desktop. I only can use SSH. Could you please inform me how can I enable Remote Desktop by using SSH ?
 
Old 02-09-2008, 11:12 PM   #2
snowman81
Member
 
Registered: Aug 2006
Location: Michigan
Distribution: Ubuntu
Posts: 238

Rep: Reputation: 30
Which distro is it using?
 
Old 02-10-2008, 01:59 AM   #3
paragkalra
Member
 
Registered: Sep 2006
Location: Nagpur, Maharashtra, India
Distribution: Debian, Ubuntu, Redhat, Fedora, SLES, OpenSUSE, FreeBSD, Mac OS X
Posts: 221

Rep: Reputation: 31
After login through ssh, use: "#vncpasswd" to set the vnc password on the server.

Then start the vncserver service on the using following command:
"#vncserver"

Then from your machine execute following command:
#vncviewer <ipaddress:1>

This will connect you to the remote server
 
Old 02-10-2008, 03:24 AM   #4
Samotnik
Member
 
Registered: Jun 2006
Location: Belarus
Distribution: Debian GNU/Linux testing/unstable
Posts: 471

Rep: Reputation: 40
ssh is a standard remote interface for the linux machine. And there are can't be any GUI applications on linux server - you simply take a linux for a windows.
 
Old 02-10-2008, 11:26 AM   #5
khalidorama
LQ Newbie
 
Registered: Feb 2008
Posts: 8

Original Poster
Rep: Reputation: 0
Hi,

I found another solution for my problem. I downloaded and installed VNC in the server. However, when I try to start the service , I get this error message ..

Couldn't start Xvnc; trying default font path.
Please set correct fontPath in the vncserver script.
Couldn't start Xvnc process.

Couldn't open RGB_DB '/usr/X11R6/lib/X11/rgb'
10/02/08 10:10:54 Xvnc version TightVNC-1.3.9
10/02/08 10:10:54 Copyright (C) 2000-2007 TightVNC Group
10/02/08 10:10:54 Copyright (C) 1999 AT&T Laboratories Cambridge
10/02/08 10:10:54 All Rights Reserved.
10/02/08 10:10:54 See http://www.tightvnc.com/ for information on TightVNC
10/02/08 10:10:54 Desktop name 'X' (ip-68-178-227-61.ip.secureserver.net:1)
10/02/08 10:10:54 Protocol versions supported: 3.3, 3.7, 3.8, 3.7t, 3.8t
10/02/08 10:10:54 Listening for VNC connections on TCP port 5901
10/02/08 10:10:54 Listening for HTTP connections on TCP port 5801
10/02/08 10:10:54 URL http://ip-68-178-227-61.ip.secureserver.net:5801
_FontTransSocketUNIXConnect: Can't connect: errno = 2
failed to set default font path 'unix/:7100'
Fatal server error:
could not open default font 'fixed'
Couldn't open RGB_DB '/usr/X11R6/lib/X11/rgb'
10/02/08 10:10:55 Xvnc version TightVNC-1.3.9
10/02/08 10:10:55 Copyright (C) 2000-2007 TightVNC Group
10/02/08 10:10:55 Copyright (C) 1999 AT&T Laboratories Cambridge
10/02/08 10:10:55 All Rights Reserved.
10/02/08 10:10:55 See http://www.tightvnc.com/ for information on TightVNC
10/02/08 10:10:55 Desktop name 'X' (ip-68-178-227-61.ip.secureserver.net:1)
10/02/08 10:10:55 Protocol versions supported: 3.3, 3.7, 3.8, 3.7t, 3.8t
10/02/08 10:10:55 Listening for VNC connections on TCP port 5901
10/02/08 10:10:55 Listening for HTTP connections on TCP port 5801
10/02/08 10:10:55 URL http://ip-68-178-227-61.ip.secureserver.net:5801
Font directory '/usr/X11R6/lib/X11/fonts/misc/' not found - ignoring
Font directory '/usr/X11R6/lib/X11/fonts/Speedo/' not found - ignoring
Font directory '/usr/X11R6/lib/X11/fonts/Type1/' not found - ignoring
Font directory '/usr/X11R6/lib/X11/fonts/75dpi/' not found - ignoring
Font directory '/usr/X11R6/lib/X11/fonts/100dpi/' not found - ignoring

Fatal server error:
could not open default font 'fixed'

what is the reason for this ?. What is the solution ?
 
Old 02-10-2008, 09:20 PM   #6
lotusjps46
Member
 
Registered: Apr 2003
Location: Dallas
Distribution: Vector Linux, Suse 10.1
Posts: 186

Rep: Reputation: 30
I do not think that the server has X installed. Try "vi /etc/X11/xorg.conf". My bet is that there is no such file. This is probably a server that does not have a GUI at all. It is adminstered remotely with scripts and ssh.
 
Old 02-10-2008, 11:26 PM   #7
khalidorama
LQ Newbie
 
Registered: Feb 2008
Posts: 8

Original Poster
Rep: Reputation: 0
I tried "vi /etc/X11/xorg.conf" and I got an empty page. How can I install X ? Please advise as I am new to linux
 
Old 02-10-2008, 11:42 PM   #8
paragkalra
Member
 
Registered: Sep 2006
Location: Nagpur, Maharashtra, India
Distribution: Debian, Ubuntu, Redhat, Fedora, SLES, OpenSUSE, FreeBSD, Mac OS X
Posts: 221

Rep: Reputation: 31
Question

Which distro are you using?
 
Old 02-12-2008, 12:15 PM   #9
khalidorama
LQ Newbie
 
Registered: Feb 2008
Posts: 8

Original Poster
Rep: Reputation: 0
Hi,
I am using Fedora 7 . I get this error :

# system-config-display
No video cards were found on this machine, exiting
 
Old 02-13-2008, 01:50 AM   #10
paragkalra
Member
 
Registered: Sep 2006
Location: Nagpur, Maharashtra, India
Distribution: Debian, Ubuntu, Redhat, Fedora, SLES, OpenSUSE, FreeBSD, Mac OS X
Posts: 221

Rep: Reputation: 31
I guess you need to do install xorg packages. You need to execute something like:
#yum install xorg-x11*
 
Old 02-13-2008, 02:34 AM   #11
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671
What OS are you connecting from. The server doesn't need to have X running to run a graphical program on a remote x-terminal, but some of the libraries may be needed. From a Linux machine you could access the server with "ssh -X user@host" and then enter in the name of command you want to run, like "sudo /path/to/system-config-users" and have that utility show up on your screen. This will be faster than having an entire session displayed. If you are connecting from Windows, you can install Cygwin/X and use ssh instead of putty.

In either case, you can log into the server and then use xinit to start a session.
 
Old 02-21-2008, 01:55 AM   #12
khalidorama
LQ Newbie
 
Registered: Feb 2008
Posts: 8

Original Poster
Rep: Reputation: 0
Hi,
I am connectiong from Microsoft XP. but , I have not yet tried VNC client as I can't the server. So I am currenly using SSH connection using Putty.

I tried the following:

# service vncserver start
Starting VNC server: 5:root WARNING: initlog is deprecated and will be removed in a future release
vncserver: The USER environment variable is not set.

# xinit

_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/ip-68-178-227-61.ip.secureserver.net:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

X Window System Version 1.3.0
Release Date: 19 April 2007
X Protocol Version 11, Revision 0, Release 1.3
Build Operating System: Fedora Core 7 Red Hat, Inc.
Current Operating System: Linux ip-68-178-227-61.ip.secureserver.net 2.6.9-023stab043.1-smp #1 SMP Mon Mar 5 16:35:19 MSK 2007 i686
Build Date: 21 January 2008
Build ID: xorg-x11-server 1.3.0.0-16.fc7
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Feb 21 00:43:09 2008
(==) Using config file: "/etc/X11/xorg.conf"
Parse error on line 47 of section Monitor in file /etc/X11/xorg.conf
"Monitor" is not a valid keyword in this section.
(EE) Problem parsing the config file
(EE) Error parsing the config file

Fatal server error:
no screens found
XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
after 0 requests (0 known processed) with 0 events remaining.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
windows remote desktop over ssh kpachopoulos General 1 12-06-2007 08:51 AM
remote desktop+ssh binary_dreamer Debian 10 02-06-2007 05:08 AM
'Remote Desktop' with SSH and VNC kaon Slackware 11 09-21-2004 01:15 PM
Remote Desktop using SSH tunnel..... help! redhatbeatswin Linux - Newbie 5 08-14-2004 11:51 AM
ssh forwarding+remote desktop Metroid Linux - Networking 2 06-23-2004 03:14 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration