LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-28-2006, 04:41 PM   #1
richardhufford
LQ Newbie
 
Registered: May 2006
Location: Safford, AZ, USA
Distribution: Ubuntu 11.04
Posts: 15
Blog Entries: 1

Rep: Reputation: 0
enabling chmod in wu-ftpd


I've installed wu-ftpd (version wu-2.6.2) on a computer that's running Debian Linux (Sarge). I can ftp files from my Win 98 computer to the Linux machine, but I cannot change the file permissions. Using two different ftp clients, I get the same error message 502 CHMOD command not implemented.
I have edited the ftpaccess file so that it contains the line:
chmod yes guest,real
Any idea what I'm doing wrong? I am not logging in anonymously. I noticed in a README file that "additional" commands need to be included in the /bin/ftp-exec directory. Is chmod an "additional" command? And I am sure that I am editing the correct ftpaccess file, because I changed the banner line and my change took effect when I restarted the linux machine.
Thanks for any ideas.
 
Old 05-29-2006, 09:20 PM   #2
richardhufford
LQ Newbie
 
Registered: May 2006
Location: Safford, AZ, USA
Distribution: Ubuntu 11.04
Posts: 15
Blog Entries: 1

Original Poster
Rep: Reputation: 0
I am really having a tough time figuring this problem out. Is there a chance that the wu-ftpd Debian package just doesn't support the chmod command? Or could I have installed the package such that the chmod command cannot be enabled?
 
Old 06-07-2006, 02:01 PM   #3
richardhufford
LQ Newbie
 
Registered: May 2006
Location: Safford, AZ, USA
Distribution: Ubuntu 11.04
Posts: 15
Blog Entries: 1

Original Poster
Rep: Reputation: 0
I never figured out how to enable chmod, but I did find a solution to my basic problem. I was able to use the upload command in the ftpaccess file. The upload command allows me to set the file permissions of any file that is uploaded by a particular user (or group of users) to a particular directory. So, as long as I want all the files that I upload into the same directory to have the same permissions, this command works for me.
 
Old 06-21-2006, 11:15 AM   #4
richardhufford
LQ Newbie
 
Registered: May 2006
Location: Safford, AZ, USA
Distribution: Ubuntu 11.04
Posts: 15
Blog Entries: 1

Original Poster
Rep: Reputation: 0
I was wrong

I was wrong. The upload command in the ftpaccess file did not work for me. I am trying to put a program in the cgi-bin directory and I cannot give the program execute permission. I think there is something basic about file permissions or security that I do not understand. I have found another workaround: I set up a Telnet server on the machine I am uploading files to. I can successfully chmod the file using Telnet. Is there anybody out there with a better solution?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
chmod, external usb, vfat - can't chmod a directory itsjustme Slackware 2 04-02-2006 05:23 PM
Enabling virutal users on Pure-FTPD on Debian hi_teck45 Linux - Software 1 07-08-2005 10:21 AM
What can we do if we type chmod ugo-x /bin/chmod ?????? bunny123 Linux - Software 3 02-01-2005 09:53 PM
CHMOD in shell : chmod 777 /usr/ <---is that right? cpanelskindepot Programming 5 07-16-2004 06:37 AM
Help with WU-FTPD Guest/Real CHMOD CPUguy387 Linux - Newbie 1 08-11-2003 11:47 AM


All times are GMT -5. The time now is 12:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration