LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-07-2006, 04:56 PM   #1
Menno RB
LQ Newbie
 
Registered: Dec 2006
Posts: 16

Rep: Reputation: 0
Enabling all Linux users to write to a partition


Hi there,

I created a seperate partition (FAT32) to exchange files between Windows XP and Linux (Mandriva 2007 Free) but I can't write any files to it when I'm on Mandriva. So I checked the permissions and 'Group' and 'Other' are set to 'Can View Content'. I want to change this to 'Can View & Modify content' but when I select that option it says 'Access denied to /mnt/wind_d'. So I figured I had to be logged in as root to change it but I don't know how to start a session as 'root' (when I try logging in it says 'root logins are disabled' and I read on these forums that it's because of safety concerns). Then I tried opening a terminal and browsing to 'hda8' (the partition) to use the command 'chmod' but the only one I managed to find was in /dev/ and that's not the actual partition I think. How could I solve this problem? Thanks in advance,

Menno

Last edited by Menno RB; 12-07-2006 at 05:01 PM.
 
Old 12-07-2006, 05:34 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
if you're already successfully mounting on boot to /mnt/win_d or similar then just edit /etc/fstab and on the line there that's already doing the mounting, add "umask=000" to the options section. that will force *everything* within that partition to be world readable and writable. note that as this is crappy old fat32, you have to lie and coerce file permissions, and can't change them at an individual file leve, as there is no where for that information to actually go or to be understood by the fat32 format.
 
Old 12-07-2006, 05:45 PM   #3
Menno RB
LQ Newbie
 
Registered: Dec 2006
Posts: 16

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by acid_kewpie
if you're already successfully mounting on boot to /mnt/win_d or similar then just edit /etc/fstab and on the line there that's already doing the mounting, add "umask=000" to the options section. that will force *everything* within that partition to be world readable and writable. note that as this is crappy old fat32, you have to lie and coerce file permissions, and can't change them at an individual file leve, as there is no where for that information to actually go or to be understood by the fat32 format.
Thanks for the help, but I'm still having problems. Here's the line in my fstab:

/dev/hda8 /mnt/win_d vfat umask=0000,iocharset=utf8 0 0

I tried creating a new textfile on hda8 but it still won't let me, do I have to run something first in order to let the changes be recognized? (Keep in mind I'm a real newb to Linux)
 
Old 12-07-2006, 06:07 PM   #4
Menno RB
LQ Newbie
 
Registered: Dec 2006
Posts: 16

Original Poster
Rep: Reputation: 0
Awesome, I should have tried what I thought before asking, I rebooted and it works now. Thanks a bunch
 
Old 12-07-2006, 06:10 PM   #5
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
The code looks right--did you run "mount" after changing the fstab?
If you do ls -l, what permissions are shown after mounting with your new fstab?
 
Old 12-07-2006, 06:17 PM   #6
Menno RB
LQ Newbie
 
Registered: Dec 2006
Posts: 16

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by pixellany
The code looks right--did you run "mount" after changing the fstab?
If you do ls -l, what permissions are shown after mounting with your new fstab?
I did not run 'mount' but I rebooted and it works now, running mount would have done the same thing? So 'mount' basically re-does the 'commands' in fstab?
 
Old 12-07-2006, 06:31 PM   #7
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
Quote:
Originally Posted by Menno RB
I did not run 'mount' but I rebooted and it works now, running mount would have done the same thing? So 'mount' basically re-does the 'commands' in fstab?
fstab is the code that tells the system what to mount and where (and when).
The default is mount automatically at boot time.
If there is "noauto" in the options, then you have to mount manually.
If it mounts at boot, you can always unmount (umount) and mount manually.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
fat32 partition, ordinary users read/write quietbyday Linux - General 1 08-02-2005 12:31 AM
What are the most common new Linux users questions? Have a mind to write a book:) kornerr Linux - General 33 07-31-2005 08:42 AM
mounting hard drive partition write for normal users jojotx0 Linux - Hardware 1 04-19-2005 01:10 PM
Making a Windows partition read/write for all users d1v1d38yz3r0 Linux - Newbie 2 12-08-2003 03:10 PM
vfat partition - write permission for users group digitized_funk Linux - Newbie 8 03-19-2003 08:30 AM


All times are GMT -5. The time now is 05:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration