LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 04-16-2006, 10:30 AM   #1
MercuryRising
LQ Newbie
 
Registered: Apr 2006
Posts: 22

Rep: Reputation: 15
Enable Linux to read CD-R?


Hi Everyone,

I used "Easy CD creator" in Windows XP to burn some CDs. When I go over to my Linux box (slackware 10.2 with KDE), it won't read these CDs, but will read other CDs (such as installatin CDs).

Someone on another thread said I have to enable "packet writing" in the kernel.

I'm a complete novice with linux, could someone please share exactly how this is done? I've looked online and am having a tough time finding answers to my questions in relation to my linux issues.

Thanks!
 
Old 04-16-2006, 10:41 AM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
No need to enable packet wrinting in the kernel in orer to read CD media. Some versions of 'Easy CD Creator' have a bad habit by default to write media as UDF and does not close the session which could be your problem.

Solutions;

Have Easy CD Creaor close the session or rewrite the CD as an ISO9660-Level2 CD.

You might want to mount the CD (if UDF and session cloesed) by;

mount -t udf /my/cdromdevice /my/mountpoint
 
Old 04-16-2006, 11:20 AM   #3
MercuryRising
LQ Newbie
 
Registered: Apr 2006
Posts: 22

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Lenard
Have Easy CD Creaor close the session or rewrite the CD as an ISO9660-Level2 CD.
Hi Lenard, thanks for your help.

I went to Easy cd creator >> File >> CD Project Properties >> Set filesystem as ISO 9660 (Physical format of cd is set to mode 2:cdrom-xa)

I re-burned the cd this way... used the same cd. By default I finalize each session after burning and don't finalize the cd.

I placed the cd into the linux box and got the following error:

Could not mount device... mount: no medium found

Was there some other setting I may have missed in setting up the cd?

Quote:
Originally Posted by Lenard
You might want to mount the CD (if UDF and session cloesed) by;

mount -t udf /my/cdromdevice /my/mountpoint
I don't understand this. I did type it into Konsole and it said "mount point /my/mountpoint does not exist".
 
Old 04-16-2006, 11:23 AM   #4
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 3,990

Rep: Reputation: 261Reputation: 261Reputation: 261
You need to create the mountpoint before you can use it. This is as simple as just making a directory (e.g mkdir /test). Most distros have /mnt/cdrom and a couple other created already for you to use.
 
Old 04-16-2006, 11:32 AM   #5
MercuryRising
LQ Newbie
 
Registered: Apr 2006
Posts: 22

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by btmiller
You need to create the mountpoint before you can use it. This is as simple as just making a directory (e.g mkdir /test). Most distros have /mnt/cdrom and a couple other created already for you to use.
Hi- Thanks for your help.

I created the test directory, then entered in

mount -t udf /my/cdromdevice /my/mountpoint

system came back with:
mount: mount point /my/mountpoint does not exist
 
Old 04-16-2006, 11:39 AM   #6
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
You don't literally type "/my/mountpoint", substitute that with the directory you want to mount to. It's the same kinda thing for "/my/cdromdevice", substitute that with the actual device for your CD drive, e.g. if I wanted to mount my CD-ROM drive (which is attached to /dev/hdc) to /mnt/cdrom, I'd use "mount /dev/hdc /mnt/cdrom".
 
Old 04-16-2006, 11:41 AM   #7
MercuryRising
LQ Newbie
 
Registered: Apr 2006
Posts: 22

Original Poster
Rep: Reputation: 15


Thanks... I have a lot to learn. Think I'll go to the library and get a book on linux... any suggestions?

I went to fstab and found:
/dev/cdrom /mnt/cdrom auto noauto,owner, ro 0 0

I went back to shell and typed:
mount -t udf /dev/cdrom /mnt/cdrom

response back was:
mount: block device /dev/cdrom is write-protected, mounting read-only
mount: No medium found

??

Last edited by MercuryRising; 04-16-2006 at 11:47 AM.
 
Old 04-16-2006, 01:50 PM   #8
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
OK, looks like you are learning........

The udf filesystem is just one of a few CD filesystem types another is the iso9660 filesystem....

Since you already now know both the device (/dev/cdrom) and the mountpoint (/mnt/cdrom) and you have wriiten the CD with an iso9660 filesystem combine all that you have done and learned;

mount -t iso9660 /dev/cdrom /mnt/cdrom

or if you want; mount -t auto /dev/cdrom /mnt/cdrom

See the man page for the details, options and additional information, from the console or xterm session type; man mount

Most Linux commands are also documented this way (man pages or info pages)

Some suggested reading;

http://www.tldp.org/HOWTO/Filesystems-HOWTO.html
http://www.tldp.org/HOWTO/CD-Writing-HOWTO.html

Notice the main website http://www.tldp.org/ a nice place to start learning Linux. And before I forget Welcome to Linux!!!
 
Old 04-16-2006, 09:01 PM   #9
MercuryRising
LQ Newbie
 
Registered: Apr 2006
Posts: 22

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Lenard
OK, looks like you are learning........

The udf filesystem is just one of a few CD filesystem types another is the iso9660 filesystem....

Since you already now know both the device (/dev/cdrom) and the mountpoint (/mnt/cdrom) and you have wriiten the CD with an iso9660 filesystem combine all that you have done and learned;

mount -t iso9660 /dev/cdrom /mnt/cdrom

or if you want; mount -t auto /dev/cdrom /mnt/cdrom

See the man page for the details, options and additional information, from the console or xterm session type; man mount

Most Linux commands are also documented this way (man pages or info pages)

Some suggested reading;

http://www.tldp.org/HOWTO/Filesystems-HOWTO.html
http://www.tldp.org/HOWTO/CD-Writing-HOWTO.html

Notice the main website http://www.tldp.org/ a nice place to start learning Linux. And before I forget Welcome to Linux!!!
I greatly appreciate everyone's help.

I'm also feeling close to exploding because I STILL haven't been able to make this work. I've spent hours just trying to get the #!%# cdrom to read the cd. I'm stuck and desparate. I've read the Howto's Lenard sent and found the bit about adding "joliet" in fstab, but that didn't work.

Currently Fstab shows cdrom:
/dev/cdrom /mnt/cdrom auto noauto,owner,ro 0 0

Here is what I've tried:
In addtion to finalizing the session, I've closed the cd

*I've tried burning it in iso 9660
*I've tried whatever the 'easy cd creator' default burning fs is
*I've changed fstab to iso9660 instead of auto
*I've changed fstab to iso9660,joliet instead of auto
*I've changed fstab 'owner' to 'users'
*I've tried various combinations of the above
*I've tried mount -t udf /dev/cdrom /mnt/cdrom
*I've tried mount -t iso9660 /dev/cdrom /mnt/cdrom
*I've tried...

I've gotten so many different errors I don't remember them all. The last was:
mount: block device /dev/cdrom is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblcok on /dev/cdrom, missing codepage or other error


If I place an adobe installatin cd into the drive, it reads it right away... it will not read the data cd's I've burned (I'm trying to install ndiswrapper by cd since I have no internet access)

I feel like I'm tilting at windmills...

Any help greatly appreciated.
 
Old 04-17-2006, 01:24 AM   #10
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Quote:
Originally Posted by MercuryRising
I've gotten so many different errors I don't remember them all. The last was:
mount: block device /dev/cdrom is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblcok on /dev/cdrom, missing codepage or other error
Did those two come at the same time? The first isn't an error message.
 
Old 04-17-2006, 06:03 AM   #11
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Question; Is the location of the downloaded ndiswrapper on the same hard drive on a dual boot system??


My current /etc/fstab entry for the CD/DVD burner is (modified to use your mountpoint) for comparision;

Code:
/dev/hdc                /mnt/cdrom       auto    exec,noauto,users,ro 0 0
I'm using the actual device which can be known by typing; ls -l /dev/cdrom

See;
$ ls -l /dev/cdrom
lrwxrwxrwx 1 root root 3 Apr 16 16:06 /dev/cdrom -> hdc

You might want to check your /etc/filesystems file, mine is below;

$ cat /etc/filesystems
ext3
ext2
nodev proc
nodev devpts
iso9660
udf
cdfs
vfat
ntfs
hfs

Do not worry about the cdfs entry, I have patched my kernel to allow mounting of audio CD/DVD media.

Finally nothing is really wrong with your /etc/fstab entry except you have to mount as root. Since the entry is in /etc/fstab all you need to type (as root) is;

mount /mnt/cdrom

Also as a suggestion try burning the CD (once more time) using the Windows version of cdrecord found here; http://www.geoshock.com/cdrtools/ get the first one listed
(CDRTools v2.01.01a03 binaries + cygwin1.dll).
 
Old 04-18-2006, 12:21 AM   #12
MercuryRising
LQ Newbie
 
Registered: Apr 2006
Posts: 22

Original Poster
Rep: Reputation: 15
Hi Everyone,

I've got a crazy week ahead of me and will try to make time to look at this, but realistically it will not be until next week.

I will report back with the results when I've had a chance to work on the suggestions. Thanks again for all the help!!

Dave
 
Old 04-30-2006, 03:45 PM   #13
MercuryRising
LQ Newbie
 
Registered: Apr 2006
Posts: 22

Original Poster
Rep: Reputation: 15
Hi Everyone,

After trying somemore I took someones advice and went to a more noobie friendly (I think) distribution SUSE 10.0 Of course, I'm having problems there also, but it does seem to be easier.

Thanks agian for your help!

MercuryRising
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to enable Telnet in Linux? lapzlinux Linux - Networking 9 08-11-2006 01:26 AM
Enable framebuffer to have read/write access vidhyapria Red Hat 0 08-11-2005 07:26 AM
How to enable read-write support on NTFS? theMonkeY Linux - Software 4 06-26-2004 12:23 PM
K3b says to enable ide-scsi to read from drives but its already doner in lilo Bradster Linux - Software 5 04-21-2004 03:22 AM
linux scripting help needed read from file line by line exc commands each line read atokad Programming 4 12-26-2003 10:24 PM


All times are GMT -5. The time now is 06:20 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration