LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-26-2002, 09:35 AM   #1
pperon
Member
 
Registered: Jan 2002
Location: Cleveland
Distribution: Gentoo and umm... Gentoo
Posts: 64

Rep: Reputation: 15
Question emu10k1 install problems


Hi all.

I'm currently running RH7.2 and the 2.4.7-10 kernel. I have an Audigy (Gamer) based sound card so naturally I pulled down the latest emu10k1 source. When I attempted to run 'make', I was hit by a strange error:

make: *** No rule to make target '/usr/src/linux-2.4.9-13/include/linux/modversions.h', needed by 'audio.o'. Stop.

2.4.9-13!?! How can that be?

Being a newbie, I read through the README's which came with the emu source and also checked as many online sources for emutools as Google could muster. (Unfortunately opensource.creative.com was cracked recently.) None of these resources produced an answer. Finally I decided to check out the 'Makefile.config' file. I noticed that the 'KERNELVERSION' (constant?) was set to 'auto' so I changed it to 'linux-2.4.7-10' leaving the 'KERNELSOURCE' value: '/usr/src/linux/'. This was a shot in the dark.

The 'make' command still remained unimpressed, repeating it's previous error.

Can anyone shed light on this?

Thanks in advance.

-pperon
 
Old 02-25-2002, 08:24 PM   #2
jashmore
LQ Newbie
 
Registered: Feb 2002
Distribution: RH 7.2
Posts: 9

Rep: Reputation: 0
RH

If you used RH's automatic service update service, the newest version is 2.4.9-13. For whatever reason, the "up2date" function does not install the latest kernel at /usr/src/linux 2.4.XX or whatever. In fact, RH does not install the kernel code anywhere that I could find. I had the exact same issue.

You can check your version to be sure by typing:

uname -a

I ended up downloading the latest kernel 2.4.17 and building my own from scratch. You can download the latest kernel from:

http://www.kernel.org

There are some good kernel HOW-To's at:

http://www.redhat.com/docs/manuals/l...-guide/custom-
kernel.html

However, it is a pain because you have to configure the kernel yourself. If it is your first time (like it was mine this week), it is not easy.

I hope this has helped!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
audigy 2 emu10k1 install problems bat Linux - Hardware 1 10-27-2004 01:04 PM
Emu10k1 digital out problems mrsolo Linux - Hardware 1 09-24-2004 08:28 PM
emu10K1 how to install Jenia999 Linux - Newbie 2 08-03-2004 08:58 AM
Problems with SBlive (emu10k1) datavortex Fedora 7 05-14-2004 04:36 PM
emu10k1 problems dtjohnst Slackware 17 04-14-2004 08:52 PM


All times are GMT -5. The time now is 09:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration