LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-27-2009, 06:18 AM   #1
bloony
LQ Newbie
 
Registered: May 2009
Posts: 7

Rep: Reputation: 0
Emerge - blocks B error


Hi,

Im getting a "blocks B" error msg when Im trying to install wicd using emerge in Gentoo.. How can I fix this?

Code:
[blocks B     ] sys-libs/com_err ("sys-libs/com_err" is blocking sys-libs/e2fsprogs-libs-1.41.3-r1)
[blocks B     ] sys-libs/ss ("sys-libs/ss" is blocking sys-libs/e2fsprogs-libs-1.41.3-r1)
[blocks B     ] <sys-fs/e2fsprogs-1.41 ("<sys-fs/e2fsprogs-1.41" is blocking sys-libs/e2fsprogs-libs-1.41.3-r1)

Total: 38 packages (1 upgrade, 36 new, 1 in new slot), Size of downloads: 32,448 kB
Conflict: 3 blocks (3 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  ('ebuild', '/', 'sys-libs/e2fsprogs-libs-1.41.3-r1', 'merge') pulled in by
    >=sys-libs/e2fsprogs-libs-1.41 required by ('ebuild', '/', 'sys-fs/cryptsetup-1.0.5-r1', 'merge')
    sys-libs/e2fsprogs-libs required by ('installed', '/', 'x11-libs/libSM-1.1.0', 'nomerge')

  ('installed', '/', 'sys-fs/e2fsprogs-1.40.8', 'nomerge') pulled in by
    sys-fs/e2fsprogs required by world
    >=sys-fs/e2fsprogs-1.34 required by ('installed', '/', 'sys-apps/util-linux-2.13.1.1', 'nomerge')
    sys-fs/e2fsprogs required by system
 
Old 05-27-2009, 09:13 AM   #2
nuwen52
Member
 
Registered: Feb 2009
Distribution: Debian, CentOS 5, Gentoo, FreeBSD, Fedora, Mint, Slackware64
Posts: 208

Rep: Reputation: 46
After a quick google search on "emerge block e2fsprogs", I found a couple of resources: http://linux-bsd-sharing.blogspot.co...on-gentoo.html and http://www.odi.ch/weblog/posting.php?posting=524. There were other postings you could check out.

If this is the error you are getting (which it looks like it to me)... What it basically came down to is e2fsprogs incorporates the other two packages now. So, before unmerging them, you need to do an emerge with a --fetchonly on the new stuff (since those other packages are needed for wget and other programs to work right), so you need to have the packages local before removing the things wget needs.

Anyhow, reading those posts should give you a good idea of what to do. One part of the post recommends a --fetchonly on world. That's probably not a bad idea. I remember doing roughly this before on my Gentoo box. You might also want to have a liveCD available just in case.

Do a little research before unmerging anything. Also, you might want to make sure that portage is updated first, since it looks like from some posts that the newest version might be able to solve the problem.
 
Old 05-27-2009, 09:55 AM   #3
bloony
LQ Newbie
 
Registered: May 2009
Posts: 7

Original Poster
Rep: Reputation: 0
Thanks mate, that fixed it.. I saw that second one earlier, but I didn't it was similar to my problem for some reason.. That first one worked perfectly. Thanks.
 
Old 05-27-2009, 09:59 AM   #4
nuwen52
Member
 
Registered: Feb 2009
Distribution: Debian, CentOS 5, Gentoo, FreeBSD, Fedora, Mint, Slackware64
Posts: 208

Rep: Reputation: 46
Just from curiosity, which part fixed it? The new portage, or the emerge procedure? I'm curious since the portage thing didn't work for me.
 
Old 05-28-2009, 12:50 AM   #5
bloony
LQ Newbie
 
Registered: May 2009
Posts: 7

Original Poster
Rep: Reputation: 0
These steps from the first link there fixed it:

1. $ su
2. # eix-sync
3. # emerge --fetchonly e2fsprogs e2fsprogs-libs
4. # emerge --unmerge com_err ss e2fsprogs
5. # emerge --oneshot e2fsprogs
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
python: can't open file 'emerge\bin\emerge.py' Virtuality Programming 5 01-30-2008 02:23 PM
emerge xgl error darkangel29 Linux - Software 0 11-26-2006 03:37 PM
wine emerge error darkangel29 Linux - Software 1 04-16-2006 03:16 AM
emerge error in gentoo xcalibra Linux - Software 9 11-20-2005 01:00 PM
emerge error ? shanenin Linux - Software 0 01-06-2004 01:56 PM


All times are GMT -5. The time now is 08:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration