LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 03-05-2005, 07:02 PM   #1
dt4stat
LQ Newbie
 
Registered: Mar 2005
Posts: 19

Rep: Reputation: 0
Unhappy emacs, xemacs, No pop-up window


Hi all:

Newbie to linux, and need your help to make emacs/xemacs work.
I just installed emacs and xemacs, and it works. However, no pop-up window shows up. It just uses the xterm as the editor screen instead pop up a new window. When typing command TOP, root.. X is shown.
I want a pop-up window for emacs/xemacs. So can anyone help me out with this?

Redhat: Enterprise 3.0
emacs: 21.4a.tar.gz
xemacs: 21.4.17.tar.gz

If some one asked this question already, sorry about that. Please point me to the right direction if so.


Many many thanks.

DT

Last edited by dt4stat; 03-05-2005 at 09:57 PM.
 
Old 03-05-2005, 07:50 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,005
Blog Entries: 11

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
Hi, and welcome to LQ!

May I first ask a few questions, since it's not possible
to answer that kind of inquiry without some back-ground
information...

What distro are you using, how did you install emacs?
I won't comment on xemacs since I don't use it.


Cheers,
Tink
 
Old 03-05-2005, 09:52 PM   #3
dt4stat
LQ Newbie
 
Registered: Mar 2005
Posts: 19

Original Poster
Rep: Reputation: 0
I got the emacs (emacs-21.4a.tar.gz) from the offical site:
http://ftp.gnu.org/pub/gnu/emacs/

Steps i went through:
1. download emacs-21.4a.tar.gz to mydirectory/
2. tar -zxvf emacs-21.4a.tar.gz
3. cd emacs-21.4 (new create directory)
4. ./configure
5. make
6. su => become root
7. make install
8. su myusername
9. emacs & => no window pop up, it just hangs there, when i hit ENTER.
The promt looks like:

[myusername@ redhat myusername]$ emacs &
[1] 25392
[myusername@ redhat myusername]$

After i hit ENTER for the second time:
[myusername@ redhat myusername]$

[1]+ stopped emacs
[myusername@ redhat myusername]$


10. emacs => the terminal become the emacs screen with no menu bar, etc.

I have also tried:
echo $DISPLAY ==> localhost:10.0

There were no error msgs displayed.


So what should i do to get that display a seperate window for emacs ?

Thanks again.

DT

Last edited by dt4stat; 03-05-2005 at 09:56 PM.
 
Old 03-06-2005, 06:08 AM   #4
enemorales
Member
 
Registered: Jul 2004
Location: Santiago, Chile
Distribution: Ubuntu
Posts: 410

Rep: Reputation: 30
emacs and xemacs are two different editors. You don't need emacs for using xemacs or the opposite. Emacs should be able to run in its own window when compiled properly. Maybe you compiled emacs without X support. Do the sources come with a README file or something like that? Perhaps you could find some answers there.

I don't know why xemacs isn't working for you. I didn't know it can run in the terminal. Maybe you only have to set some parameter in your .emacs file. Look at the FAQs that come with xemacs/emacs.

Anyway, Do you have any particular reason to install emacs/xemacs from source? I think you are using Red-Hat, thus you should be able to get a compiled rpm that problably will have X support.

Good luck!
 
Old 03-06-2005, 01:35 PM   #5
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 51
yes i think when you configured emacs you did not have X11 developements files in place and you got a non x emacs (emacs configure sees x as optional)
use this to comple emacs once x is in place
Code:
./configure  
make bootstrap 
make install
after you get emacs working for extra popup fun
try this in your .emacs file
(setq pop-up-frames t)

Last edited by foo_bar_foo; 03-06-2005 at 01:43 PM.
 
Old 03-07-2005, 03:07 AM   #6
dt4stat
LQ Newbie
 
Registered: Mar 2005
Posts: 19

Original Poster
Rep: Reputation: 0
First of all, thanks for those who replied.

I got it to work. It's very simple. just find the add/remove application from the menu, and click detail next to text-editor.....

I haven't tried the "make bootstrap" option mentioned by foo_bar_foo. Thanks anyway.

DT
 
Old 03-18-2005, 07:28 PM   #7
mrgoodtrips
LQ Newbie
 
Registered: Mar 2005
Posts: 11

Rep: Reputation: 0
Hi guys,

I actually have the same distro and same problem, and none of the above seems to work. Emacs was installed as a package with the OS, and I downloaded and installed Xemacs separately.

Unfortunately, the "make bootstrap" command did not work as there was no "bootstrap" target in the xemacs install directory. And dt4stat's suggestion did not help. Under "details", I can't really do anything but read about the different text editors.

This is frustrating as I've worked with several different distros on several computers both at work and at home, and I've never had anything like this happen. In fact, I previously had this distro installed on another hard drive on this same computer, and both xemacs and emacs worked exactly as advertised. I don't know what gives.

Any thoughts?

BTW - I don't really care about getting a separate window for emacs as much as xemacs.

Thanks!
 
Old 03-18-2005, 07:41 PM   #8
mrgoodtrips
LQ Newbie
 
Registered: Mar 2005
Posts: 11

Rep: Reputation: 0
Hmmm... it seems that in my $PATH variable, /usr/local/bin occurs before /usr/bin and that they are running two different versions of the "emacs" command. When I execuate /usr/local/bin/emacs I get emacs in the xterm. When I run /usr/bin/emacs I get a separate emacs window....

Does anyone understand this?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xemacs starts instead of emacs sh4d0w13 Linux - Newbie 4 09-30-2005 04:44 PM
emacs and xemacs darknails Linux - Software 1 01-16-2005 08:42 AM
xemacs/ emacs conflict s.mcclatchie Mandriva 1 04-25-2004 11:07 PM
emacs or xemacs? Tyir Linux - General 8 04-02-2004 03:33 AM
emacs or Xemacs saurya_s Linux - Software 1 02-05-2004 03:44 PM


All times are GMT -5. The time now is 12:25 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration