LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 11-03-2009, 03:12 AM   #1
raja_tlr
LQ Newbie
 
Registered: May 2008
Posts: 9

Rep: Reputation: 0
Question emacs not found in /usr/bin


hi,
I use fedora. I just installed emacs by using this command.
yum install emacs.It did install(updated).

But when i try whereis emacs i get only this,
emacs: /usr/share/emacs

when i try emacs in command prompt it didn't open.

Pls help.

Thanks.
 
Old 11-03-2009, 03:15 AM   #2
AwesomeMachine
Senior Member
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian jessie/sid; OpenSuSE; Fedora
Posts: 1,589

Rep: Reputation: 161Reputation: 161
Try:
updatedb
locate emacsen
 
Old 11-03-2009, 03:22 AM   #3
raja_tlr
LQ Newbie
 
Registered: May 2008
Posts: 9

Original Poster
Rep: Reputation: 0
nothing displayed
 
Old 11-03-2009, 06:14 AM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2013.07, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,193

Rep: Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372
Fedora 11 : ' which emacs ' , the reply is : /usr/bin/emacs

rpm -ql emacs
/usr/bin/emacs-23.1
/usr/libexec/emacs
/usr/libexec/emacs/23.1
.
.

The rpm / yum install is supposed to create the link /usr/bin/emacs :
Code:
[knudfl@localhost ~]$ ls -l /usr/bin/emacs*
lrwxrwxrwx 1 root root      23  3 nov 12:58 /usr/bin/emacs -> /etc/alternatives/emacs
-rwxr-xr-t 1 root root 6829360 29 sep 13:19 /usr/bin/emacs-23.1
-rwxr-xr-x 1 root root   18548 29 sep 13:19 /usr/bin/emacsclient
So I guess you will have to give it another try with yum or :
1) ' su '
2 ) :
Code:
 # update-alternatives --config emacs

......... 1 program ......... 'emacs'.

  Choices         Command
-----------------------------------------------
*+ 1           /usr/bin/emacs-23.1/
Or create a link ' emacs ' yourself.
.....

Last edited by knudfl; 11-03-2009 at 06:18 AM.
 
Old 11-03-2009, 06:33 AM   #5
raja_tlr
LQ Newbie
 
Registered: May 2008
Posts: 9

Original Poster
Rep: Reputation: 0
whereis emacs returns the following.
emacs: /usr/share/emacs


which emacs returns the following
/usr/bin/which: no emacs in (/usr/kerberos/sbin:/usr/lib/qt-3.3/bin:/usr/kerberos/bin:/usr/lib/ccache:/usr/java/jdk1.6.0_06/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/usr/local/jakarta-tomcat-5.0.28/bin:/opt/real/RealPlayer:/home/raju/bin:/opt/real/RealPlayer:/opt/real/RealPlayer)
 
Old 11-03-2009, 08:20 AM   #6
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2013.07, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,193

Rep: Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372Reputation: 2372
*
OK, did you follow one of the advices in post # 4
to get the link created ? ?

Else you can do : open the terminal window and ...
1) cd /usr/bin/
2) su <enter-your-password>
3) ln -s emacs-23.1 emacs
.....
 
Old 11-03-2009, 10:30 PM   #7
raja_tlr
LQ Newbie
 
Registered: May 2008
Posts: 9

Original Poster
Rep: Reputation: 0
As in #4 i did this,
ls -l /usr/bin/emacs*

It returns nothing.

when,
rpm -ql emacs
package emacs is not installed.

I installed it with yum.

The /usr/share/emacs folder contains another folder named site-lisp and it contains some .el files and .elc files.

Hope this helps to find the problem.

Last edited by raja_tlr; 11-03-2009 at 10:45 PM.
 
Old 11-03-2009, 10:43 PM   #8
evo2
Senior Member
 
Registered: Jan 2009
Location: Japan
Distribution: Debian
Posts: 4,822

Rep: Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022
Quote:
Originally Posted by raja_tlr View Post
As in #4 i did this,
ls -l /usr/bin/emacs*

It returns nothing.

when,
rpm -ql emacs
package emacs is not installed.

I installed it with yum.
It seems that it was not installed. Please try to do it again, and post exactly what you did and what was reported by yum.

Evo2.
 
Old 11-03-2009, 10:54 PM   #9
raja_tlr
LQ Newbie
 
Registered: May 2008
Posts: 9

Original Poster
Rep: Reputation: 0
I installed it again. Still emacs doesn't start.

yum install emacs
Loaded plugins: refresh-packagekit
fedora | 2.8 kB 00:00
updates | 3.4 kB 00:00
adobe-linux-i386 | 951 B 00:00
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package emacs.i386 1:22.3-5.fc10 set to be updated
--> Processing Dependency: emacs-common = 1:22.3-5.fc10 for package: emacs
--> Processing Dependency: xorg-x11-fonts-ISO8859-1-75dpi for package: emacs
--> Processing Dependency: xorg-x11-fonts-misc for package: emacs
--> Running transaction check
---> Package emacs-common.i386 1:22.3-5.fc10 set to be updated
---> Package xorg-x11-fonts-misc.noarch 0:7.2-6.fc9 set to be updated
---> Package xorg-x11-fonts-ISO8859-1-75dpi.noarch 0:7.2-6.fc9 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
Package Arch Version Repository Size
================================================================================
Installing:
emacs i386 1:22.3-5.fc10 updates 2.0 M
Installing for dependencies:
emacs-common i386 1:22.3-5.fc10 updates 19 M
xorg-x11-fonts-ISO8859-1-75dpi noarch 7.2-6.fc9 fedora 928 k
xorg-x11-fonts-misc noarch 7.2-6.fc9 fedora 5.9 M

Transaction Summary
================================================================================
Install 4 Package(s)
Update 0 Package(s)
Remove 0 Package(s)

Total download size: 28 M
Is this ok [y/N]: y
Downloading Packages:
(1/4): xorg-x11-fonts-ISO8859-1-75dpi-7.2-6.fc9.noarch.r | 928 kB 00:07
(2/4): emacs-22.3-5.fc10.i386.rpm | 2.0 MB 00:22
(3/4): xorg-x11-fonts-misc-7.2-6.fc9.noarch.rpm | 5.9 MB 01:01
(4/4): emacs-common-22.3-5.fc10.i386.rpm | 19 MB 03:11
--------------------------------------------------------------------------------------------------------------------------------------------------------------
Total 101 kB/s | 28 MB 04:43
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Installing : xorg-x11-fonts-ISO8859-1-75dpi 1/4
Installing : xorg-x11-fonts-misc 2/4
Installing : emacs-common 3/4
Installing : emacs 4/4

Installed:
emacs.i386 1:22.3-5.fc10

Dependency Installed:
emacs-common.i386 1:22.3-5.fc10 xorg-x11-fonts-ISO8859-1-75dpi.noarch 0:7.2-6.fc9 xorg-x11-fonts-misc.noarch 0:7.2-6.fc9

Complete!
[root@localhost site-lisp]# emacs
bash: emacs: command not found
 
Old 11-03-2009, 11:04 PM   #10
evo2
Senior Member
 
Registered: Jan 2009
Location: Japan
Distribution: Debian
Posts: 4,822

Rep: Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022
Quote:
Originally Posted by raja_tlr View Post
<snip>

Dependency Installed:
emacs-common.i386 1:22.3-5.fc10 xorg-x11-fonts-ISO8859-1-75dpi.noarch 0:7.2-6.fc9 xorg-x11-fonts-misc.noarch 0:7.2-6.fc9

Complete!
[root@localhost site-lisp]# emacs
bash: emacs: command not found
Ok, it seems to have installed without error. Can you please post the output of:

rpm -ql emacs

and

echo $PATH

Evo2.
 
Old 11-03-2009, 11:06 PM   #11
raja_tlr
LQ Newbie
 
Registered: May 2008
Posts: 9

Original Poster
Rep: Reputation: 0
seems to be nearing solution.

rpm -ql emacs returns,

/usr/bin/emacs-22.3
/usr/libexec/emacs
/usr/libexec/emacs/22.3
/usr/libexec/emacs/22.3/i386-redhat-linux-gnu
/usr/share/applications/emacs.desktop
/usr/share/icons/hicolor/16x16/apps/emacs.png
/usr/share/icons/hicolor/24x24/apps/emacs.png
/usr/share/icons/hicolor/32x32/apps/emacs.png
/usr/share/icons/hicolor/48x48/apps/emacs.png
 
Old 11-03-2009, 11:12 PM   #12
raja_tlr
LQ Newbie
 
Registered: May 2008
Posts: 9

Original Poster
Rep: Reputation: 0
Before, I had a link like this. Here emacs-23.1 is not available. How to change it to emacs-22.3

ls -l /usr/bin/emacs*
lrwxrwxrwx 1 root root 10 2009-11-04 09:53 /usr/bin/emacs -> emacs-23.1
 
Old 11-03-2009, 11:12 PM   #13
evo2
Senior Member
 
Registered: Jan 2009
Location: Japan
Distribution: Debian
Posts: 4,822

Rep: Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022
Quote:
Originally Posted by raja_tlr View Post
seems to be nearing solution.

rpm -ql emacs returns,

/usr/bin/emacs-22.3
/usr/libexec/emacs
/usr/libexec/emacs/22.3
/usr/libexec/emacs/22.3/i386-redhat-linux-gnu
/usr/share/applications/emacs.desktop
/usr/share/icons/hicolor/16x16/apps/emacs.png
/usr/share/icons/hicolor/24x24/apps/emacs.png
/usr/share/icons/hicolor/32x32/apps/emacs.png
/usr/share/icons/hicolor/48x48/apps/emacs.png
Excellent. So it really is installed now. So you can run it with the comand: emacs-22.3

Best thing to do though would be to follow the instructions in post #4 and run update-alternatives.

Evo2.
 
Old 11-03-2009, 11:13 PM   #14
raja_tlr
LQ Newbie
 
Registered: May 2008
Posts: 9

Original Poster
Rep: Reputation: 0
echo $PATH
/usr/kerberos/sbin:/usr/lib/qt-3.3/bin:/usr/kerberos/bin:/usr/lib/ccache:/usr/java/jdk1.6.0_06/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/usr/local/jakarta-tomcat-5.0.28/bin:/opt/real/RealPlayer:/home/raja/bin:/opt/real/RealPlayer:/opt/real/RealPlayer:/opt/real/RealPlayer
 
Old 11-03-2009, 11:15 PM   #15
evo2
Senior Member
 
Registered: Jan 2009
Location: Japan
Distribution: Debian
Posts: 4,822

Rep: Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022
Quote:
Originally Posted by raja_tlr View Post
Before, I had a link like this. Here emacs-23.1 is not available. How to change it to emacs-22.3

ls -l /usr/bin/emacs*
lrwxrwxrwx 1 root root 10 2009-11-04 09:53 /usr/bin/emacs -> emacs-23.1
rm /usr/bin/emacs
ln -s /usr/bin/emacs-22.3 /usr/bin/emacs

Evo2.
 
  


Reply

Tags
emacs


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
echo $PATH = /home/g3rc4n/bin:/usr/local/bin:/usr/bin:/bin:/usr/games ? i_heart_pandas Linux - Software 7 09-18-2009 08:33 AM
/usr/bin/gcc not found an_sush Linux - Software 1 07-10-2009 01:43 AM
SOme commands are not found in /usr/bin directory bachelorlko Linux - Newbie 9 11-26-2008 01:19 AM
/usr/bin/emacs: No such file or directory...yet it exists andeity Linux - General 6 04-16-2006 08:54 PM
Error when starting up snort: bash:!/bin/sh/usr/local/bin/snort :Eent not found cynthia_thomas Linux - Software 1 11-11-2005 02:59 PM


All times are GMT -5. The time now is 10:15 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration