LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-30-2005, 01:32 PM   #1
projectborn
LQ Newbie
 
Registered: May 2005
Distribution: Knoppix 3.8.1
Posts: 5

Rep: Reputation: 0
Editing LILO in a Knoppix Install


Installed Knoppix 3.8; my first experience with Linux. I have a dual boot with XP. The Boot Screen is set at 50 for the timeout which is too quick. I found how to get to the /etc/lilo.conf by typing vi /etc/lilo.conf. After much searching I found how to edit the file. (I think) I typed "i" and changed the 50 to a 250.
I understand to apply the change one would type from Root../sbin/lilo -v?? Maybe this is not correct as when I re-booted the Boot Screen was still way too fast.
Can someone explain what I am doing wrong in Newbie's terms? Perhaps tell me the steps which would correct the problem in simple terms. Thanks very much.
 
Old 05-30-2005, 01:48 PM   #2
scr
LQ Newbie
 
Registered: May 2005
Distribution: Slackware 10.1 / FreeBSD 5.4
Posts: 8

Rep: Reputation: 0
...

Hello!

You actually didn't give much information, and the steps you did are probably correct.
I think it can be 2 things:

You forgot to save the changes you've made in lilo.conf.
run the command above and make sure the output is the timeout you actually configured:
Code:
 cat /etc/lilo.conf | grep "timeout"
Second thing, the "timeout" parameter, sets a timeout in tenths of a second, so probably 250 it'll still be fast. Try increasing the timeout, save the changes, then run /sbin/lilo, as root of course

Also one more thing, make sure "prompt" is mentioned in your lilo.conf.
If you're still having problems, paste your lilo.conf file here, and we'll try to help.
Enjoy.

Last edited by scr; 05-30-2005 at 01:53 PM.
 
Old 05-30-2005, 02:11 PM   #3
projectborn
LQ Newbie
 
Registered: May 2005
Distribution: Knoppix 3.8.1
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks for the quick reply. I think you are right: the changes were not saved. I actually typed "/sbin/lilo -v" but maybe the "-v" part is not needed or incorrect. I noted you said to type "/sbin/lilo" to save changes. Another thing which is confusing is when I edit the lilo.conf I am in an editing program, right? So after making the edit I would bring up a command line in a separate window and apply the changes? Thanks for the help.
 
Old 05-30-2005, 02:21 PM   #4
dcdbutler
Member
 
Registered: Jan 2005
Location: Boston
Distribution: slackware
Posts: 502

Rep: Reputation: 30
If the timeout is set for 50, that's 5 seconds. Isn't that long enough?

Also, you could try a different text editor which is easier to use than vi, such as nano or pico, as root.

# nano /etc/lilo.conf

Cheers
 
Old 05-30-2005, 02:25 PM   #5
scr
LQ Newbie
 
Registered: May 2005
Distribution: Slackware 10.1 / FreeBSD 5.4
Posts: 8

Rep: Reputation: 0
First of all, try using a simpler editor, like 'pico', it'll be a lot easier for you.
If you still want to use vi, edit the file like you did, and type :wq to save the changes & exit.
And no, you don't need another window to accomplish that.
Simply edit the config, save and exit.

About the command, there is nothing wrong with /sbin/lilo -v.
It'll simply increase lilo verbose, nothing you should be worried about.

The steps you should take are:
1. edit the lilo.conf file and save the changes ( i to edit and :wq to save & exit )
2. run as root: /sbin/lilo or /sbin/lilo -v, as you wish.
3. reboot
 
Old 05-30-2005, 02:28 PM   #6
projectborn
LQ Newbie
 
Registered: May 2005
Distribution: Knoppix 3.8.1
Posts: 5

Original Poster
Rep: Reputation: 0
5 seconds is pretty quick more so because I don't have experience with how to make a choice in the 5 seconds. I went back into the lilo.conf and now get the message that edit session crashed. I chose to recover but anyway I am in way over my head now! So, maybe I can get someone over to help me out. Thanks for the replies. My experience with command lines is very non-existent.
 
Old 05-30-2005, 03:08 PM   #7
scr
LQ Newbie
 
Registered: May 2005
Distribution: Slackware 10.1 / FreeBSD 5.4
Posts: 8

Rep: Reputation: 0
The first thing you should do, don't lose hope
Second, you won't learn all the stuff in one day, and feeling comfortable with command-line is crucial when working with *nix.

As dcdbutler and me told you, try getting a easier editor.
Try pico, maybe you already have it installed, so just use it.
If you have pico, edit the lilo.conf file like this:
pico /etc/lilo.conf, make your changes there, and press CONTROL+O to save, and CONTROL+X to exit.

Just follow the steps I wrote, and you'll be fine.
I couldn't quite understand what you wrote, you can't boot lilo anymore?
Please make your self clear, so we can help you more.

And to help you faster, please post your lilo.conf file here.
 
Old 05-30-2005, 03:23 PM   #8
projectborn
LQ Newbie
 
Registered: May 2005
Distribution: Knoppix 3.8.1
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks SCR. My problem was the LILO boot screen was booting Knoppix before I could make a choice to load XP. This is probably common knowledge but by hitting any key you can stop the timer. I didn't know this. I found it on the internet.
So, I can know choose which OS to load. I really appreciate the help you guys have given me.

Maybe one more question? Now that I can choose which OS to load I have three choices: 1) Linux 2)Linux 2.6 (I think) and 3)Win XP

Which is the Knoppix? Is it the 2.6? Sorry for being so ill-informed.
 
Old 05-30-2005, 03:34 PM   #9
scr
LQ Newbie
 
Registered: May 2005
Distribution: Slackware 10.1 / FreeBSD 5.4
Posts: 8

Rep: Reputation: 0
...

projectborn, I actually pointed out this problem, as I told you to check if "prompt" is present in your file.
About which one is Knoppix, I really can't help you since I never used Knoppix before.

But you can check by yourself, either by trying them, and check which one is Knoppix, or you can manually check by reading lilo.conf, and see which image does lilo load when you choose Linux or Linux 2.6.

When you've found out which one boots your knoppix correctly, you can remove the other instance, and stay only with two options


Enjoy your new system.
 
Old 05-30-2005, 04:00 PM   #10
projectborn
LQ Newbie
 
Registered: May 2005
Distribution: Knoppix 3.8.1
Posts: 5

Original Poster
Rep: Reputation: 0
You did mention "prompt" in your post, but I guess it slipped right by me. Anyway as a first time poster I have to say the advice is excellent. Thanks for your time. I'm sure I will have many more questions.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Where should i install LILO for Knoppix HD install? netneo Linux - Newbie 4 09-22-2005 07:59 PM
How to install lilo from knoppix JediMasterTux Linux - Newbie 3 12-19-2004 04:58 PM
Knoppix HD Install LILO Troubles With SATA Drive - HELP alpinewonder Debian 2 09-09-2004 01:38 PM
change lilo on knoppix install? FuriousGibbon Debian 1 09-08-2004 07:34 PM
No new kernel-option in LILO after editing lilo.conf corwax Debian 3 08-26-2003 09:55 PM


All times are GMT -5. The time now is 03:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration