LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-06-2001, 11:39 AM   #1
jamaso
Member
 
Registered: Oct 2001
Location: brasil
Distribution: mdrk 8.0,redht7.1,debianpotato
Posts: 615

Rep: Reputation: 30
Editing /etc/rc.d/rc. modules ?


Quote:
If you have it in a module then edit /etc/rc.d/rc. modules and uncomment the line that loads the sound driver.
1. I would like to know how do i edit the above , and how do i know which is the module of my sound card .

2. how do i uncomment a line ?

--------------------------------------------------------

Quote:
...you may need to alter the permissions on /dev/dsp,mixer and audio . If you can play sound as root but not as a normal user ...
1. I was told to use chmod to change permission



chmod a+w dsp
is this the right aproach? what should i do next ? I think my problem is the editing stuff . I see it all the time but still didn't find an easy explanation of how it works . Thanks
 
Old 12-06-2001, 03:23 PM   #2
taz.devil
Senior Member
 
Registered: Nov 2001
Location: Wa. State
Distribution: Slackware
Posts: 1,261

Rep: Reputation: 45
It's gonna depend on which distro you are using as to which file to edit. Slack uses rc.modules to load and unload modules. Others use /etc/modules.conf or so forth. Since you seem to use many different distros, which one are you trying to do this with?

When speeking of uncommenting a line it is speaking of removing the # (usually) in front of the module or code to load. For Example: (commented) #/sbin/modprobe emu10k1
(uncommented) /sbin/modprobe emu10k1

Using chmod changes the file permissions for any given file. Sometimes whenyou create a new user he won't hear sound, therefore you would have to set permission for him to use the applicable devices related to sound. The chmod a+w gives 'w'rite access to 'a'll. Type man chmod to get a grasp on how it works before deciding anything on it.

What is the name/brand/etc..of your sound card? That will tell you which driver you'll need to load/uncomment in the modules file. whn you know that and have the module loading, then you can worry about anything else IF it's even a problem.
 
Old 12-06-2001, 08:46 PM   #3
jamaso
Member
 
Registered: Oct 2001
Location: brasil
Distribution: mdrk 8.0,redht7.1,debianpotato
Posts: 615

Original Poster
Rep: Reputation: 30
I'm using Slackware 8 (2.2.9 version) . I'm not shure if this is the right info about my sound card, ( i guess it's onboard) i went to kde device manager and found this :

AC 97 Audio controller ( multimedia audio controller)


Is this the information needed ? thanks for the help .


PEACE
 
Old 12-06-2001, 11:02 PM   #4
taz.devil
Senior Member
 
Registered: Nov 2001
Location: Wa. State
Distribution: Slackware
Posts: 1,261

Rep: Reputation: 45
Quote:
Originally posted by jamaso
AC 97 Audio controller ( multimedia audio controller)
Yes, that's what you need to know. The modules as I said with Slack are loaded using /etc/rc.d/rc.modules So you'll want to edit that file, scroll down to audio support, then uncomment the line dealing with the AC97 Audio Codec. Save the file and make sure you have PNP BIOS set to NO in your BIOS. That'll save you alot of sound and other hassles. When you reboot, you should see the module loading, if you get an error, it may be that it's not built as a module in the kernel. That's probably not the case though on a new install. Try that and see what happens first and go from there.
 
Old 12-09-2001, 08:29 AM   #5
jamaso
Member
 
Registered: Oct 2001
Location: brasil
Distribution: mdrk 8.0,redht7.1,debianpotato
Posts: 615

Original Poster
Rep: Reputation: 30
This looks stupid but how can i actually edit a file ? I already tried emacs but i guess JOE is easier ( at least it looked simpler) . I know i'm not doing my "homework" but i've got very little time to study Linux . I already wrote the /etc/rc.d/rc.modules on th editor but NOTHING happend . I'm going now to disable the PNP BIOS and return . thanks
 
Old 12-09-2001, 11:32 AM   #6
jamaso
Member
 
Registered: Oct 2001
Location: brasil
Distribution: mdrk 8.0,redht7.1,debianpotato
Posts: 615

Original Poster
Rep: Reputation: 30
Pnp bios is disabled already. .
 
Old 12-09-2001, 01:08 PM   #7
taz.devil
Senior Member
 
Registered: Nov 2001
Location: Wa. State
Distribution: Slackware
Posts: 1,261

Rep: Reputation: 45
I sort of go against the grain when editing by not using the 'standard' editors like pico and vi/vim. By far, the easiest is jed. I think you'll be surprised how much easier editing a file is using this editor. So when you edited rc.modules, which file did you uncomment and does it load on startup? It should be in some of the last ten or so startup lines. If not sure, jed your /var/log/messages file and go to the bottom and look at the last startup and see. I believe that the emu10k1 module will work for the AC97 Codec for the on-board sound.
 
Old 12-09-2001, 02:50 PM   #8
jamaso
Member
 
Registered: Oct 2001
Location: brasil
Distribution: mdrk 8.0,redht7.1,debianpotato
Posts: 615

Original Poster
Rep: Reputation: 30
I went to jed and manage to see to see the sound support , found the module : #/sbin/modprob emu10k1


but it say the buffer is read only . How can i change that?
 
Old 12-09-2001, 06:11 PM   #9
taz.devil
Senior Member
 
Registered: Nov 2001
Location: Wa. State
Distribution: Slackware
Posts: 1,261

Rep: Reputation: 45
That's great to hear you found the module in rc.modules. All you have to do is remove the # sign to make the module load on startup. When is it and what is it that you've done to get the read-only buffer? That's could be easily file permissions in /dev if you are doing this as a user and not root. Try all this as root first.
 
Old 12-09-2001, 07:59 PM   #10
jamaso
Member
 
Registered: Oct 2001
Location: brasil
Distribution: mdrk 8.0,redht7.1,debianpotato
Posts: 615

Original Poster
Rep: Reputation: 30
After changing to root i did manage to uncomment asyou said . Went to the EDIT and "saved as" . I got the message of the lines it wrote to the file . what next ? I tried to use xmms but no sound . thanks
 
Old 12-09-2001, 08:32 PM   #11
jamaso
Member
 
Registered: Oct 2001
Location: brasil
Distribution: mdrk 8.0,redht7.1,debianpotato
Posts: 615

Original Poster
Rep: Reputation: 30
After rebooting the computer i got this lines :
Quote:
Creative emu10k1 pci audio driver , version 0.7........
Quote:
/lib/modules/2.2.9/misc/emu10k1 1.0 gz :init_module:device or resource busy
Quote:
................hint :insmod errors can be caused by incoreect module parameters incuding invalid I0 or irq parameters
Quote:
.............................................insmod /lib/modules/2.29/misc/emu10k1.o.gz failed
Quote:
...............................insmod emu10k1 failed
 
Old 12-09-2001, 08:42 PM   #12
jamaso
Member
 
Registered: Oct 2001
Location: brasil
Distribution: mdrk 8.0,redht7.1,debianpotato
Posts: 615

Original Poster
Rep: Reputation: 30
Sorry about the quoting .i think i was trying to do something else. Is there a way that i can record stuff like this , to show it as quote supposing it's quite often one needs to refer to outcoming messages like it ?
 
Old 12-11-2001, 06:41 AM   #13
jamaso
Member
 
Registered: Oct 2001
Location: brasil
Distribution: mdrk 8.0,redht7.1,debianpotato
Posts: 615

Original Poster
Rep: Reputation: 30
I tried /sbin/modprobe [driver-name] as you said to someone and got this :
Quote:
/lib/modules/2.2.9/misc/soundcore.0.gz:create_moduleperation not permited
" " " " :insmod/lib/modules/2.2.9/misc/soundcore.0.gz failed
" " " " :insmod emu10k1 failed
 
Old 12-11-2001, 10:08 AM   #14
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
You said you had onboard sound using the AC97 codec but the emu10k1 module is for the sound blaster live card, so the error would be because your loading the wrong module.
 
Old 12-11-2001, 04:02 PM   #15
jamaso
Member
 
Registered: Oct 2001
Location: brasil
Distribution: mdrk 8.0,redht7.1,debianpotato
Posts: 615

Original Poster
Rep: Reputation: 30
Hi i'm going to pass some information i got from my mother board manual


Quote:
Audio driver (optional) : Installthe necessary audio drivers and utilities to access the features of the built-in PCI audio chipset.

PS I had the this onboard card working with mandrake so i guess it would work on Slackware . Can i try all the other modules , and not damage anything ? thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
question about "sound support" and editing /etc/modules.conf 1sciroccofahrer Linux - Newbie 1 04-20-2005 04:31 PM
Editing modules.conf jatabe Linux - Networking 1 08-01-2003 02:47 AM
Slack9 - no PPP (can't open dependencies file /lib/modules/2.4.18/modules.dep) bluehz Slackware 1 05-04-2003 03:32 PM
Re: modprobe: Note: /etc/modules.conf is more recent than lib/modules/2.4.9/modules.d Andy.M Linux - General 1 01-24-2002 02:50 AM
Re: modprobe: Note: /etc/modules.conf is more recent than lib/modules/2.4.9/modules.d Andy.M Linux - Newbie 2 01-24-2002 02:40 AM


All times are GMT -5. The time now is 10:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration