LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-26-2009, 11:34 AM   #1
gNguyen
Member
 
Registered: Jul 2008
Distribution: FreeBSD, Slackware, Debian
Posts: 67

Rep: Reputation: 15
Easiest Way to Check for Librarys before Compiling


For instance when compiling an application there are some build requirements. Whats the easiest way to see if I have those installed. I am using Slackware.

Edit: Wow I spelled libraries wrong. I'm an idiot.

Last edited by gNguyen; 07-26-2009 at 11:37 AM.
 
Old 07-26-2009, 11:49 AM   #2
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,818
Blog Entries: 1

Rep: Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191
Isn't it the role of ./configure?
 
Old 07-26-2009, 11:58 AM   #3
gNguyen
Member
 
Registered: Jul 2008
Distribution: FreeBSD, Slackware, Debian
Posts: 67

Original Poster
Rep: Reputation: 15
But say for instance a build needs libglib2.0-dev >= 2.6 but 2.10+ is highly recommended.
 
Old 07-26-2009, 12:31 PM   #4
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,818
Blog Entries: 1

Rep: Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191Reputation: 1191
Have you got any particular problem compiling something specific or is it a general question?

Quote:
But say for instance a build needs libglib2.0-dev >= 2.6 but 2.10+ is highly recommended.
It's not that I've got any extensive experience with dependencies but I don't remember ever seeing anything like
it. If it says that 2.10+ is required then anything lower will fail. If it says that 2.0 is required, anything higher will
work as well. If the developers of a program decided that using 2.0 would make the program unstable or lacking some functionality, I assume they would completely abandon 2.0 support and clearly state that 2.10 is required.
Having said that, I'm not a developer so ...
 
Old 07-26-2009, 12:38 PM   #5
gNguyen
Member
 
Registered: Jul 2008
Distribution: FreeBSD, Slackware, Debian
Posts: 67

Original Poster
Rep: Reputation: 15
Just curious.
 
Old 07-26-2009, 12:57 PM   #6
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,085

Rep: Reputation: 398Reputation: 398Reputation: 398Reputation: 398
Quote:
Just curious.
.... should send you off here first.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to check that you have dependancies when compiling programs from source karuna-bdc Linux - Software 4 07-01-2009 06:55 AM
CPP Fails Sanity Check when compiling grapnell Linux - Software 4 08-16-2006 11:03 AM
Java librarys, Where are they?! Joe2003 Linux - Software 1 01-02-2006 07:14 AM
Librarys sir_aelurus Linux - Software 3 04-18-2003 09:10 PM
Librarys, What Where When Why? Micah Linux - Newbie 6 07-15-2002 08:16 PM


All times are GMT -5. The time now is 03:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration