Have you got any particular problem compiling something specific or is it a general question?
But say for instance a build needs libglib2.0-dev >= 2.6 but 2.10+ is highly recommended.
It's not that I've got any extensive experience with dependencies but I don't remember ever seeing anything like
it. If it says that 2.10+ is required then anything lower will fail. If it says that 2.0 is required, anything higher will
work as well. If the developers of a program decided that using 2.0 would make the program unstable or lacking some functionality, I assume they would completely abandon 2.0 support and clearly state that 2.10 is required.
Having said that, I'm not a developer so ...