LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 07-21-2013, 11:49 PM   #1
FortressMvelez
Member
 
Registered: May 2013
Location: Bronx, New York
Posts: 40

Rep: Reputation: Disabled
E-mail sends as user@localhost.domainname


Hello,

I have a dev server set up and this is what I was able to set up so far and have working:

Apache
MySQL
PHP
Dovecot
Postfix

When I send a e-mail to someone, my e-mail address shows up as user@localhost.dominename

I would like it to show up as user@domainname

I have postfix set up to use the system users and not users in a file or database for post fix. Could this be the reason? I have checked /etc/hosts and that seems fine. Not sure what else to do and I have been looking in google for a few days now and tried different things but nothing.

Thank you for any and all help!!!
 
Old 07-22-2013, 04:59 PM   #2
smallpond
Senior Member
 
Registered: Feb 2011
Location: Massachusetts, USA
Distribution: CentOS 6 (pre-systemd)
Posts: 1,773

Rep: Reputation: 454Reputation: 454Reputation: 454Reputation: 454Reputation: 454
Edit /etc/postfix/main.cf (after making a backup copy, of course)
Add:
Code:
masquerade_domains = example.com
Then restart postfix. This will change anything.example.com to example.com.
 
Old 07-22-2013, 07:32 PM   #3
FortressMvelez
Member
 
Registered: May 2013
Location: Bronx, New York
Posts: 40

Original Poster
Rep: Reputation: Disabled
Hello,

This has worked! Thank you so much for your help!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mail received at sendmail has relay=localhost [[UNIX: localhost]] check_rcpt fails chingupt Linux - Distributions 3 04-25-2013 06:36 PM
Evolution mail with Exchange server only sends mail.(don't recieve/download) knockout_artist Linux - Newbie 5 05-03-2012 04:42 PM
sendmail server just sends mail from localhost reneve59 Linux - Server 3 09-21-2007 10:32 PM
Mutt sends mail as root <> FatOldSun Linux - Software 1 08-17-2005 05:56 AM
postfix sends mail t X but not to Y? tethysgods Linux - Networking 4 09-09-2004 01:12 PM


All times are GMT -5. The time now is 07:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration